summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-10-26 22:58:47 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-10-26 22:58:47 +0000
commit6aa96ce96f205bcdeca8ab58d554fa392e3b0e7f (patch)
tree259c1713c5fb3ce74e4d0574fe33780356aba288 /app-mobilephone
parentStable for HPPA (bug #241644). (diff)
downloadgentoo-2-6aa96ce96f205bcdeca8ab58d554fa392e3b0e7f.tar.gz
gentoo-2-6aa96ce96f205bcdeca8ab58d554fa392e3b0e7f.tar.bz2
gentoo-2-6aa96ce96f205bcdeca8ab58d554fa392e3b0e7f.zip
fixed CC/CXX variable handling using tc-getCC/CXX, solving bug #243692.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/yaps/ChangeLog5
-rw-r--r--app-mobilephone/yaps/yaps-0.96-r2.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/app-mobilephone/yaps/ChangeLog b/app-mobilephone/yaps/ChangeLog
index 982f9eb87159..3ff57b3651e3 100644
--- a/app-mobilephone/yaps/ChangeLog
+++ b/app-mobilephone/yaps/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-mobilephone/yaps
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.19 2008/07/31 20:13:29 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.20 2008/10/26 22:58:47 sbriesen Exp $
+
+ 26 Oct 2008; Stefan Briesenick <sbriesen@gentoo.org> yaps-0.96-r2.ebuild:
+ fixed CC/CXX variable handling using tc-getCC/CXX, solving bug #243692.
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-mobilephone/yaps/yaps-0.96-r2.ebuild b/app-mobilephone/yaps/yaps-0.96-r2.ebuild
index edbb5165635e..53ea553572ed 100644
--- a/app-mobilephone/yaps/yaps-0.96-r2.ebuild
+++ b/app-mobilephone/yaps/yaps-0.96-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/yaps-0.96-r2.ebuild,v 1.3 2008/02/09 12:23:15 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/yaps-0.96-r2.ebuild,v 1.4 2008/10/26 22:58:47 sbriesen Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Yet Another Pager Software (optional with CAPI support)"
HOMEPAGE="ftp://sunsite.unc.edu/pub/Linux/apps/serialcomm/machines/"
@@ -41,7 +41,7 @@ src_compile() {
local myconf=""
use lua && myconf="${myconf} LUA=True"
use slang && myconf="${myconf} SLANG=True"
- emake CFLAGS="${CFLAGS}" ${myconf} || die "emake failed"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" ${myconf} || die "emake failed"
}
src_install() {