summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-11 16:06:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-11 16:06:31 +0000
commit7c893e448e4196104bcbac659e2602a4926c0562 (patch)
tree08d1e3a6088060e4ef0dc484021a92c1f74fc007 /app-mobilephone
parentSparc stable, fast stable for Bug #273577. (diff)
downloadgentoo-2-7c893e448e4196104bcbac659e2602a4926c0562.tar.gz
gentoo-2-7c893e448e4196104bcbac659e2602a4926c0562.tar.bz2
gentoo-2-7c893e448e4196104bcbac659e2602a4926c0562.zip
Split the broken part of the -gentoo patch out so that 0.23 is still source-identical; add a 0.23-r1 that fixes the Ruby bindings to actually do something useful, as per bug #273736.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/obexftp/ChangeLog13
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch13
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch22
-rw-r--r--app-mobilephone/obexftp/obexftp-0.23-r1.ebuild89
-rw-r--r--app-mobilephone/obexftp/obexftp-0.23.ebuild3
5 files changed, 115 insertions, 25 deletions
diff --git a/app-mobilephone/obexftp/ChangeLog b/app-mobilephone/obexftp/ChangeLog
index ee094e244dea..132a8bc3c84b 100644
--- a/app-mobilephone/obexftp/ChangeLog
+++ b/app-mobilephone/obexftp/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-mobilephone/obexftp
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.49 2009/05/02 08:12:42 mrness Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.50 2009/06/11 16:06:30 flameeyes Exp $
+
+*obexftp-0.23-r1 (11 Jun 2009)
+
+ 11 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> obexftp-0.23.ebuild,
+ +obexftp-0.23-r1.ebuild, +files/obexftp-0.23-fixruby.patch,
+ files/obexftp-0.23-gentoo.patch:
+ Split the broken part of the -gentoo patch out so that 0.23 is still
+ source-identical; add a 0.23-r1 that fixes the Ruby bindings to actually
+ do something useful, as per bug #273736.
02 May 2009; Alin Năstac <mrness@gentoo.org> obexftp-0.22.ebuild,
obexftp-0.23.ebuild:
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch b/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch
new file mode 100644
index 000000000000..473fb248cf1c
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch
@@ -0,0 +1,13 @@
+Index: obexftp-0.23/swig/ruby/Makefile.am
+===================================================================
+--- obexftp-0.23.orig/swig/ruby/Makefile.am
++++ obexftp-0.23/swig/ruby/Makefile.am
+@@ -12,7 +12,7 @@ Makefile.ruby: extconf.rb
+ PREFIX=$(prefix) $(RUBY) $< --with-obexftp-include=$(top_srcdir)
+
+ obexftp.so: ruby_wrap.c Makefile.ruby
+- $(MAKE) -fMakefile.ruby
++ $(MAKE) -fMakefile.ruby LIBPATH="-Wl,-rpath-link,../../bfb/.libs -Wl,-rpath-link,../../multicobex/.libs -Wl,-rpath-link,../../obexftp/.libs -L../../bfb/.libs -L../../multicobex/.libs -L../../obexftp/.libs"
+
+ install-data-local: Makefile.ruby
+ $(MAKE) -j1 -fMakefile.ruby install
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
index a9a70f79168d..b805bc6250f0 100644
--- a/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
@@ -22,25 +22,3 @@ diff -Nru obexftp-0.23.orig/apps/obexftp.c obexftp-0.23/apps/obexftp.c
#ifdef HAVE_SYS_TIMES_H
#include <sys/times.h>
#endif
-diff -Nru obexftp-0.23.orig/swig/ruby/extconf.rb obexftp-0.23/swig/ruby/extconf.rb
---- obexftp-0.23.orig/swig/ruby/extconf.rb 2009-02-17 18:27:48.000000000 +0000
-+++ obexftp-0.23/swig/ruby/extconf.rb 2009-03-22 16:19:56.000000000 +0000
-@@ -21,10 +21,6 @@
- end
-
- dir_config('obexftp')
--if have_library('openobex', 'OBEX_Init') and
-- find_library('bfb', 'bfb_io_open', '../../bfb/.libs') and
-- find_library('multicobex', 'cobex_ctrans', '../../multicobex/.libs') and
-- find_library('obexftp', 'obexftp_open', '../../obexftp/.libs')
- create_makefile('obexftp')
-
- # hack 2: strip all rpath references
-@@ -33,7 +29,3 @@
- out.puts line.gsub(/-Wl,-R'[^']*'/, '')
- end
- end
--else
-- puts 'obex libs not found'
--end
--
diff --git a/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild b/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild
new file mode 100644
index 000000000000..1f49ad1d22d8
--- /dev/null
+++ b/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild,v 1.1 2009/06/11 16:06:30 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils perl-module flag-o-matic python
+
+DESCRIPTION="File transfer over OBEX for mobile phones"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+SRC_URI="mirror://sourceforge/openobex/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="bluetooth debug perl python ruby swig tcl"
+
+RDEPEND="dev-libs/openobex
+ bluetooth? ( net-wireless/bluez )
+ perl? ( dev-lang/perl )
+ python? ( >=dev-lang/python-2.4.4 )
+ ruby? ( dev-lang/ruby:1.8 )
+ tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ swig? ( dev-lang/swig )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fixruby.patch
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_configure() {
+ # do not byte-compile python module
+ if use python; then
+ sed -i \
+ -e 's/\(setup.py install\)/\1 --no-compile/' \
+ swig/python/Makefile.in || die "sed failed"
+ fi
+
+ if use debug ; then
+ strip-flags
+ append-flags "-g -DOBEXFTP_DEBUG=5"
+ fi
+
+ local MYRUBY
+ use ruby && MYRUBY="RUBY=/usr/bin/ruby18"
+
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable swig) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable ruby) \
+ ${MYRUBY} || die "econf failed"
+}
+
+src_install() {
+ # -j1 because "make -fMakefile.ruby install" fails
+ # upstream added -j1 to that command so it should be removed
+ # from here in the next version bump
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
+ dohtml doc/*.html
+
+ # Install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ use perl && doins examples/*.pl
+ use python && doins examples/*.py
+ use ruby && doins examples/*.rb
+ use tcl && doins examples/*.tcl
+
+ use perl && fixlocalpod
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+ use python && python_mod_cleanup
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+ use python && {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ }
+}
diff --git a/app-mobilephone/obexftp/obexftp-0.23.ebuild b/app-mobilephone/obexftp/obexftp-0.23.ebuild
index 0bb2e7b67d2a..ef7498e648a5 100644
--- a/app-mobilephone/obexftp/obexftp-0.23.ebuild
+++ b/app-mobilephone/obexftp/obexftp-0.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23.ebuild,v 1.4 2009/05/02 08:12:42 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23.ebuild,v 1.5 2009/06/11 16:06:30 flameeyes Exp $
EAPI="2"
@@ -25,6 +25,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.22-ruby-libpath.patch
epatch "${FILESDIR}/${P}-gentoo.patch"
}