summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Silva <r3pek@gentoo.org>2006-01-10 14:55:58 +0000
committerCarlos Silva <r3pek@gentoo.org>2006-01-10 14:55:58 +0000
commite6f2b071f230c9e96eab44de77dab86fdd931e57 (patch)
tree6aada7a0728b6161419a92fa35ff4dc1fe5db8be /app-mobilephone
parentAdd dep on net-sftp (diff)
downloadgentoo-2-e6f2b071f230c9e96eab44de77dab86fdd931e57.tar.gz
gentoo-2-e6f2b071f230c9e96eab44de77dab86fdd931e57.tar.bz2
gentoo-2-e6f2b071f230c9e96eab44de77dab86fdd931e57.zip
Applied a fix to make moto4lin use LDFLAGS, CXXFLAGS and CFLAGS
(Portage version: 2.0.53)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/moto4lin/ChangeLog6
-rw-r--r--app-mobilephone/moto4lin/moto4lin-0.3.ebuild10
-rw-r--r--app-mobilephone/moto4lin/moto4lin-0.3_p20051125.ebuild10
3 files changed, 21 insertions, 5 deletions
diff --git a/app-mobilephone/moto4lin/ChangeLog b/app-mobilephone/moto4lin/ChangeLog
index 5276504fea59..ee1a3f4ab599 100644
--- a/app-mobilephone/moto4lin/ChangeLog
+++ b/app-mobilephone/moto4lin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/moto4lin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/moto4lin/ChangeLog,v 1.6 2006/01/09 14:21:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/moto4lin/ChangeLog,v 1.7 2006/01/10 14:55:58 r3pek Exp $
+
+ 10 Jan 2006; Carlos Silva <r3pek@gentoo.org> moto4lin-0.3.ebuild,
+ moto4lin-0.3_p20051125.ebuild:
+ Applied a fix to make moto4lin use LDFLAGS, CXXFLAGS and CFLAGS
09 Jan 2006; Caleb Tennis <caleb@gentoo.org> moto4lin-0.3.ebuild,
moto4lin-0.3_p20051125.ebuild:
diff --git a/app-mobilephone/moto4lin/moto4lin-0.3.ebuild b/app-mobilephone/moto4lin/moto4lin-0.3.ebuild
index 3fa5385e4343..56e5b63aa344 100644
--- a/app-mobilephone/moto4lin/moto4lin-0.3.ebuild
+++ b/app-mobilephone/moto4lin/moto4lin-0.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/moto4lin/moto4lin-0.3.ebuild,v 1.5 2006/01/09 14:21:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/moto4lin/moto4lin-0.3.ebuild,v 1.6 2006/01/10 14:55:58 r3pek Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Moto4lin is file manager and seem editor for Motorola P2K phones"
HOMEPAGE="http://moto4lin.sourceforge.net/"
@@ -20,7 +22,11 @@ src_compile() {
addwrite "${ROOT}/usr/qt/3/etc/settings"
${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake
- make || die "make failed"
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX)" \
+ LFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
diff --git a/app-mobilephone/moto4lin/moto4lin-0.3_p20051125.ebuild b/app-mobilephone/moto4lin/moto4lin-0.3_p20051125.ebuild
index d0a044b53a11..fc2efada7c9f 100644
--- a/app-mobilephone/moto4lin/moto4lin-0.3_p20051125.ebuild
+++ b/app-mobilephone/moto4lin/moto4lin-0.3_p20051125.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/moto4lin/moto4lin-0.3_p20051125.ebuild,v 1.3 2006/01/09 14:21:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/moto4lin/moto4lin-0.3_p20051125.ebuild,v 1.4 2006/01/10 14:55:58 r3pek Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Moto4lin is file manager and seem editor for Motorola P2K phones"
HOMEPAGE="http://moto4lin.sourceforge.net/"
@@ -20,7 +22,11 @@ src_compile() {
addwrite "${ROOT}/usr/qt/3/etc/settings"
${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake
- make || die "make failed"
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX)" \
+ LFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {