summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-12-14 23:43:55 +0000
committerMarinus Schraal <foser@gentoo.org>2003-12-14 23:43:55 +0000
commit41e48aa5c8f5e1b2950afa1682f9f0641e35ff4a (patch)
tree2dfba6bef21a7c9de4e351a658c53ec926e4f3d5 /app-office/abiword
parentnew release (diff)
downloadgentoo-2-41e48aa5c8f5e1b2950afa1682f9f0641e35ff4a.tar.gz
gentoo-2-41e48aa5c8f5e1b2950afa1682f9f0641e35ff4a.tar.bz2
gentoo-2-41e48aa5c8f5e1b2950afa1682f9f0641e35ff4a.zip
new release
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog9
-rw-r--r--app-office/abiword/Manifest6
-rw-r--r--app-office/abiword/abiword-2.0.2.ebuild103
-rw-r--r--app-office/abiword/files/digest-abiword-2.0.21
4 files changed, 115 insertions, 4 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index ac93a6ba5ed6..bce5ef9af910 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.55 2003/11/17 21:14:45 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.56 2003/12/14 23:43:50 foser Exp $
+
+*abiword-2.0.2 (15 Dec 2003)
+
+ 15 Dec 2003; foser <foser@gentoo.org> abiword-2.0.2.ebuild :
+ New release (#35832), minor dep fixes, add debug USE switch
+ remove the autogen stuff, doesn't seem to be needed anymore
+ plugins now moved into main pack
17 Nov 2003; <spider@gentoo.org> abiword-2.0.1.ebuild:
stable on x86
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index d4f242dad6b3..c08674c09026 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,8 +1,8 @@
MD5 81d41cc62b92ac1adba7924fa528c48a abiword-2.0.0.ebuild 2215
MD5 7921df3134ed60f1eb9c3d1c920bde16 abiword-1.0.6-r1.ebuild 1927
-MD5 03a7dadab979f0ce853f56565f663b18 abiword-2.0.2.ebuild 2180
-MD5 ed2c2c1f1b40577800331420a8927a86 abiword-2.0.1.ebuild 2169
-MD5 18d9d4f38e0d27305098b1ba48a59ed3 ChangeLog 8605
+MD5 1b8adf0df7d0c585d0c439f297fb71b4 abiword-2.0.2.ebuild 2249
+MD5 2605b704e6858360d51cfa871918960d abiword-2.0.1.ebuild 2163
+MD5 bc10e0f4d45fcad98ef74a3375f7d73c ChangeLog 8857
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 53a88ebee6a70ad41f3eb428b4a3a3e7 files/digest-abiword-2.0.0 142
MD5 28dcae4a10f58c12a4a73346a7ab1ed0 files/digest-abiword-2.0.1 142
diff --git a/app-office/abiword/abiword-2.0.2.ebuild b/app-office/abiword/abiword-2.0.2.ebuild
new file mode 100644
index 000000000000..6a6aa8a195f1
--- /dev/null
+++ b/app-office/abiword/abiword-2.0.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.2.ebuild,v 1.1 2003/12/14 23:43:50 foser Exp $
+
+inherit eutils
+
+IUSE="spell jpeg xml2 gnome debug"
+
+S=${WORKDIR}/${P}/abi
+S_P=${WORKDIR}/${P}/${PN}-plugins
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=media-libs/fontconfig-2.1
+ media-libs/libpng
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ ( xml2? >=dev-libs/libxml2-2.4.10 : dev-libs/expat )
+ spell? ( >=app-text/enchant-1 )
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprint-2.2.1
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libbonobo-2 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ dev-util/pkgconfig"
+
+# >=dev-libs/libole2-0.2.4-r1
+# perl? ( >=dev-lang/perl-5.6 )
+# perl seems broken
+
+src_compile() {
+
+# ./autogen.sh
+
+ # this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
+ # The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
+ cp configure configure.old
+ cat configure.old |sed s:-pedantic::g >configure
+ rm -f configure.old
+
+ econf \
+ `use_enable gnome` \
+ `use_with xml2 libxml2` \
+ `use_enable spell enchant` \
+ `use_enable debug` \
+ --enable-bidi \
+ --enable-threads \
+ --without-ImageMagick \
+ --disable-scripting \
+ --with-sys-wv || die
+
+ emake all-recursive || die
+
+ # Build plugins
+
+ cd ${S_P}
+
+# ./nextgen.sh
+ econf \
+ `use_enable debug` \
+ --enable-all \
+ --with-abiword=${S} \
+ --without-ImageMagick || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D} || die
+
+ dosed "s:Exec=abiword:Exec=abiword-2.0:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.0
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.0 /usr/bin/abiword-2.0
+
+ dodoc COPYING *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+
+ # install plugins
+
+ cd ${S_P}
+
+ make DESTDIR=${D} install || die
+
+}
diff --git a/app-office/abiword/files/digest-abiword-2.0.2 b/app-office/abiword/files/digest-abiword-2.0.2
new file mode 100644
index 000000000000..7888a5eef459
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.0.2
@@ -0,0 +1 @@
+MD5 bcb7b45b04e285d5a8b82fb13ebaa170 abiword-2.0.2.tar.bz2 22067405