summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-23 12:46:50 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-23 12:46:50 +0000
commitda6cc6d04217d807fcafe95ca1d6d0c0ef6e82e8 (patch)
tree3292081706237654895b2e269ceb21826d28d2fc /app-office/abiword
parentVirga is just a build dependency. (diff)
downloadgentoo-2-da6cc6d04217d807fcafe95ca1d6d0c0ef6e82e8.tar.gz
gentoo-2-da6cc6d04217d807fcafe95ca1d6d0c0ef6e82e8.tar.bz2
gentoo-2-da6cc6d04217d807fcafe95ca1d6d0c0ef6e82e8.zip
Use Arch patch to fix compilation with gcc-4.6 (bug #367865).
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog6
-rw-r--r--app-office/abiword/abiword-2.8.6-r1.ebuild11
-rw-r--r--app-office/abiword/files/abiword-2.8.6-gcc46.patch21
3 files changed, 33 insertions, 5 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 5254ce09c125..9bd545068ad4 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/abiword
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.247 2011/09/23 09:08:02 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.248 2011/09/23 12:46:50 pacho Exp $
+
+ 23 Sep 2011; Pacho Ramos <pacho@gentoo.org> abiword-2.8.6-r1.ebuild,
+ +files/abiword-2.8.6-gcc46.patch:
+ Use Arch patch to fix compilation with gcc-4.6 (bug #367865).
23 Sep 2011; Lars Wendler <polynomial-c@gentoo.org>
files/abiword-2.8.6-libpng15.patch:
diff --git a/app-office/abiword/abiword-2.8.6-r1.ebuild b/app-office/abiword/abiword-2.8.6-r1.ebuild
index ae94b7a790c8..72e829894b82 100644
--- a/app-office/abiword/abiword-2.8.6-r1.ebuild
+++ b/app-office/abiword/abiword-2.8.6-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.8.6-r1.ebuild,v 1.11 2011/08/07 08:59:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.8.6-r1.ebuild,v 1.12 2011/09/23 12:46:50 pacho Exp $
EAPI="3"
-inherit alternatives eutils gnome2 versionator
+inherit alternatives eutils gnome2 versionator autotools
MY_MAJORV=$(get_version_component_range 1-2)
@@ -117,16 +117,19 @@ src_configure() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-libpng15.patch
-
gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+
# install icon to pixmaps (bug #220097)
sed 's:$(datadir)/icons:$(datadir)/pixmaps:' \
-i Makefile.am Makefile.in || die "sed 1 failed"
# readme.txt will be installed using dodoc
sed '/readme\.txt\|abw/d' \
-i user/wp/Makefile.am user/wp/Makefile.in || die "sed 2 failed"
+
+ eautoreconf
}
src_install() {
diff --git a/app-office/abiword/files/abiword-2.8.6-gcc46.patch b/app-office/abiword/files/abiword-2.8.6-gcc46.patch
new file mode 100644
index 000000000000..c07000edbfa3
--- /dev/null
+++ b/app-office/abiword/files/abiword-2.8.6-gcc46.patch
@@ -0,0 +1,21 @@
+diff -u -r abiword-2.8.6.orig/src/Makefile.am abiword-2.8.6/src/Makefile.am
+--- abiword-2.8.6.orig/src/Makefile.am 2009-09-09 15:11:01.000000000 +0200
++++ abiword-2.8.6/src/Makefile.am 2011-08-02 23:35:51.904761961 +0200
+@@ -107,7 +107,7 @@
+
+ AbiWord_LDFLAGS = \
+ $(DEPS_LIBS) \
+- --no-undefined \
++ -Wl,--no-undefined \
+ -avoid-version \
+ -export-dynamic \
+ -headerpad_max_install_names
+@@ -129,7 +129,7 @@
+
+ abiword_LDFLAGS = \
+ $(platform_ldflags) \
+- --no-undefined \
++ -Wl,--no-undefined \
+ -avoid-version \
+ -export-dynamic
+