summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2013-03-04 19:11:06 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2013-03-04 19:11:06 +0000
commit343ade52e3da6b33410b4f91bd81408b7dfec647 (patch)
tree6ad80a2653e838a6cbf6126b3a68af54f1f05a64 /app-office/akonadi-server
parentMySQL 5.6 needs to NOT have -fno-implicit-templates, also support epatch_user. (diff)
downloadgentoo-2-343ade52e3da6b33410b4f91bd81408b7dfec647.tar.gz
gentoo-2-343ade52e3da6b33410b4f91bd81408b7dfec647.tar.bz2
gentoo-2-343ade52e3da6b33410b4f91bd81408b7dfec647.zip
Version bump
(Portage version: 2.2.0_alpha165/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog8
-rw-r--r--app-office/akonadi-server/akonadi-server-1.9.1.ebuild113
2 files changed, 120 insertions, 1 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index cdfb2dcd6091..568dc879be5c 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.100 2013/03/02 19:34:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.101 2013/03/04 19:11:06 mschiff Exp $
+
+*akonadi-server-1.9.1 (04 Mar 2013)
+
+ 04 Mar 2013; Marc Schiffbauer <mschiff@gentoo.org>
+ +akonadi-server-1.9.1.ebuild:
+ Version bump
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org>
akonadi-server-1.8.0.ebuild, akonadi-server-1.8.1.ebuild,
diff --git a/app-office/akonadi-server/akonadi-server-1.9.1.ebuild b/app-office/akonadi-server/akonadi-server-1.9.1.ebuild
new file mode 100644
index 000000000000..32cfec9c3fa7
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.9.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.1.ebuild,v 1.1 2013/03/04 19:11:06 mschiff Exp $
+
+EAPI=4
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="git://anongit.kde.org/akonadi"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://kde/stable/${PN/-server/}/src/${P/-server/}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${P/-server/}"
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+mysql postgres sqlite test"
+
+CDEPEND="
+ dev-libs/boost
+ >=dev-libs/soprano-2.6.51
+ >=dev-qt/qtgui-4.5.0:4[dbus]
+ >=dev-qt/qtsql-4.5.0:4[mysql?,postgres?]
+ >=dev-qt/qttest-4.5.0:4
+ x11-misc/shared-mime-info
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+"
+RDEPEND="${CDEPEND}
+ postgres? ( dev-db/postgresql-server )
+"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/${P}-qt5.patch" )
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about driver name change
+ if use sqlite && has_version "<=${CATEGORY}/${PN}-1.4.0[sqlite]"; then
+ ewarn
+ ewarn "SQLite driver name changed from QSQLITE to QSQLITE3."
+ ewarn "Please edit your ~/.config/akonadi/akonadiserverrc."
+ fi
+
+ # Notify about MySQL not being default anymore
+ if ! use sqlite && has_version "<=${CATEGORY}/${PN}-1.9.0[sqlite]"; then
+ ewarn
+ ewarn "The default storage drive has changed from SQLite to MySQL."
+ ewarn "If you want to stay with SQLite, enable the sqlite USE flag and reinstall"
+ ewarn "${CATEGORY}/${PN}."
+ ewarn "Otherwise, select a different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAKONADI_USE_STRIGI_SEARCH=OFF
+ -DWITH_QT5=OFF
+ $(cmake-utils_use test AKONADI_BUILD_TESTS)
+ $(cmake-utils_use sqlite AKONADI_BUILD_QSQLITE)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ echo
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}