summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 05:25:08 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 05:25:08 +0000
commitf64ab4da2c9ca24d922de295b06cf83f8df57dde (patch)
tree337e87a33bb3bc87bd984a7c8b03ebdf4197e680 /app-office/akonadi-server
parentversion bump, kde 4.3 dep (diff)
downloadgentoo-2-f64ab4da2c9ca24d922de295b06cf83f8df57dde.tar.gz
gentoo-2-f64ab4da2c9ca24d922de295b06cf83f8df57dde.tar.bz2
gentoo-2-f64ab4da2c9ca24d922de295b06cf83f8df57dde.zip
version bump. kde 4.3 dep.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog8
-rw-r--r--app-office/akonadi-server/akonadi-server-1.2.0.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index 07c5e536c917..386e3bd122cb 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.15 2009/07/22 23:33:35 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.16 2009/08/04 05:25:08 wired Exp $
+
+*akonadi-server-1.2.0 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org>
+ +akonadi-server-1.2.0.ebuild:
+ version bump. kde 4.3 dep.
22 Jul 2009; Alex Alexander <wired@gentoo.org>
akonadi-server-1.1.2.ebuild:
diff --git a/app-office/akonadi-server/akonadi-server-1.2.0.ebuild b/app-office/akonadi-server/akonadi-server-1.2.0.ebuild
new file mode 100644
index 000000000000..6ddf80eba71b
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.2.0.ebuild,v 1.1 2009/08/04 05:25:08 wired Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+SRC_URI="http://download.akonadi-project.org/${P/-server/}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="+mysql sqlite"
+
+RDEPEND="
+ dev-libs/boost
+ >=dev-libs/soprano-2.2
+ >=x11-libs/qt-core-4.5.0:4
+ >=x11-libs/qt-dbus-4.5.0:4
+ >=x11-libs/qt-sql-4.5.0:4[mysql?,sqlite?]
+ x11-misc/shared-mime-info
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=kde-base/automoc-0.9.88
+"
+
+S="${WORKDIR}/${P/-server/}"
+
+src_install() {
+ # Set default storage backend in order: mysql, sqlite
+ if use mysql; then
+ driver="QMYSQL"
+ elif use sqlite; then
+ driver="QSQLITE"
+ fi
+ # Who knows, maybe it accidentally fixes our permission issues
+ mkdir -p "${D}"/usr/share/config/akonadi || die "mkdir failed"
+ cat <<-EOF > "${D}"/usr/share/config/akonadi/akonadiserverrc
+[%General]
+Driver=${driver}
+EOF
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ if use mysql || use sqlite; then
+ echo
+ elog "${driver} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are:"
+ elog "QMYSQL, QSQLITE (experimental)"
+ elog "Note that QMYSQL is the one fully tested and officially supported."
+ echo
+ else
+ echo
+ ewarn "You have decided to build akonadi-server with both"
+ ewarn "'mysql' and 'sqlite' USE flags disabled."
+ ewarn "akonadi-server will not be functional."
+ echo
+ fi
+}