summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-20 17:58:57 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-20 17:58:57 +0000
commit2e5225e280c1c233a8d71f3e67e28ea406ac6721 (patch)
tree2f773508654b8824c76c1d4d3ae043ace4f04d04 /app-office/calligra-l10n
parentMask not-yet-released calligra (diff)
downloadgentoo-2-2e5225e280c1c233a8d71f3e67e28ea406ac6721.tar.gz
gentoo-2-2e5225e280c1c233a8d71f3e67e28ea406ac6721.tar.bz2
gentoo-2-2e5225e280c1c233a8d71f3e67e28ea406ac6721.zip
Version bump
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'app-office/calligra-l10n')
-rw-r--r--app-office/calligra-l10n/ChangeLog8
-rw-r--r--app-office/calligra-l10n/calligra-l10n-2.3.84.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/app-office/calligra-l10n/ChangeLog b/app-office/calligra-l10n/ChangeLog
index b46c6988e2ff..49e64b8f92ff 100644
--- a/app-office/calligra-l10n/ChangeLog
+++ b/app-office/calligra-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/calligra-l10n
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.4 2011/10/29 17:56:47 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.5 2011/11/20 17:58:57 dilfridge Exp $
+
+*calligra-l10n-2.3.84 (20 Nov 2011)
+
+ 20 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +calligra-l10n-2.3.84.ebuild:
+ Version bump
*calligra-l10n-2.3.83 (29 Oct 2011)
diff --git a/app-office/calligra-l10n/calligra-l10n-2.3.84.ebuild b/app-office/calligra-l10n/calligra-l10n-2.3.84.ebuild
new file mode 100644
index 000000000000..e7825153fede
--- /dev/null
+++ b/app-office/calligra-l10n/calligra-l10n-2.3.84.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/calligra-l10n-2.3.84.ebuild,v 1.1 2011/11/20 17:58:57 dilfridge Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Calligra localization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+MY_LANGS="ca ca@valencia cs da de el en_GB es et fr it kk nb nds nl pl pt pt_BR ru sv uk zh_TW"
+URI_BASE="mirror://kde/unstable/${PN/-l10n/}-${PV}/${PN}/"
+SRC_URI=""
+SLOT="4"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+unset MY_LANG
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)
+ )
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}