summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-12-18 03:21:41 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-12-18 03:21:41 +0000
commitde4cf35ef69d95e9d370833293a3b22e4bab6b40 (patch)
treee252cebd217640d6342cd73e8ef9eab063f0a0ef /app-office/gnucash
parentNew version of the incredible pwm (diff)
downloadgentoo-2-de4cf35ef69d95e9d370833293a3b22e4bab6b40.tar.gz
gentoo-2-de4cf35ef69d95e9d370833293a3b22e4bab6b40.tar.bz2
gentoo-2-de4cf35ef69d95e9d370833293a3b22e4bab6b40.zip
updated to 1.6.5
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.6.51
-rw-r--r--app-office/gnucash/gnucash-1.6.4.ebuild5
-rw-r--r--app-office/gnucash/gnucash-1.6.5.ebuild49
3 files changed, 54 insertions, 1 deletions
diff --git a/app-office/gnucash/files/digest-gnucash-1.6.5 b/app-office/gnucash/files/digest-gnucash-1.6.5
new file mode 100644
index 000000000000..e0ccfc97e4dc
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.6.5
@@ -0,0 +1 @@
+MD5 1d711b754fa533b9ee2c4865a2ef9fac gnucash-1.6.5.tar.gz 14000128
diff --git a/app-office/gnucash/gnucash-1.6.4.ebuild b/app-office/gnucash/gnucash-1.6.4.ebuild
index f8a0bf8ab0b9..a8d2b87a9001 100644
--- a/app-office/gnucash/gnucash-1.6.4.ebuild
+++ b/app-office/gnucash/gnucash-1.6.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.4.ebuild,v 1.1 2001/10/07 10:48:59 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.4.ebuild,v 1.2 2001/12/18 03:21:41 hallski Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A personal finance manager"
@@ -43,4 +43,7 @@ src_install () {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+
}
+
diff --git a/app-office/gnucash/gnucash-1.6.5.ebuild b/app-office/gnucash/gnucash-1.6.5.ebuild
new file mode 100644
index 000000000000..60154930b08e
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.6.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.5.ebuild,v 1.1 2001/12/18 03:21:41 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A personal finance manager"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gnucash.sourceforge.net"
+
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.10
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-base/gnome-print-0.30
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/slib-2.3.8
+ >=dev-libs/g-wrap-1.1.5
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ $myconf || die
+
+ make || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+
+}
+