summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-09 22:45:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-09 22:45:32 +0000
commit4946d37988e2ce40c6dd36dbb9cac05c68f1406d (patch)
treecafefaf8668ac3a1d6adec7fcf6946c3834b6678 /app-office/gnumeric
parentamd64/x86 stable, bug #261142 (diff)
downloadgentoo-2-4946d37988e2ce40c6dd36dbb9cac05c68f1406d.tar.gz
gentoo-2-4946d37988e2ce40c6dd36dbb9cac05c68f1406d.tar.bz2
gentoo-2-4946d37988e2ce40c6dd36dbb9cac05c68f1406d.zip
Bump to 1.8.4-r1. Fix for CVE-2009-0318, bug #257012.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/ChangeLog8
-rw-r--r--app-office/gnumeric/files/gnumeric-1.8.4-CVE-2009-0318.patch17
-rw-r--r--app-office/gnumeric/gnumeric-1.8.4-r1.ebuild90
3 files changed, 114 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 463278d3c2ee..22fff1ac1979 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.177 2009/01/26 21:54:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.178 2009/03/09 22:45:32 eva Exp $
+
+*gnumeric-1.8.4-r1 (09 Mar 2009)
+
+ 09 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gnumeric-1.8.4-CVE-2009-0318.patch, +gnumeric-1.8.4-r1.ebuild:
+ Bump to 1.8.4-r1. Fix for CVE-2009-0318, bug #257012.
*gnumeric-1.8.4 (26 Jan 2009)
diff --git a/app-office/gnumeric/files/gnumeric-1.8.4-CVE-2009-0318.patch b/app-office/gnumeric/files/gnumeric-1.8.4-CVE-2009-0318.patch
new file mode 100644
index 000000000000..a4889ce4909e
--- /dev/null
+++ b/app-office/gnumeric/files/gnumeric-1.8.4-CVE-2009-0318.patch
@@ -0,0 +1,17 @@
+#
+# Jon Kåre:
+# * Work around vulnerability in Python. CVE-2009-0318 [#569648]
+#
+# https://bugs.gentoo.org/show_bug.cgi?id=257012
+# https://bugzilla.redhat.com/show_bug.cgi?id=481572
+--- branches/gnumeric-1-8/plugins/python-loader/gnm-py-interpreter.c 2009/01/29 14:08:41 17110
++++ branches/gnumeric-1-8/plugins/python-loader/gnm-py-interpreter.c 2009/01/29 14:33:02 17111
+@@ -79,7 +79,7 @@
+ G_TYPE_NONE, 0);
+ }
+
+-static char *plugin_argv[] = {(char *) "gnumeric", NULL};
++static char *plugin_argv[] = {(char *) "/dev/null/python/is/buggy/gnumeric", NULL};
+
+ GnmPyInterpreter *
+ gnm_py_interpreter_new (GOPlugin *plugin)
diff --git a/app-office/gnumeric/gnumeric-1.8.4-r1.ebuild b/app-office/gnumeric/gnumeric-1.8.4-r1.ebuild
new file mode 100644
index 000000000000..5e12beb7f6ea
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.8.4-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.8.4-r1.ebuild,v 1.1 2009/03/09 22:45:32 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 flag-o-matic python
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="gnome perl python"
+# bonobo guile libgda mono (experimental)
+
+# lots of missing files, wait for next release
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.6
+ >=gnome-extra/libgsf-1.14.6[gnome]
+ >=x11-libs/goffice-0.6.3
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+
+ >=x11-libs/gtk+-2.10
+ x11-libs/cairo[svg]
+ >=gnome-base/libglade-2.3.6
+ >=media-libs/libart_lgpl-2.3.11
+
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2 )
+ perl? ( dev-lang/perl )
+ python? (
+ >=dev-lang/python-2
+ >=dev-python/pygtk-2 )"
+ # libgda? (
+ # >=gnome-extra/libgda-3.1.1
+ # >=gnome-extra/libgnomedb-3.0.1 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.18
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ local will_die=false
+
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --enable-static
+ --without-gda
+ --without-guile
+ --without-mono
+ $(use_with perl)
+ $(use_with python)
+ $(use_with gnome)"
+
+ # gcc bug (http://bugs.gnome.org/show_bug.cgi?id=128834)
+ replace-flags "-Os" "-O2"
+}
+
+src_prepare() {
+ # Fix for CVE-2009-0318, bug #257012
+ epatch "${FILESDIR}/${P}-CVE-2009-0318.patch"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # make gnumeric find its help
+ dosym \
+ /usr/share/gnome/help/gnumeric \
+ /usr/share/${PN}/${PV}/doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}