summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:36:55 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:36:55 +0000
commit64ad903f022d3e1828c9244814d4c005981839bf (patch)
treeaff01ee870b4bcc852a15c102af0e17f8c597f99 /app-office/kplato
parentRe-added the database management application of koffice (diff)
downloadgentoo-2-64ad903f022d3e1828c9244814d4c005981839bf.tar.gz
gentoo-2-64ad903f022d3e1828c9244814d4c005981839bf.tar.bz2
gentoo-2-64ad903f022d3e1828c9244814d4c005981839bf.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-office/kplato')
-rw-r--r--app-office/kplato/ChangeLog8
-rw-r--r--app-office/kplato/kplato-2.2.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/app-office/kplato/ChangeLog b/app-office/kplato/ChangeLog
index 9503e95d16aa..e56324e6067e 100644
--- a/app-office/kplato/ChangeLog
+++ b/app-office/kplato/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kplato
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/ChangeLog,v 1.76 2010/03/31 21:47:28 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/ChangeLog,v 1.77 2010/09/25 20:36:55 dilfridge Exp $
+
+*kplato-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kplato-2.2.2.ebuild:
+ Version bump
*kplato-2.1.2 (31 Mar 2010)
diff --git a/app-office/kplato/kplato-2.2.2.ebuild b/app-office/kplato/kplato-2.2.2.ebuild
new file mode 100644
index 000000000000..847476a4eeae
--- /dev/null
+++ b/app-office/kplato/kplato-2.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/kplato-2.2.2.ebuild,v 1.1 2010/09/25 20:36:55 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KPlato is a project management application."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="~app-office/kchart-${PV}:${SLOT}[reports]"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libs/"
+KMEXTRA="
+ filters/${KMMODULE}/
+ kdgantt/
+"
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ -DBUILD_kplato=ON
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}