summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-16 11:34:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-16 11:34:16 +0000
commitadda7a01de8f2195fe86cd2d36a72bd7f297b12a (patch)
tree6f10fce4e827b8b7a44f17ddf013deb563c0622c /app-office/kspread
parentBump to 1.6.2 pre-release. (diff)
downloadgentoo-2-adda7a01de8f2195fe86cd2d36a72bd7f297b12a.tar.gz
gentoo-2-adda7a01de8f2195fe86cd2d36a72bd7f297b12a.tar.bz2
gentoo-2-adda7a01de8f2195fe86cd2d36a72bd7f297b12a.zip
Bump to 1.6.2 pre-release.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-office/kspread')
-rw-r--r--app-office/kspread/ChangeLog7
-rw-r--r--app-office/kspread/files/digest-kspread-1.6.23
-rw-r--r--app-office/kspread/kspread-1.6.2.ebuild64
3 files changed, 73 insertions, 1 deletions
diff --git a/app-office/kspread/ChangeLog b/app-office/kspread/ChangeLog
index ded824694229..632454b6cf04 100644
--- a/app-office/kspread/ChangeLog
+++ b/app-office/kspread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kspread
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.72 2007/02/15 00:57:59 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.73 2007/02/16 11:34:16 flameeyes Exp $
+
+*kspread-1.6.2 (16 Feb 2007)
+
+ 16 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> +kspread-1.6.2.ebuild:
+ Bump to 1.6.2 pre-release.
15 Feb 2007; Bryan Østergaard <kloeri@gentoo.org> kspread-1.6.1.ebuild:
Stable on Alpha, bug 166246.
diff --git a/app-office/kspread/files/digest-kspread-1.6.2 b/app-office/kspread/files/digest-kspread-1.6.2
new file mode 100644
index 000000000000..cfd7d14fcad4
--- /dev/null
+++ b/app-office/kspread/files/digest-kspread-1.6.2
@@ -0,0 +1,3 @@
+MD5 74ef62a5f8f766fe8192d5b7d65a3928 koffice-1.6.2.tar.bz2 57049103
+RMD160 fb4ef5870870d80481a4a9d2864199428f495460 koffice-1.6.2.tar.bz2 57049103
+SHA256 fa5ca02eba02219d34c3c6efff92bf767060b4b1343da56eb63139661d53f380 koffice-1.6.2.tar.bz2 57049103
diff --git a/app-office/kspread/kspread-1.6.2.ebuild b/app-office/kspread/kspread-1.6.2.ebuild
new file mode 100644
index 000000000000..8c3f02323be6
--- /dev/null
+++ b/app-office/kspread/kspread-1.6.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/kspread-1.6.2.ebuild,v 1.1 2007/02/16 11:34:16 flameeyes Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice spreadsheet application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange $PV $MAXKOFFICEVER app-office/kchart)
+ $(deprange $PV $MAXKOFFICEVER app-office/kexi)"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkochart interfaces
+ libkrossmain lib/kross/main
+ libkrossapi lib/kross/api
+ libkexidb kexi/kexidb
+ libkexidbparser kexi/kexidb/parser"
+
+KMEXTRACTONLY="lib/
+ interfaces/
+ filters/kexi
+ kexi/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kspread"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter kspread" > ${S}/filters/Makefile.am
+
+ # Work around broken conditional
+ echo "SUBDIRS = applixspread csv dbase gnumeric latex opencalc html qpro excel kexi" > ${S}/filters/kspread/Makefile.am
+
+ for i in $(find ${S}/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}