summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-01 20:29:43 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-01 20:29:43 +0000
commit18f05b5b5fec3e1ce85432aca6c2e2a425dd0e96 (patch)
treed8b109c1a5662a3fd1ed7b1a53dcebd79f849b58 /app-office/lyx
parentsnapshot update, marked previous version stable (diff)
downloadgentoo-2-18f05b5b5fec3e1ce85432aca6c2e2a425dd0e96.tar.gz
gentoo-2-18f05b5b5fec3e1ce85432aca6c2e2a425dd0e96.tar.bz2
gentoo-2-18f05b5b5fec3e1ce85432aca6c2e2a425dd0e96.zip
touchups ... $DEBUG -> use debug
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/lyx-1.2.1.ebuild32
-rw-r--r--app-office/lyx/lyx-1.3.2-r1.ebuild28
-rw-r--r--app-office/lyx/lyx-1.3.2.ebuild31
3 files changed, 44 insertions, 47 deletions
diff --git a/app-office/lyx/lyx-1.2.1.ebuild b/app-office/lyx/lyx-1.2.1.ebuild
index 24d6d1cbba31..d480b4dc8684 100644
--- a/app-office/lyx/lyx-1.2.1.ebuild
+++ b/app-office/lyx/lyx-1.2.1.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.1.ebuild,v 1.13 2003/06/09 17:38:03 satai Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.1.ebuild,v 1.14 2003/08/01 20:29:43 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="WYSIWYM frontend for LaTeX"
-SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc"
-IUSE="nls cups"
+IUSE="nls cups debug"
# This lyx-base ebuild only depends on the absolutely necessary packages.
# The acompanying lyx-utils ebuild depends on lyx-base and on everything
@@ -35,18 +37,14 @@ RDEPEND="${DEPEND}
dev-tex/chktex"
src_compile() {
- use nls || myconf="${myconf} --disable-nls"
- [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
-
- # -O3 and higher breaks
- export CXXFLAGS="${CXXFLAGS//-O[3..9]/-O2}"
- export CFLAGS="${CFLAGS//-O[3..9]/-O2}"
-
- export WANT_AUTOCONF_2_5=1
-
+ replace-flags -O? -O2
+ #export WANT_AUTOCONF_2_5=1
#./autogen.sh
-
- econf ${myconf}
+
+ econf \
+ `use_enable nls` \
+ `use_enable debug` \
+ || die
#--infodir='$(prefix)/share/info' \
#--with-extra-inc=/usr/X11R6/include \
#--mandir='$(prefix)/share/man' \
@@ -57,6 +55,6 @@ src_install() {
# The 'install-strip' target is provided by the LyX makefile
# for stripping installed binaries. Use prefix= instead of
# DESTDIR=, otherwise it violates the sandbox in the po directory.
- einstall
- dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE ABOUT-NLS
+ einstall || die
+ dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE
}
diff --git a/app-office/lyx/lyx-1.3.2-r1.ebuild b/app-office/lyx/lyx-1.3.2-r1.ebuild
index 7abad57e9be0..c325f84ef732 100644
--- a/app-office/lyx/lyx-1.3.2-r1.ebuild
+++ b/app-office/lyx/lyx-1.3.2-r1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2-r1.ebuild,v 1.1 2003/06/11 09:17:43 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2-r1.ebuild,v 1.2 2003/08/01 20:29:43 vapier Exp $
DESCRIPTION="WYSIWYM frontend for LaTeX"
+HOMEPAGE="http://www.lyx.org/"
SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
http://www.math.tau.ac.il/~dekelts/lyx/files/preferences"
-HOMEPAGE="http://www.lyx.org/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha"
-IUSE="nls cups qt"
+IUSE="nls cups qt debug"
DEPEND="virtual/x11
app-text/tetex
@@ -40,23 +40,26 @@ src_unpack() {
}
src_compile() {
- use nls || myconf="${myconf} --disable-nls"
- if [ -n "`use qt`" ]; then
+ local myconf=""
+ if [ `use qt` ]; then
inherit kde-functions
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
myconf="$myconf --with-frontend=xforms"
fi
- [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
export WANT_AUTOCONF_2_5=1
- flags="${CFLAGS}"
+ local flags="${CFLAGS}"
unset CFLAGS
unset CXXFLAGS
- econf ${myconf} --enable-optimization="$flags"
-
+ econf \
+ `use_enable nls` \
+ `use_enable debug` \
+ ${myconf} \
+ --enable-optimization="$flags" \
+ || die
emake || die "emake failed"
}
@@ -69,8 +72,7 @@ src_install() {
}
pkg_postinst() {
-
- if [ -n "`use qt`" ]; then
+ if [ `use qt` ] ; then
einfo "WARNING: the QT gui, together with xft2+fontconfig (which you"
einfo "almost certainly have), suffer from one infamous bug that causes"
einfo "the matheditor not to display any special characters (the ones from"
@@ -95,6 +97,4 @@ pkg_postinst() {
einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
einfo "for instructions on using lyx's own preferences dialog to equal effect."
einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
-
}
-
diff --git a/app-office/lyx/lyx-1.3.2.ebuild b/app-office/lyx/lyx-1.3.2.ebuild
index cc56733f8e92..6496744ddef0 100644
--- a/app-office/lyx/lyx-1.3.2.ebuild
+++ b/app-office/lyx/lyx-1.3.2.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2.ebuild,v 1.3 2003/07/02 11:45:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2.ebuild,v 1.4 2003/08/01 20:29:43 vapier Exp $
DESCRIPTION="WYSIWYM frontend for LaTeX"
-SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2"
HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~alpha"
-IUSE="nls cups qt"
+IUSE="nls cups qt debug"
DEPEND="virtual/x11
app-text/tetex
@@ -38,35 +38,36 @@ src_unpack() {
}
src_compile() {
- use nls || myconf="${myconf} --disable-nls"
- if [ -n "`use qt`" ]; then
+ local myconf=""
+ if [ `use qt` ]; then
inherit kde-functions
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
myconf="$myconf --with-frontend=xforms"
fi
- [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
export WANT_AUTOCONF_2_5=1
- flags="${CFLAGS}"
+ local flags="${CFLAGS}"
unset CFLAGS
unset CXXFLAGS
- econf ${myconf} --enable-optimization="$flags"
-
+ econf \
+ `use_enable nls` \
+ `use_enable debug` \
+ ${myconf} \
+ --enable-optimization="$flags" \
+ || die
emake || die "emake failed"
-
}
src_install() {
einstall
- dodoc README* UPGRADING INSTALL* ChangeLog NEWS COPYING ANNOUNCE ABOUT-NLS
+ dodoc README* UPGRADING INSTALL* ChangeLog NEWS COPYING ANNOUNCE
}
pkg_postinst() {
-
- if [ -n "`use qt`" ]; then
+ if [ `use qt` ] ; then
einfo "WARNING: the QT gui, together with xft2+fontconfig (which you"
einfo "almost certainly have), suffer from one infamous bug that causes"
einfo "the matheditor not to display any special characters (the ones from"
@@ -81,6 +82,4 @@ pkg_postinst() {
einfo "fonts package derived from bluesky (see the recent threads on the"
einfo "lyx-devel mailing list about this if you want to know more)."
fi
-
}
-