summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-12 13:11:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-12 13:11:45 +0000
commit89dab4a30fc044d84058ae6a23f0466aa14d7706 (patch)
tree7ebb9ecad6b6dca604510e165e2075a91086b8fe /app-office/qcharselect
parentVersion bumps for new genpatches and new TuxOnIce patch version 3.0.99.41. (diff)
downloadgentoo-2-89dab4a30fc044d84058ae6a23f0466aa14d7706.tar.gz
gentoo-2-89dab4a30fc044d84058ae6a23f0466aa14d7706.tar.bz2
gentoo-2-89dab4a30fc044d84058ae6a23f0466aa14d7706.zip
Initial commit.
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'app-office/qcharselect')
-rw-r--r--app-office/qcharselect/ChangeLog10
-rw-r--r--app-office/qcharselect/metadata.xml9
-rw-r--r--app-office/qcharselect/qcharselect-0.2.ebuild39
3 files changed, 58 insertions, 0 deletions
diff --git a/app-office/qcharselect/ChangeLog b/app-office/qcharselect/ChangeLog
new file mode 100644
index 000000000000..586617370900
--- /dev/null
+++ b/app-office/qcharselect/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-office/qcharselect
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/qcharselect/ChangeLog,v 1.1 2009/12/12 13:11:45 ssuominen Exp $
+
+*qcharselect-0.2 (12 Dec 2009)
+
+ 12 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +qcharselect-0.2.ebuild:
+ Initial commit.
+
diff --git a/app-office/qcharselect/metadata.xml b/app-office/qcharselect/metadata.xml
new file mode 100644
index 000000000000..7ce270433c50
--- /dev/null
+++ b/app-office/qcharselect/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/qcharselect/qcharselect-0.2.ebuild b/app-office/qcharselect/qcharselect-0.2.ebuild
new file mode 100644
index 000000000000..502c7de96e78
--- /dev/null
+++ b/app-office/qcharselect/qcharselect-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/qcharselect/qcharselect-0.2.ebuild,v 1.1 2009/12/12 13:11:45 ssuominen Exp $
+
+EAPI=2
+inherit multilib
+
+DESCRIPTION="A Qt4 port of KCharSelect from KDE 3.5"
+HOMEPAGE="http://qcharselect.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4[qt3support]"
+
+src_prepare() {
+ sed -i \
+ -e 's:update-mime-database:true:g' \
+ -e 's:data/desktop/qcharselect:src/QCharSelect:' \
+ Makefile.in || die
+}
+
+src_configure() {
+ local myconf
+ use debug && myconf="--enable-debug"
+
+ econf \
+ --with-qtdir=/usr \
+ --with-qtlibdir=/usr/$(get_libdir)/qt4 \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README
+}