summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Stadler <centic@gentoo.org>2004-03-06 21:25:35 +0000
committerDominik Stadler <centic@gentoo.org>2004-03-06 21:25:35 +0000
commitde82aae102e412b2cfce3b4fea0a62c14032d588 (patch)
treeacd173f5e3d559d9f1ad4a6e1fabdb8fe97e9611 /app-office/qhacc
parentuse "have_NPTL" instead of "if use nptl;" (Manifest recommit) (diff)
downloadgentoo-2-de82aae102e412b2cfce3b4fea0a62c14032d588.tar.gz
gentoo-2-de82aae102e412b2cfce3b4fea0a62c14032d588.tar.bz2
gentoo-2-de82aae102e412b2cfce3b4fea0a62c14032d588.zip
Add new ebuild for qhacc 2.9.8, see Bug# 38825.
Diffstat (limited to 'app-office/qhacc')
-rw-r--r--app-office/qhacc/ChangeLog8
-rw-r--r--app-office/qhacc/Manifest2
-rw-r--r--app-office/qhacc/files/digest-qhacc-2.9.81
-rw-r--r--app-office/qhacc/qhacc-2.9.8.ebuild49
4 files changed, 59 insertions, 1 deletions
diff --git a/app-office/qhacc/ChangeLog b/app-office/qhacc/ChangeLog
index 3f1089b7304d..a72882d9ec05 100644
--- a/app-office/qhacc/ChangeLog
+++ b/app-office/qhacc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/qhacc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/ChangeLog,v 1.5 2004/01/04 02:03:42 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/ChangeLog,v 1.6 2004/03/06 21:25:35 centic Exp $
+
+*qhacc-2.9.8 (07 Mar 2004)
+
+ 07 Mar 2004; Dominik Stadler <centic@gentoo.org> qhacc-2.9.8.ebuild:
+ Version bump, thanks to Charles Phoenix <phoenixreads@rogers.com>, Bug# 38825
+ Patches are not needed any more.
03 Jan 2004; Caleb Tennis <caleb@gentoo.org> qhacc-2.9.ebuild:
Put the qt dependency directly in the ebuild, remove the need kde as I don't
diff --git a/app-office/qhacc/Manifest b/app-office/qhacc/Manifest
index 2a67c686109d..abad1b4fe886 100644
--- a/app-office/qhacc/Manifest
+++ b/app-office/qhacc/Manifest
@@ -1,6 +1,8 @@
MD5 493a3e2bec9549a2b8e1f28ef42a2345 ChangeLog 919
MD5 512150b47a904b0240101e319856aab1 metadata.xml 156
MD5 1579031f58444a52dbc62801472ba7d7 qhacc-2.9.ebuild 1232
+MD5 ea15fc48a664ec47b3db6378db46c0ac qhacc-2.9.8.ebuild 1012
MD5 f9848845170083de3cf3420f27f240c1 files/digest-qhacc-2.9 61
MD5 83196bf0c0685733494d5f401c3d926f files/qhacc-2.9-gentoo.patch 7175
MD5 8411a52d54ebbb2038e2e08a9f43b238 files/qhacc-2.9-mysqlplugin-gcc-3.3.patch 982
+MD5 703c28cb8b7fdc28c19e990234c7eea6 files/digest-qhacc-2.9.8 63
diff --git a/app-office/qhacc/files/digest-qhacc-2.9.8 b/app-office/qhacc/files/digest-qhacc-2.9.8
new file mode 100644
index 000000000000..94140c9da691
--- /dev/null
+++ b/app-office/qhacc/files/digest-qhacc-2.9.8
@@ -0,0 +1 @@
+MD5 a7ab274784e4e9132cb40c6b0c13332c qhacc-2.9.8.tar.gz 489572
diff --git a/app-office/qhacc/qhacc-2.9.8.ebuild b/app-office/qhacc/qhacc-2.9.8.ebuild
new file mode 100644
index 000000000000..171f104aeaaa
--- /dev/null
+++ b/app-office/qhacc/qhacc-2.9.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/qhacc-2.9.8.ebuild,v 1.1 2004/03/06 21:25:35 centic Exp $
+
+inherit libtool
+
+IUSE="mysql xml"
+
+DESCRIPTION="Personal Finance for QT"
+HOMEPAGE="http://qhacc.sourceforge.net"
+SRC_URI="mirror://sourceforge/sourceforge/qhacc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+DEPEND="mysql? ( dev-db/mysql++ )
+ xml? ( dev-libs/libxml sys-libs/zlib )
+ >=x11-libs/qt-3"
+
+src_compile() {
+
+ elibtoolize
+
+ local myconf=""
+ use mysql || myconf="${myconf} --disable-mysql"
+ use xml || myconf="${myconf} --disable-xml"
+
+ econf ${myconf} || die "configure failed"
+
+ make || die "make failed"
+
+}
+
+src_install() {
+
+ einstall || die "install failed"
+
+ dodir /etc/qhacc
+ cp -R ${S}/contrib/easysetup/* ${D}/etc/qhacc/
+}
+
+pkg_postinst() {
+ einfo "Copy the files in /etc/qhacc to ~/.qhacc,
+ You have to run this program with the command:
+ qhacc -f ~/.qhacc/
+ I prefer to put this in my .bashrc
+ alias qhacc=\"qhacc -f ~/.qhacc\""
+}