summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-06 19:33:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-06 19:33:29 +0000
commit8a73e4e66d423dca102d7b4f4a186d13a77d5c7f (patch)
tree8ff6a9d16fe17d154204efc98a16617a06cae02e /app-office/scribus
parentadd libglade dependency from Prefix (diff)
downloadgentoo-2-8a73e4e66d423dca102d7b4f4a186d13a77d5c7f.tar.gz
gentoo-2-8a73e4e66d423dca102d7b4f4a186d13a77d5c7f.tar.bz2
gentoo-2-8a73e4e66d423dca102d7b4f4a186d13a77d5c7f.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-office/scribus')
-rw-r--r--app-office/scribus/ChangeLog12
-rw-r--r--app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch26
-rw-r--r--app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch21
-rw-r--r--app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch105
-rw-r--r--app-office/scribus/scribus-1.3.5.1.ebuild73
5 files changed, 235 insertions, 2 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index 91b4d5f34a33..a9940dd4d47c 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/scribus
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.115 2009/12/26 19:27:03 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.116 2010/01/06 19:33:28 ssuominen Exp $
+
+*scribus-1.3.5.1 (06 Jan 2010)
+
+ 06 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +scribus-1.3.5.1.ebuild, +files/scribus-1.3.5.1-check-hdict.patch,
+ +files/scribus-1.3.5.1-lib2geom.patch,
+ +files/scribus-1.3.5.1-system-hyphen.patch:
+ Version bump.
26 Dec 2009; Peter Volkov <pva@gentoo.org> scribus-1.3.3.11.ebuild,
scribus-1.3.3.12-r1.ebuild, scribus-1.3.3.13.ebuild,
diff --git a/app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch b/app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch
new file mode 100644
index 000000000000..40c93226138e
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch
@@ -0,0 +1,26 @@
+From dedea3f94802f0f9d9adef4c48f8061282baf776 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
+Date: Mon, 23 Nov 2009 10:13:48 +0100
+Subject: [PATCH] check hdict value before freeing the hyphenator
+
+---
+ Scribus/scribus/hyphenator.cpp | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/Scribus/scribus/hyphenator.cpp b/Scribus/scribus/hyphenator.cpp
+index 614db47..4da4467 100644
+--- a/Scribus/scribus/hyphenator.cpp
++++ b/Scribus/scribus/hyphenator.cpp
+@@ -90,7 +90,8 @@ Hyphenator::Hyphenator(QWidget* parent, ScribusDoc *dok) : QObject( parent ),
+
+ Hyphenator::~Hyphenator()
+ {
+- hnj_hyphen_free(hdict);
++ if (hdict)
++ hnj_hyphen_free(hdict);
+ }
+
+ void Hyphenator::NewDict(const QString& name)
+--
+1.6.3.3
+
diff --git a/app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch b/app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch
new file mode 100644
index 000000000000..6b7492770359
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch
@@ -0,0 +1,21 @@
+diff -ur scribus-1.3.5.1.orig/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt scribus-1.3.5.1/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt
+--- scribus-1.3.5.1.orig/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt 2008-06-02 01:38:43.000000000 +0300
++++ scribus-1.3.5.1/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt 2010-01-06 20:31:13.000000000 +0200
+@@ -16,6 +16,10 @@
+ #CB SET(CMAKE_MAKE_PROGRAM "${CMAKE_MAKE_PROGRAM}")
+ # We need to pass -fPIC only to lib2geom on amd64 - avoid it elsewhere see: http://www.gentoo.org/proj/en/base/amd64/howtos/index.xml?part=1&chap=3
+
++IF (ARCH_X86_64 EQUAL 1)
++ SET(CMAKE_CXX_FLAGS "$(CMAKE_CXX_FLAGS) -fPIC")
++ENDIF (ARCH_X86_64 EQUAL 1)
++
+ OPTION(2GEOM_BUILD_SHARED
+ "Build lib2geom and libtoy as shared libraries."
+ OFF)
+@@ -112,4 +116,4 @@
+ #CONFIGURE_FILE( ${CMAKE_SOURCE_DIR}/2geom.pc.in
+ # ${CMAKE_BINARY_DIR}/2geom.pc @ONLY IMMEDIATE )
+ #INSTALL(FILES "${CMAKE_BINARY_DIR}/2geom.pc" DESTINATION lib/pkgconfig)
+-#
+\ No newline at end of file
++#
diff --git a/app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch b/app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch
new file mode 100644
index 000000000000..2884cdde1565
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch
@@ -0,0 +1,105 @@
+diff -Nrup scribus-1.3.5.rc3.orig/cmake/modules/FindHYPHEN.cmake scribus-1.3.5.rc3/cmake/modules/FindHYPHEN.cmake
+--- scribus-1.3.5.rc3.orig/cmake/modules/FindHYPHEN.cmake 1970-01-01 01:00:00.000000000 +0100
++++ scribus-1.3.5.rc3/cmake/modules/FindHYPHEN.cmake 2009-07-02 14:23:26.000000000 +0200
+@@ -0,0 +1,28 @@
++# - Find HYPHEN library
++# Find the native HYPHEN includes and library
++# This module defines
++# HYPHEN_INCLUDE_DIR, where to find hyphen.h, etc.
++# HYPHEN_LIBRARIES, libraries to link against to use HYPHEN.
++# HYPHEN_FOUND, If false, do not try to use HYPHEN.
++# also defined, but not for general use are
++# HYPHEN_LIBRARY, where to find the HYPHEN library.
++
++FIND_PATH(HYPHEN_INCLUDE_DIR hyphen.h)
++
++SET(HYPHEN_NAMES_RELEASE ${HYPHEN_NAMES_RELEASE} ${HYPHEN_NAMES} hyphen libhyphen)
++SET(HYPHEN_NAMES_DEBUG ${HYPHEN_NAMES_DEBUG} hyphend libhyphend)
++
++FIND_LIBRARY(HYPHEN_LIBRARY_RELEASE NAMES ${HYPHEN_NAMES_RELEASE} )
++FIND_LIBRARY(HYPHEN_LIBRARY_DEBUG NAMES ${HYPHEN_NAMES_DEBUG} )
++
++INCLUDE(LibraryDebugAndRelease)
++SET_LIBRARY_FROM_DEBUG_AND_RELEASE(HYPHEN)
++
++# handle the QUIETLY and REQUIRED arguments and set HYPHEN_FOUND to TRUE if
++# all listed variables are TRUE
++INCLUDE(ScribusFindPackageHandleStandardArgs)
++FIND_PACKAGE_HANDLE_STANDARD_ARGS(HYPHEN DEFAULT_MSG HYPHEN_LIBRARY HYPHEN_INCLUDE_DIR)
++
++IF(HYPHEN_FOUND)
++ SET( HYPHEN_LIBRARIES ${HYPHEN_LIBRARY} )
++ENDIF(HYPHEN_FOUND)
+--- scribus-1.3.5.rc3.orig/CMakeLists.txt 2009-05-30 14:38:09.000000000 +0200
++++ scribus-1.3.5.rc3/CMakeLists.txt 2009-07-02 14:32:24.000000000 +0200
+@@ -638,6 +638,16 @@ ELSE(LIBPODOFO_FOUND)
+ ENDIF(LIBPODOFO_FOUND)
+ #>>PoDoFo for AI PDF import
+
++#<<HYPHEN for system hyphenation library
++FIND_PACKAGE(HYPHEN)
++IF(HYPHEN_FOUND)
++ MESSAGE("system hyphenation library found OK")
++ SET(HAVE_HYPHEN 1)
++ELSE(HYPHEN_FOUND)
++ MESSAGE("system hyphenation library NOT found - will use internal one")
++ENDIF(HYPHEN_FOUND)
++#>>HYPHEN for system hyphenation library
++
+ ##############################################################################################################
+ ########## Include Setup ##########
+
+diff -Nrup -x CMakeFiles -x Makefile -x FindHYPHEN.cmake scribus-1.3.5.rc3.orig/scribus/CMakeLists.txt scribus-1.3.5.rc3/scribus/CMakeLists.txt
+--- scribus-1.3.5.rc3.orig/scribus/CMakeLists.txt 2009-06-07 09:05:54.000000000 +0200
++++ scribus-1.3.5.rc3/scribus/CMakeLists.txt 2009-07-02 15:22:52.000000000 +0200
+@@ -403,10 +403,8 @@ SET(SCRIBUS_SOURCES
+ guidesdelegate.cpp
+ guidesmodel.cpp
+ helpbrowser.cpp
+- hnjalloc.c
+ hruler.cpp
+ hyask.cpp
+- hyphen.c
+ hyphenator.cpp
+ hysettings.cpp
+ imageinfodialog.cpp
+@@ -641,6 +639,14 @@ SET(SCRIBUS_SOURCES
+ vruler.cpp
+ )
+
++IF(NOT HAVE_HYPHEN)
++ SET(SCRIBUS_SOURCES
++ ${SCRIBUS_SOURCES}
++ hnjalloc.c
++ hyphen.c
++ )
++ENDIF(NOT HAVE_HYPHEN)
++
+ IF(WIN32)
+ SET(SCRIBUS_MOC_WIN32_ONLY_CLASSES scprintengine_gdi.h)
+ SET(SCRIBUS_WIN32_ONLY_SOURCES
+@@ -785,6 +791,12 @@ IF(HAVE_PODOFO)
+ )
+ ENDIF(HAVE_PODOFO)
+
++IF(HAVE_HYPHEN)
++ TARGET_LINK_LIBRARIES(${EXE_NAME}
++ ${HYPHEN_LIBRARY}
++ )
++ENDIF(HAVE_HYPHEN)
++
+ # Now build plugins
+ SET(PLUGIN_LIBRARIES)
+ IF(WIN32)
+diff -Nrup -x CMakeFiles -x Makefile -x '*.cmake' scribus-1.3.5.rc3.orig/scribus/hyphenator.h scribus-1.3.5.rc3/scribus/hyphenator.h
+--- scribus-1.3.5.rc3.orig/scribus/hyphenator.h 2007-07-10 22:33:09.000000000 +0200
++++ scribus-1.3.5.rc3/scribus/hyphenator.h 2009-07-02 14:03:11.000000000 +0200
+@@ -13,7 +13,7 @@ for which a new license (GPL+exception)
+ #include <QSet>
+
+ #include "scribusapi.h"
+-#include "hyphen.h"
++#include <hyphen.h>
+ class ScribusDoc;
+ class ScribusMainWindow;
+ class PageItem;
diff --git a/app-office/scribus/scribus-1.3.5.1.ebuild b/app-office/scribus/scribus-1.3.5.1.ebuild
new file mode 100644
index 000000000000..6d9903d081e0
--- /dev/null
+++ b/app-office/scribus/scribus-1.3.5.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.3.5.1.ebuild,v 1.1 2010/01/06 19:33:28 ssuominen Exp $
+
+EAPI=2
+NEED_PYTHON=2.6
+inherit cmake-utils fdo-mime multilib python
+
+DESCRIPTION="Desktop publishing (DTP) and layout program"
+HOMEPAGE="http://www.scribus.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo debug +pdf spell"
+
+COMMON_DEPEND="dev-libs/hyphen
+ dev-libs/libxml2
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ media-libs/jpeg
+ media-libs/lcms
+ media-libs/libpng
+ media-libs/tiff
+ net-print/cups
+ sys-libs/zlib
+ x11-libs/qt-gui:4
+ spell? ( app-text/aspell )
+ pdf? ( app-text/podofo )
+ cairo? ( x11-libs/cairo[X,svg] )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost"
+
+PATCHES=( "${FILESDIR}/${P}-check-hdict.patch"
+ "${FILESDIR}/${P}-system-hyphen.patch"
+ "${FILESDIR}/${P}-lib2geom.patch" )
+
+DOCS="AUTHORS ChangeLog* LINKS NEWS README TODO TRANSLATION"
+
+src_configure() {
+ python_version
+
+ mycmakeargs="${mycmakeargs}
+ -DHAVE_PYTHON=ON
+ -DPYTHON_INCLUDE_PATH=/usr/include/python${PYVER}
+ -DPYTHON_LIBRARY=/usr/$(get_libdir)/libpython${PYVER}.so
+ -DWANT_NORPATH=ON
+ -DWANT_QTARTHUR=ON
+ -DWANT_QT3SUPPORT=OFF
+ $(cmake-utils_use_has spell ASPELL)
+ $(cmake-utils_use_has pdf PODOFO)
+ $(cmake-utils_use_want cairo)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ doicon scribus/icons/scribus.png
+ domenu scribus.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}