summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-19 13:01:49 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-19 13:01:49 +0000
commit1e4390c0edc1f6d9fe3b8f9cc8096ceb9c639472 (patch)
tree1e0d99d3bc2ca7cc56696c3299b8a9164eff5d81 /app-office/skrooge
parentsparc stable wrt #365909 (diff)
downloadgentoo-2-1e4390c0edc1f6d9fe3b8f9cc8096ceb9c639472.tar.gz
gentoo-2-1e4390c0edc1f6d9fe3b8f9cc8096ceb9c639472.tar.bz2
gentoo-2-1e4390c0edc1f6d9fe3b8f9cc8096ceb9c639472.zip
Version bump
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-office/skrooge')
-rw-r--r--app-office/skrooge/ChangeLog7
-rw-r--r--app-office/skrooge/skrooge-0.9.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-office/skrooge/ChangeLog b/app-office/skrooge/ChangeLog
index 33335e04005a..fe99e694bd02 100644
--- a/app-office/skrooge/ChangeLog
+++ b/app-office/skrooge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/skrooge
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/skrooge/ChangeLog,v 1.16 2011/03/17 11:09:41 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/skrooge/ChangeLog,v 1.17 2011/06/19 13:01:49 dilfridge Exp $
+
+*skrooge-0.9.0 (19 Jun 2011)
+
+ 19 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> +skrooge-0.9.0.ebuild:
+ Version bump
*skrooge-0.8.1 (17 Mar 2011)
diff --git a/app-office/skrooge/skrooge-0.9.0.ebuild b/app-office/skrooge/skrooge-0.9.0.ebuild
new file mode 100644
index 000000000000..c2fe4c0dfeb6
--- /dev/null
+++ b/app-office/skrooge/skrooge-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/skrooge/skrooge-0.9.0.ebuild,v 1.1 2011/06/19 13:01:49 dilfridge Exp $
+
+EAPI=4
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fr ga gl hu it ja ko lt ms nb
+nds nl pl pt pt_BR ro ru sk sv tr ug uk zh_TW"
+KDE_DOC_DIRS="doc"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="personal finances manager for KDE4, aiming at being simple and intuitive"
+HOMEPAGE="http://skrooge.org/"
+SRC_URI="http://skrooge.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +handbook test"
+
+DEPEND=">=dev-libs/libofx-0.9.1
+ app-crypt/qca:2
+ x11-libs/qt-sql:4[sqlite]"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdesdk-scripts)"
+
+# Quite few tests fail in all versions
+# Upstream does not seem to be bothered by the fact release fails tests
+RESTRICT="test"
+
+DOCS="AUTHORS CHANGELOG README TODO"
+
+src_configure() {
+ mycmakeargs+=( $(cmake-utils_use test SKG_BUILD_TEST) )
+ kde4-base_src_configure
+}