summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-09-09 08:04:36 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-09-09 08:04:36 +0000
commit5692c2032e61fd6f968a5197a2a03887f3c06db7 (patch)
tree6d177936666887308e6b765eb37561d9c644cf81 /app-office/taskcoach/taskcoach-1.3.32.ebuild
parentVersion bump couchdb to 1.4.0. (diff)
downloadgentoo-2-5692c2032e61fd6f968a5197a2a03887f3c06db7.tar.gz
gentoo-2-5692c2032e61fd6f968a5197a2a03887f3c06db7.tar.bz2
gentoo-2-5692c2032e61fd6f968a5197a2a03887f3c06db7.zip
Version bump to 1.3.32
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'app-office/taskcoach/taskcoach-1.3.32.ebuild')
-rw-r--r--app-office/taskcoach/taskcoach-1.3.32.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-office/taskcoach/taskcoach-1.3.32.ebuild b/app-office/taskcoach/taskcoach-1.3.32.ebuild
new file mode 100644
index 000000000000..7e0c8c5580b2
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.3.32.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.3.32.ebuild,v 1.1 2013/09/09 08:04:36 ago Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org http://pypi.python.org/pypi/TaskCoach"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}