summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-06-04 08:24:46 +0000
committerVlastimil Babka <caster@gentoo.org>2008-06-04 08:24:46 +0000
commitf6b18a4e3201a6c0047a8767e82419a3b4097b9d (patch)
tree0562a9c965e87b15f7821d22d63a08822bf03815 /app-office/taskcoach
parentversion bump (diff)
downloadgentoo-2-f6b18a4e3201a6c0047a8767e82419a3b4097b9d.tar.gz
gentoo-2-f6b18a4e3201a6c0047a8767e82419a3b4097b9d.tar.bz2
gentoo-2-f6b18a4e3201a6c0047a8767e82419a3b4097b9d.zip
Fix bug #222391 for python 2.4 users. Also switch to icon that's now included in the upstream distfile instead of distributing own.
(Portage version: 2.1.5.3)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/files/taskcoach-setup.patch11
-rw-r--r--app-office/taskcoach/taskcoach-0.70.0.ebuild15
3 files changed, 28 insertions, 5 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 51b2abd7939a..398f5f57a6f6 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.6 2008/05/12 19:32:15 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.7 2008/06/04 08:24:45 caster Exp $
+
+ 04 Jun 2008; Vlastimil Babka <caster@gentoo.org>
+ +files/taskcoach-setup.patch, taskcoach-0.70.0.ebuild:
+ Fix bug #222391 for python 2.4 users. Also switch to icon that's now
+ included in the upstream distfile instead of distributing own.
*taskcoach-0.70.0 (12 May 2008)
diff --git a/app-office/taskcoach/files/taskcoach-setup.patch b/app-office/taskcoach/files/taskcoach-setup.patch
new file mode 100644
index 000000000000..8226dc7641d0
--- /dev/null
+++ b/app-office/taskcoach/files/taskcoach-setup.patch
@@ -0,0 +1,11 @@
+--- setup.py.orig 2008-06-04 10:16:13.000000000 +0200
++++ setup.py 2008-06-04 10:15:39.000000000 +0200
+@@ -20,7 +20,7 @@
+
+ import platform
+ from distutils.core import setup
+-from taskcoachlib import meta
++from taskcoachlib import meta, thirdparty
+
+
+ setupOptions = {
diff --git a/app-office/taskcoach/taskcoach-0.70.0.ebuild b/app-office/taskcoach/taskcoach-0.70.0.ebuild
index f00a0ae5d236..09ab04aae5f9 100644
--- a/app-office/taskcoach/taskcoach-0.70.0.ebuild
+++ b/app-office/taskcoach/taskcoach-0.70.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-0.70.0.ebuild,v 1.1 2008/05/12 19:32:15 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-0.70.0.ebuild,v 1.2 2008/06/04 08:24:45 caster Exp $
inherit distutils eutils
@@ -9,8 +9,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Simple personal tasks and todo lists manager"
HOMEPAGE="http://www.taskcoach.org"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
- mirror://gentoo/${PN}-icon.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -23,12 +22,20 @@ S="${WORKDIR}/${MY_P}"
DOCS="CHANGES.txt"
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ # bug 222391
+ epatch "${FILESDIR}/${PN}-setup.patch"
+}
+
src_install() {
distutils_src_install
mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
rm "${D}/usr/bin/taskcoach.pyw" || die
- doicon "${WORKDIR}/${PN}-icon/${PN}.png" || die
+ doicon "icons.in/${PN}.png" || die
make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
}