summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-08-08 15:33:55 +0000
committerMamoru Komachi <usata@gentoo.org>2005-08-08 15:33:55 +0000
commit5fbe3d298a7fee867afdcacb73ec3e3ef46c3993 (patch)
tree0c50214ee5227644995aa27b30513498f279149d /app-office/texmacs/texmacs-1.0.5.6.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-5fbe3d298a7fee867afdcacb73ec3e3ef46c3993.tar.gz
gentoo-2-5fbe3d298a7fee867afdcacb73ec3e3ef46c3993.tar.bz2
gentoo-2-5fbe3d298a7fee867afdcacb73ec3e3ef46c3993.zip
Version bumped.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-office/texmacs/texmacs-1.0.5.6.ebuild')
-rw-r--r--app-office/texmacs/texmacs-1.0.5.6.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-office/texmacs/texmacs-1.0.5.6.ebuild b/app-office/texmacs/texmacs-1.0.5.6.ebuild
new file mode 100644
index 000000000000..590876b41950
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.5.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.5.6.ebuild,v 1.1 2005/08/08 15:33:55 usata Exp $
+
+# although flag-o-matic functions in portage, we should inherit it
+inherit flag-o-matic
+
+MY_P=${P/tex/TeX}-src
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GNU TeXmacs is a free GUI scientific editor, inspired by TeX and GNU Emacs."
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="spell static"
+# TeXmacs 1.0.X-r? -> stable release, TeXmacs 1.0.X.Y -> development release
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/tetex
+ >=dev-util/guile-1.4
+ >=sys-apps/sed-4
+ virtual/x11
+ spell? ( >=app-text/ispell-3.2 )"
+
+DEPEND="${RDEPEND}
+ virtual/ghostscript"
+
+src_compile() {
+
+ # we're not trusting texmacs optimisations here, so
+ # we only want the following two
+ strip-flags
+ append-flags -fno-default-inline
+ append-flags -fno-inline
+
+ econf || die
+ # and now replace the detected optimisations with our safer ones
+ sed -i "s:\(^CXXOPTIMIZE = \).*:\1${CXXFLAGS}:" src/common.makefile
+ # emake b0rked
+ if use static ; then
+ emake -j1 STATIC_TEXMACS || die
+ else
+ emake -j1 || die
+ fi
+
+}
+
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ dodoc COMPILE COPYING LICENSE
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/TeXmacs.desktop
+
+ # now install the fonts
+ cd ${WORKDIR}
+ dodir /usr/share/texmf
+ cp -r fonts ${D}/usr/share/texmf/
+
+}