summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-12 18:55:30 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-12 18:55:30 +0000
commit5bd0ec4530dc9f6983a3ebccdc390ce789fe1c07 (patch)
tree2a9c8c273e70c455a6828b62b135c3611a767c4e /app-office/texmaker
parentUse QA_PREBUILD Bug #451436 (diff)
downloadgentoo-2-5bd0ec4530dc9f6983a3ebccdc390ce789fe1c07.tar.gz
gentoo-2-5bd0ec4530dc9f6983a3ebccdc390ce789fe1c07.tar.bz2
gentoo-2-5bd0ec4530dc9f6983a3ebccdc390ce789fe1c07.zip
app-office/texmaker: Add fix for clang, #449376
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-3.5.2-clang.patch16
-rw-r--r--app-office/texmaker/texmaker-3.5.2.ebuild6
3 files changed, 25 insertions, 5 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 560fd666b742..aa6bbfe81bfe 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/texmaker
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.115 2012/12/12 16:34:57 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.116 2013/01/12 18:55:30 jlec Exp $
+
+ 12 Jan 2013; Justin Lecher <jlec@gentoo.org> texmaker-3.5.2.ebuild,
+ +files/texmaker-3.5.2-clang.patch:
+ Add fix for clang, #449376
12 Dec 2012; Justin Lecher <jlec@gentoo.org> texmaker-3.3.4.ebuild,
texmaker-3.5.2.ebuild, metadata.xml:
diff --git a/app-office/texmaker/files/texmaker-3.5.2-clang.patch b/app-office/texmaker/files/texmaker-3.5.2-clang.patch
new file mode 100644
index 000000000000..8a232a99eb17
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-3.5.2-clang.patch
@@ -0,0 +1,16 @@
+ texmaker.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/texmaker.h b/texmaker.h
+index 3b7135e..acd49d8 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -121,7 +121,7 @@ UserTagsListWidget *usertagsListWidget;
+ XmlTagsListWidget *MpListWidget, *PsListWidget, *leftrightWidget, *tikzWidget, *asyWidget;
+ SymbolListWidget *RelationListWidget, *ArrowListWidget, *MiscellaneousListWidget, *DelimitersListWidget, *GreekListWidget, *MostUsedListWidget, *FavoriteListWidget;
+ QTreeWidget *StructureTreeWidget;
+-QVBoxLayout *OutputLayoutV, *CentralLayoutBis,*LeftPanelLayoutBis,;
++QVBoxLayout *OutputLayoutV, *CentralLayoutBis,*LeftPanelLayoutBis;
+ QHBoxLayout *OutputLayoutH, *LeftPanelLayout, *CentralLayout;
+ QTableWidget *OutputTableWidget;
+ //menu-toolbar
diff --git a/app-office/texmaker/texmaker-3.5.2.ebuild b/app-office/texmaker/texmaker-3.5.2.ebuild
index a485bd5df9f1..1e9c0eead1de 100644
--- a/app-office/texmaker/texmaker-3.5.2.ebuild
+++ b/app-office/texmaker/texmaker-3.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-3.5.2.ebuild,v 1.2 2012/12/12 16:34:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-3.5.2.ebuild,v 1.3 2013/01/12 18:55:30 jlec Exp $
EAPI=4
@@ -50,7 +50,7 @@ DEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}"/${P}-hunspell.patch
-# "${FILESDIR}"/${PN}-3.3.3-qt48.patch
+ "${FILESDIR}"/${P}-clang.patch
)
src_configure() {
eqmake4 \