summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-12 17:42:57 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-12 17:42:57 +0000
commit8341068a8692c9c15d7a54980e0f31269e1ef921 (patch)
tree27af2465378c94fd2b9d214055c47746fecdbffa /app-office/texmaker
parentMasked broken media-video/avidemux again, needs a revise for it to become mai... (diff)
downloadgentoo-2-8341068a8692c9c15d7a54980e0f31269e1ef921.tar.gz
gentoo-2-8341068a8692c9c15d7a54980e0f31269e1ef921.tar.bz2
gentoo-2-8341068a8692c9c15d7a54980e0f31269e1ef921.zip
app-office/texmaker: Version Bump, #461476
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog7
-rw-r--r--app-office/texmaker/texmaker-4.0.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 3845a1325c0c..f9a1ec8a39d0 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.118 2013/03/02 19:38:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.119 2013/03/12 17:42:57 jlec Exp $
+
+*texmaker-4.0 (12 Mar 2013)
+
+ 12 Mar 2013; Justin Lecher <jlec@gentoo.org> +texmaker-4.0.ebuild:
+ Version Bump, #461476
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> texmaker-3.3.4.ebuild,
texmaker-3.5.2-r1.ebuild, texmaker-3.5.2.ebuild:
diff --git a/app-office/texmaker/texmaker-4.0.ebuild b/app-office/texmaker/texmaker-4.0.ebuild
new file mode 100644
index 000000000000..603ee0bd44b9
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-4.0.ebuild,v 1.1 2013/03/12 17:42:57 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.2-hunspell.patch
+ )
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}"/usr \
+ DESKTOPDIR=/usr/share/applications \
+ ICONDIR=/usr/share/pixmaps
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+
+ doicon utilities/texmaker*.png utilities/texmaker.svg
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}