summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-25 17:05:13 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-25 17:05:13 +0000
commit040bbcfb25ab680de0500cf2562837ff131709bb (patch)
tree099b255243d748867fd42d117a3575891c68694e /app-office
parent*** empty log message *** (diff)
downloadgentoo-2-040bbcfb25ab680de0500cf2562837ff131709bb.tar.gz
gentoo-2-040bbcfb25ab680de0500cf2562837ff131709bb.tar.bz2
gentoo-2-040bbcfb25ab680de0500cf2562837ff131709bb.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/dia/dia-0.86-r1.ebuild8
-rw-r--r--app-office/gnumeric/gnumeric-0.59a.ebuild12
2 files changed, 13 insertions, 7 deletions
diff --git a/app-office/dia/dia-0.86-r1.ebuild b/app-office/dia/dia-0.86-r1.ebuild
index d19624382323..e7f74946a43a 100644
--- a/app-office/dia/dia-0.86-r1.ebuild
+++ b/app-office/dia/dia-0.86-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.86-r1.ebuild,v 1.3 2000/11/25 16:44:14 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.86-r1.ebuild,v 1.4 2000/11/25 17:05:13 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -17,10 +17,10 @@ src_compile() {
cd ${S}
local myconf
- if [ "`use bonobo`" ]
- then
+# if [ "`use bonobo`" ]
+# then
# myconf="--enable-bonobo"
- fi
+# fi
try ./configure --host=${CHOST} --prefix=/opt/gnome \
--enable-gnome --enable-gnome-print ${myconf}
# bonobo support does not work yet
diff --git a/app-office/gnumeric/gnumeric-0.59a.ebuild b/app-office/gnumeric/gnumeric-0.59a.ebuild
index a1638782317b..c27237f1ad33 100644
--- a/app-office/gnumeric/gnumeric-0.59a.ebuild
+++ b/app-office/gnumeric/gnumeric-0.59a.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.59a.ebuild,v 1.1 2000/11/25 13:04:23 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.59a.ebuild,v 1.2 2000/11/25 17:05:13 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -16,12 +16,18 @@ DEPEND=">=sys-devel/perl-5
>=gnome-base/libunicode-0.4
>=gnome-base/gal-0.2
>=gnome-libs/gb-0.0.15
- >=gnome-libs/libole2-0.1.7"
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28 )"
src_compile() {
cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-bonobo --with-gb
+ ${myconf} --with-gb
cd plugins/perl
cp Makefile Makefile.orig
# sed -e "s:perl Makefile\.PL:perl Makefile\.PL $PERLINSTALL:" \