summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-18 14:22:33 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-18 14:22:33 +0000
commit062b39bfd130c1508b2c5fdaaff1037bed78318c (patch)
tree309d0c68f5a6a179e14b5a2b2ef1a597232f042b /app-office
parentInitial import. New dependency of dev-ruby/mechanize. (diff)
downloadgentoo-2-062b39bfd130c1508b2c5fdaaff1037bed78318c.tar.gz
gentoo-2-062b39bfd130c1508b2c5fdaaff1037bed78318c.tar.bz2
gentoo-2-062b39bfd130c1508b2c5fdaaff1037bed78318c.zip
Non-maintainer commit. Remove double environment calls, cleanup global variables by unsetting them where possible, add missing dies during install, run eautoreconf and econf instead of autogen.sh, sort the deps alphabetically, add base eclass and PATCHES array support (and epatch_user), run emake instead of make. Mostly fixed all issues i had during the time i compiled it. Still good idea would be to migrate most parts of this ebuild to elbits. PS: debuging something in package that builds for 3 hours is major pita.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog13
-rw-r--r--app-office/libreoffice/libreoffice-3.4.1.ebuild347
2 files changed, 189 insertions, 171 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index a879837e9858..bfb27ffe598c 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.38 2011/07/14 20:55:30 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.39 2011/07/18 14:22:33 scarabeus Exp $
+
+ 18 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libreoffice-3.4.1.ebuild:
+ Non-maintainer commit. Remove double environment calls, cleanup global
+ variables by unsetting them where possible, add missing dies during install,
+ run eautoreconf and econf instead of autogen.sh, sort the deps
+ alphabetically, add base eclass and PATCHES array support (and epatch_user),
+ run emake instead of make. Mostly fixed all issues i had during the time i
+ compiled it. Still good idea would be to migrate most parts of this ebuild to
+ elbits. PS: debuging something in package that builds for 3 hours is major
+ pita.
14 Jul 2011; Andreas Proschofsky <suka@gentoo.org> libreoffice-3.4.1.ebuild:
Extensions now build fine again without java
diff --git a/app-office/libreoffice/libreoffice-3.4.1.ebuild b/app-office/libreoffice/libreoffice-3.4.1.ebuild
index 33156e6c430a..de9f3ab76756 100644
--- a/app-office/libreoffice/libreoffice-3.4.1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.1.ebuild
@@ -1,28 +1,26 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.1.ebuild,v 1.6 2011/07/14 20:55:30 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.1.ebuild,v 1.7 2011/07/18 14:22:33 scarabeus Exp $
-EAPI="3"
-
-WANT_AUTOMAKE="1.9"
+EAPI=3
KDE_REQUIRED="optional"
CMAKE_REQUIRED="never"
PYTHON_DEPEND="2"
-PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH="threads,xml"
-inherit autotools check-reqs db-use eutils fdo-mime flag-o-matic gnome2-utils java-pkg-opt-2 kde4-base multilib pax-utils prefix python toolchain-funcs
+inherit base autotools check-reqs db-use eutils fdo-mime flag-o-matic gnome2-utils java-pkg-opt-2 kde4-base multilib pax-utils prefix python toolchain-funcs
-IUSE="binfilter cups -custom-cflags dbus debug eds gnome gstreamer gtk kde ldap nsplugin odk offlinehelp opengl templates"
+IUSE="binfilter cups custom-cflags dbus debug eds gnome gstreamer gtk kde ldap nsplugin odk offlinehelp opengl templates"
MY_PV=3.4.1.3
-MY_P="${PN}-build-${MY_PV}"
PATCHLEVEL=OOO320
SRC=OOo_${PV}_src
S="${WORKDIR}/${PN}-bootstrap-${MY_PV}"
-DEVPATH="http://download.documentfoundation.org/libreoffice/src"
-EXT_SRC="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
+DEV_URI="http://download.documentfoundation.org/libreoffice/src"
+EXT_URI="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
+ADDONS_URI="http://dev-www.libreoffice.org/src/"
CONFFILE=${S}/distro-configs/Gentoo.conf
DESCRIPTION="LibreOffice, a full office productivity suite."
@@ -33,115 +31,104 @@ SRC_URI="odk? ( java? ( http://tools.openoffice.org/unowinreg_prebuild/680/unowi
MODULES="artwork base calc components extensions extras filters help
impress libs-core libs-extern libs-extern-sys libs-gui postprocess sdk testing
ure writer translations"
-
-MODULES2="${MODULES} bootstrap"
-
-for mod in ${MODULES2}; do
- SRC_URI+=" ${DEVPATH}/${PN}-${mod}-${MY_PV}.tar.bz2"
+# split out as bootstrap is required to be done first
+SRC_URI+=" ${DEV_URI}/${PN}-bootstrap-${MY_PV}.tar.bz2"
+for mod in ${MODULES}; do
+ SRC_URI+=" ${DEV_URI}/${PN}-${mod}-${MY_PV}.tar.bz2"
done
+unset mod MODULES2
# addons
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/48a9f787f43a09c0a9b7b00cd1fddbbf-hyphen-2.7.1.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/128cfc86ed5953e57fe0f5ae98b62c2e-libtextcat-2.2.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/1756c4fa6c616ae15973c104cd8cb256-Adobe-Core35_AFMs-314.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/24be19595acad0a2cae931af77a0148a-LICENSE_source-9.0.0.7-bj.html"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/26b3e95ddf3d9c077c480ea45874b3b8-lp_solve_5.5.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/284e768eeda0e2898b0d5bf7e26a016e-raptor-1.4.18.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/2a177023f9ea8ec8bd00837605c5df1b-jakarta-tomcat-5.0.30-src.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/ca4870d899fd7e943ffc310a5421ad4d-liberation-fonts-ttf-1.06.0.20100721.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/35efabc239af896dfb79be7ebdd6e6b9-gentiumbasic-fonts-1.10.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/3ade8cfe7e59ca8e65052644fed9fca4-epm-3.7.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/48470d662650c3c074e1c3fabbc67bbd-README_source-9.0.0.7-bj.txt"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/4a660ce8466c9df01f19036435425c3a-glibc-2.1.3-stub.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/599dc4cc65a07ee868cf92a667a913d2-xpdf-3.02.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/7376930b0d3f3d77a685d94c4a3acda8-STLport-4.5-0119.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/8294d6c42e3553229af9934c5c0ed997-stax-api-1.0-2-sources.jar"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/a4d9b30810a434a3ed39fc0003bbd637-LICENSE_stax-api-1.0-2-sources.html"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/bc702168a2af16869201dbe91e46ae48-LICENSE_Python-2.6.1"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/c441926f3a552ed3e5b274b62e86af16-STLport-4.0.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/d4c4d91ab3a8e52a2e69d48d34ef4df4-core.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/e0707ff896045731ff99e99799606441-README_db-4.7.25.NC-custom.txt"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/fb7ba5c2182be4e73748859967455455-README_stax-api-1.0-2-sources.txt"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/fca8706f2c4619e2fa3f8f42f8fc1e9d-rasqal-0.9.16.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/37282537d0ed1a087b1c8f050dc812d9-dejavu-fonts-ttf-2.32.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/067201ea8b126597670b5eff72e1f66c-mythes-1.2.0.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/3bdf40c0d199af31923e900d082ca2dd-libfonts-1.1.6.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/451ccf439a36a568653b024534669971-ConvertTextToNumber-1.3.2.oxt"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/47e1edaa44269bc537ae8cabebb0f638-JLanguageTool-1.0.0.tar.bz2"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/90401bca927835b6fbae4a707ed187c8-nlpsolver-0.9.tar.bz2"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/0f63ee487fda8f21fafa767b3c447ac9-ixion-0.2.0.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/71474203939fafbe271e1263e61d083e-nss-3.12.8-with-nspr-4.8.6.tar.gz"
-ADDONS_SRC+=" http://dev-www.libreoffice.org/src/7a0dcb3fe1e8c7229ab4fb868b7325e6-mdds_0.5.2.tar.bz2"
+ADDONS_SRC+=" ${ADDONS_URI}/48a9f787f43a09c0a9b7b00cd1fddbbf-hyphen-2.7.1.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/128cfc86ed5953e57fe0f5ae98b62c2e-libtextcat-2.2.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/1756c4fa6c616ae15973c104cd8cb256-Adobe-Core35_AFMs-314.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/24be19595acad0a2cae931af77a0148a-LICENSE_source-9.0.0.7-bj.html"
+ADDONS_SRC+=" ${ADDONS_URI}/26b3e95ddf3d9c077c480ea45874b3b8-lp_solve_5.5.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/284e768eeda0e2898b0d5bf7e26a016e-raptor-1.4.18.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/2a177023f9ea8ec8bd00837605c5df1b-jakarta-tomcat-5.0.30-src.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/ca4870d899fd7e943ffc310a5421ad4d-liberation-fonts-ttf-1.06.0.20100721.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/35efabc239af896dfb79be7ebdd6e6b9-gentiumbasic-fonts-1.10.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/3ade8cfe7e59ca8e65052644fed9fca4-epm-3.7.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/48470d662650c3c074e1c3fabbc67bbd-README_source-9.0.0.7-bj.txt"
+ADDONS_SRC+=" ${ADDONS_URI}/4a660ce8466c9df01f19036435425c3a-glibc-2.1.3-stub.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/599dc4cc65a07ee868cf92a667a913d2-xpdf-3.02.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/7376930b0d3f3d77a685d94c4a3acda8-STLport-4.5-0119.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/8294d6c42e3553229af9934c5c0ed997-stax-api-1.0-2-sources.jar"
+ADDONS_SRC+=" ${ADDONS_URI}/a4d9b30810a434a3ed39fc0003bbd637-LICENSE_stax-api-1.0-2-sources.html"
+ADDONS_SRC+=" ${ADDONS_URI}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/bc702168a2af16869201dbe91e46ae48-LICENSE_Python-2.6.1"
+ADDONS_SRC+=" ${ADDONS_URI}/c441926f3a552ed3e5b274b62e86af16-STLport-4.0.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/d4c4d91ab3a8e52a2e69d48d34ef4df4-core.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/e0707ff896045731ff99e99799606441-README_db-4.7.25.NC-custom.txt"
+ADDONS_SRC+=" ${ADDONS_URI}/fb7ba5c2182be4e73748859967455455-README_stax-api-1.0-2-sources.txt"
+ADDONS_SRC+=" ${ADDONS_URI}/fca8706f2c4619e2fa3f8f42f8fc1e9d-rasqal-0.9.16.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/37282537d0ed1a087b1c8f050dc812d9-dejavu-fonts-ttf-2.32.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/067201ea8b126597670b5eff72e1f66c-mythes-1.2.0.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/3bdf40c0d199af31923e900d082ca2dd-libfonts-1.1.6.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip"
+ADDONS_SRC+=" ${ADDONS_URI}/451ccf439a36a568653b024534669971-ConvertTextToNumber-1.3.2.oxt"
+ADDONS_SRC+=" ${ADDONS_URI}/47e1edaa44269bc537ae8cabebb0f638-JLanguageTool-1.0.0.tar.bz2"
+ADDONS_SRC+=" ${ADDONS_URI}/90401bca927835b6fbae4a707ed187c8-nlpsolver-0.9.tar.bz2"
+ADDONS_SRC+=" ${ADDONS_URI}/0f63ee487fda8f21fafa767b3c447ac9-ixion-0.2.0.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/71474203939fafbe271e1263e61d083e-nss-3.12.8-with-nspr-4.8.6.tar.gz"
+ADDONS_SRC+=" ${ADDONS_URI}/7a0dcb3fe1e8c7229ab4fb868b7325e6-mdds_0.5.2.tar.bz2"
ADDONS_SRC+=" http://download.go-oo.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll"
ADDONS_SRC+=" http://download.go-oo.org/extern/b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2"
ADDONS_SRC+=" http://www.numbertext.org/linux/881af2b7dca9b8259abbca00bbbc004d-LinLibertineG-20110101.zip"
SRC_URI+=" ${ADDONS_SRC}"
-LANGS1="af ar as ast be_BY bg bn bo br brx bs ca ca_XV cs cy da de dgo dz el en en_GB en_ZA eo es et eu fa fi fr ga gd gl gu he hi hr hu id is it ja ka kk km kn ko kok ks ku ky lo lt lv mai mk ml mn mni mr ms my nb ne nl nn nr ns oc om or pa_IN pap pl ps pt pt_BR ro ru rw sa_IN sat sd sh si sk sl sq sr ss st sv sw_TZ ta te tg th ti tn tr ts ug uk uz ve vi xh zh_CN zh_TW zu"
-LANGS="${LANGS1} en en_US"
-
-for X in ${LANGS} ; do
+# translations
+LANGUAGES="af ar as ast be_BY bg bn bo br brx bs ca ca_XV cs cy da de dgo dz el
+en en_GB en_ZA eo es et eu fa fi fr ga gd gl gu he hi hr hu id is it ja ka kk km
+kn kok ko ks ku ky lo lt lv mai mk ml mn mni mr ms my nb ne nl nn nr ns oc om or
+pa pap pl ps pt pt_BR ro ru rw sat sd sh si sk sl sq sr ss st sv sw_TZ ta te tg
+th ti tn tr ts ug uk uz ve vi xh zh_CN zh_TW zu"
+for X in ${LANGUAGES} ; do
IUSE+=" linguas_${X}"
done
+unset X
# intersection of available linguas and app-dicts/myspell-* dictionaries
-SPELL_DIRS="af bg ca cs cy da de el en eo es et fr ga gl he hr hu it ku lt mk nb nl nn pl pt ru sk sl sv tn zu"
-SPELL_DIRS_DEPEND=""
+SPELL_DIRS="af bg ca cs cy da de el en eo es et fr ga gl he hr hu it ku lt mk nb
+nl nn pl pt ru sk sl sv tn zu"
for X in ${SPELL_DIRS} ; do
SPELL_DIRS_DEPEND+=" linguas_${X}? ( app-dicts/myspell-${X} )"
done
-
-TDEPEND="${EXT_SRC}/472ffb92d82cf502be039203c606643d-Sun-ODF-Template-Pack-en-US_1.0.0.oxt"
-TDEPEND+=" linguas_de? ( ${EXT_SRC}/53ca5e56ccd4cab3693ad32c6bd13343-Sun-ODF-Template-Pack-de_1.0.0.oxt )"
-TDEPEND+=" linguas_en_GB? ( ${EXT_SRC}/472ffb92d82cf502be039203c606643d-Sun-ODF-Template-Pack-en-US_1.0.0.oxt )"
-TDEPEND+=" linguas_en_ZA? ( ${EXT_SRC}/472ffb92d82cf502be039203c606643d-Sun-ODF-Template-Pack-en-US_1.0.0.oxt )"
-TDEPEND+=" linguas_es? ( ${EXT_SRC}/4ad003e7bbda5715f5f38fde1f707af2-Sun-ODF-Template-Pack-es_1.0.0.oxt )"
-TDEPEND+=" linguas_fr? ( ${EXT_SRC}/a53080dc876edcddb26eb4c3c7537469-Sun-ODF-Template-Pack-fr_1.0.0.oxt )"
-TDEPEND+=" linguas_hu? ( ${EXT_SRC}/09ec2dac030e1dcd5ef7fa1692691dc0-Sun-ODF-Template-Pack-hu_1.0.0.oxt )"
-TDEPEND+=" linguas_it? ( ${EXT_SRC}/b33775feda3bcf823cad7ac361fd49a6-Sun-ODF-Template-Pack-it_1.0.0.oxt )"
-
+unset X
+
+TDEPEND="${EXT_URI}/472ffb92d82cf502be039203c606643d-Sun-ODF-Template-Pack-en-US_1.0.0.oxt"
+TDEPEND+=" linguas_de? ( ${EXT_URI}/53ca5e56ccd4cab3693ad32c6bd13343-Sun-ODF-Template-Pack-de_1.0.0.oxt )"
+TDEPEND+=" linguas_en_GB? ( ${EXT_URI}/472ffb92d82cf502be039203c606643d-Sun-ODF-Template-Pack-en-US_1.0.0.oxt )"
+TDEPEND+=" linguas_en_ZA? ( ${EXT_URI}/472ffb92d82cf502be039203c606643d-Sun-ODF-Template-Pack-en-US_1.0.0.oxt )"
+TDEPEND+=" linguas_es? ( ${EXT_URI}/4ad003e7bbda5715f5f38fde1f707af2-Sun-ODF-Template-Pack-es_1.0.0.oxt )"
+TDEPEND+=" linguas_fr? ( ${EXT_URI}/a53080dc876edcddb26eb4c3c7537469-Sun-ODF-Template-Pack-fr_1.0.0.oxt )"
+TDEPEND+=" linguas_hu? ( ${EXT_URI}/09ec2dac030e1dcd5ef7fa1692691dc0-Sun-ODF-Template-Pack-hu_1.0.0.oxt )"
+TDEPEND+=" linguas_it? ( ${EXT_URI}/b33775feda3bcf823cad7ac361fd49a6-Sun-ODF-Template-Pack-it_1.0.0.oxt )"
SRC_URI+=" templates? ( ${TDEPEND} )"
+unset ADDONS_URI
+unset EXT_URI
+
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-COMMON_DEPEND="!app-office/libreoffice-bin
- !app-office/openoffice-bin
- !app-office/openoffice
- cups? ( net-print/cups )
- dbus? ( >=dev-libs/dbus-glib-0.71 )
- eds? ( >=gnome-extra/evolution-data-server-1.2 )
- gnome? ( >=x11-libs/gtk+-2.10:2
- gnome-base/gconf:2 )
- gtk? ( >=x11-libs/gtk+-2.10:2 )
- gstreamer? ( >=media-libs/gstreamer-0.10
- >=media-libs/gst-plugins-base-0.10 )
- java? ( >=dev-java/bsh-2.0_beta4
- dev-java/lucene:2.3
- dev-java/lucene-analyzers:2.3 )
- ldap? ( net-nds/openldap )
- nsplugin? ( net-libs/xulrunner:1.9
- >=dev-libs/nspr-4.6.6
- >=dev-libs/nss-3.11-r1 )
- opengl? ( virtual/opengl )
+COMMON_DEPEND="
app-arch/zip
app-arch/unzip
>=app-text/hunspell-1.1.4-r1
@@ -165,19 +152,46 @@ COMMON_DEPEND="!app-office/libreoffice-bin
>=x11-libs/cairo-1.0.2
x11-libs/libXaw
x11-libs/libXinerama
- x11-libs/libXrandr"
+ x11-libs/libXrandr
+ cups? ( net-print/cups )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ eds? ( >=gnome-extra/evolution-data-server-1.2 )
+ gnome? (
+ >=x11-libs/gtk+-2.10:2
+ gnome-base/gconf:2
+ )
+ gtk? ( >=x11-libs/gtk+-2.10:2 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10
+ )
+ java? (
+ >=dev-java/bsh-2.0_beta4
+ dev-java/lucene:2.3
+ dev-java/lucene-analyzers:2.3
+ )
+ ldap? ( net-nds/openldap )
+ nsplugin? (
+ net-libs/xulrunner:1.9
+ >=dev-libs/nspr-4.6.6
+ >=dev-libs/nss-3.11-r1
+ )
+ opengl? ( virtual/opengl )
+"
-RDEPEND="java? ( >=virtual/jre-1.5 )
+RDEPEND="${COMMON_DEPEND}
+ !app-office/libreoffice-bin
+ !app-office/openoffice-bin
+ !app-office/openoffice
+ java? ( >=virtual/jre-1.5 )
${SPELL_DIRS_DEPEND}
- ${COMMON_DEPEND}"
+"
DEPEND="${COMMON_DEPEND}
- java? ( || ( =virtual/jdk-1.6* =virtual/jdk-1.5* )
- >=dev-java/ant-core-1.7 )
>=dev-libs/boost-1.36
>=dev-libs/libxml2-2.0
- dev-perl/Archive-Zip
dev-libs/libxslt
+ dev-perl/Archive-Zip
dev-util/cppunit
>=dev-util/gperf-3
dev-util/intltool
@@ -193,10 +207,23 @@ DEPEND="${COMMON_DEPEND}
x11-proto/printproto
x11-proto/xextproto
x11-proto/xineramaproto
- x11-proto/xproto"
+ x11-proto/xproto
+ java? (
+ || ( =virtual/jdk-1.6* =virtual/jdk-1.5* )
+ >=dev-java/ant-core-1.7
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.3.1-neon_remove_SSPI_support.diff"
+ "${FILESDIR}/${PN}-libdb5-fix-check.diff"
+ "${FILESDIR}/${P}-salfix.diff"
+)
+
+# Uncoment me when updating to eapi4
+# REQUIRED_USE="gnome? ( gtk )"
pkg_setup() {
-
java-pkg-opt-2_pkg_setup
# sys-libs/db version used
@@ -207,12 +234,35 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
+ if use custom-cflags; then
+ ewarn " You are using custom CFLAGS, which is NOT supported and can cause "
+ ewarn " all sorts of build and runtime errors. "
+ ewarn
+ ewarn " Before reporting a bug, please make sure you rebuild and try with "
+ ewarn " basic CFLAGS, otherwise the bug will not be accepted. "
+ ewarn
+ fi
+
+ if ! use java; then
+ ewarn " You are building with java-support disabled, this results in some "
+ ewarn " of the LibreOffice functionality being disabled. "
+ ewarn " If something you need does not work for you, rebuild with "
+ ewarn " java in your USE-flags. "
+ ewarn
+ fi
+
+ if ! use gtk && ! use gnome; then
+ ewarn " If you want the LibreOffice systray quickstarter to work "
+ ewarn " activate either the 'gtk' or 'gnome' use flags. "
+ ewarn
+ fi
}
src_unpack() {
+ local mod dest tmplfile tmplname
#first the bootstrap files
- unpack "${PN}-${mod}-${MY_PV}.tar.bz2"
+ unpack "${PN}-bootstrap-${MY_PV}.tar.bz2"
# and then all the separate modules
for mod in ${MODULES}; do
@@ -226,7 +276,7 @@ src_unpack() {
# copy extension templates; o what fun ...
if use templates; then
- local dest="${S}/extras/source/extensions"
+ dest="${S}/extras/source/extensions"
mkdir -p "${dest}"
for template in ${TDEPEND}; do
@@ -234,26 +284,15 @@ src_unpack() {
tmplfile="${DISTDIR}/$(basename ${template})"
tmplname="$(echo "${template}" | \
cut -f 2- -s -d - | cut -f 1 -d _)"
-
- [ -f ${tmplfile} ] && [ ! -f "${dest}/${tmplname}".oxt ] \
- && { cp -v "${tmplfile}" "${dest}/${tmplname}".oxt || die; }
+ if [[ -f ${tmplname} && ! -f "${dest}/${tmplname}.oxt" ]]; then
+ cp -v "${tmplfile}" "${dest}/${tmplname}.oxt" || die
+ fi
fi
done
fi
-
}
src_prepare() {
-
- if use custom-cflags; then
- ewarn " You are using custom CFLAGS, which is NOT supported and can cause "
- ewarn " all sorts of build and runtime errors. "
- ewarn
- ewarn " Before reporting a bug, please make sure you rebuild and try with "
- ewarn " basic CFLAGS, otherwise the bug will not be accepted. "
- ewarn
- fi
-
ewarn
ewarn " If you experience a build break, please make sure to retry "
ewarn " with MAKEOPTS="-j1" before filing a bug. "
@@ -264,7 +303,7 @@ src_prepare() {
use debug && CHECKREQS_DISK_BUILD="12288" || CHECKREQS_DISK_BUILD="7144"
check_reqs
- strip-linguas ${LANGS}
+ strip-linguas ${LANGUAGES}
# en_US is built by default, upstream needs us to use --with-lang="" in this case though, so strip it out
export LINGUAS_TEMP=$(echo ${LINGUAS} | sed -e 's/\ben_US\b//g;s/en//g;s/_GB/en_GB/g;s/_ZA/en_ZA/g')
@@ -276,27 +315,14 @@ src_prepare() {
export LINGUAS_OOO="en-US ${LINGUAS_TEMP//_/-}"
fi
- if use !java; then
- ewarn " You are building with java-support disabled, this results in some "
- ewarn " of the LibreOffice functionality being disabled. "
- ewarn " If something you need does not work for you, rebuild with "
- ewarn " java in your USE-flags. "
- ewarn
- fi
-
- if use !gtk && use !gnome; then
- ewarn " If you want the LibreOffice systray quickstarter to work "
- ewarn " activate either the 'gtk' or 'gnome' use flags. "
- ewarn
- fi
-
# Some fixes for our patchset
use java && epatch "${FILESDIR}/sdext-presenter.diff"
- epatch "${FILESDIR}/${PN}-3.3.1-neon_remove_SSPI_support.diff"
- epatch "${FILESDIR}/${PN}-libdb5-fix-check.diff"
- epatch "${FILESDIR}/${P}-salfix.diff"
+ base_src_prepare
+
+ eautoreconf
+}
- #Use flag checks
+src_configure() {
if use java ; then
echo "--with-ant-home=${ANT_HOME}" >> ${CONFFILE}
echo "--with-jdk-home=$(java-config --jdk-home 2>/dev/null)" >> ${CONFFILE}
@@ -386,9 +412,6 @@ src_prepare() {
echo "--without-myspell-dicts" >> ${CONFFILE}
echo "--without-ppds" >> ${CONFFILE}
echo "--without-stlport" >> ${CONFFILE}
-}
-
-src_configure() {
use kde && export KDE4DIR="${KDEDIR}"
use kde && export QT4LIB="/usr/$(get_libdir)/qt4"
@@ -417,27 +440,22 @@ src_configure() {
local GTKFLAG="--disable-gtk"
{ use gtk || use gnome; } && GTKFLAG="--enable-gtk"
- cd "${S}"
- ./autogen.sh --with-distro="Gentoo" \
- || die "Configuration failed!"
-
+ econf $(cat ${CONFFILE} |tr '\n' ' ') ${GTKFLAG}
}
src_compile() {
-
# Workaround for upstream download bug
touch src.downloaded
-
- make || die "Build failed"
-
+ emake || die
}
src_install() {
+ local SIZE desk app
export PYTHONPATH=""
einfo "Preparing Installation"
- make DESTDIR="${D}" install || die "Installation failed!"
+ emake DESTDIR="${D}" install || die
# Fix the permissions for security reasons
chown -RP root:0 "${ED}"
@@ -462,12 +480,12 @@ src_install() {
for SIZE in 16 32 48 128 ; do
cd "${ED}"/usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
for app in base calc draw impress main math startcenter writer ; do
- mv ${app}.png ${PN}-${app}.png
+ mv ${app}.png ${PN}-${app}.png || die
done
done
# Install wrapper script
- newbin "${T}/wrapper.in" ${PN}
+ newbin "${T}/wrapper.in" ${PN} || die
sed -i -e s/LIBDIR/$(get_libdir)/g "${ED}/usr/bin/${PN}" || die
# Cleanup after playing
@@ -476,27 +494,16 @@ src_install() {
}
pkg_preinst() {
-
- { use gtk || use gnome; } && gnome2_icon_savelist
-
+ kde4-base_pkg_preinst
}
pkg_postinst() {
-
- # Cache updates
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- { use gtk || use gnome; } && gnome2_icon_cache_update
-
- pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
-
+ # Cache updates - all handled by kde eclass for all environments
kde4-base_pkg_postinst
+ pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
}
pkg_postrm() {
-
- fdo-mime_desktop_database_update
- { use gtk || use gnome; } && gnome2_icon_cache_update
-
+ kde4-base_pkg_postrm
}