summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-01-23 10:02:36 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-01-23 10:02:36 +0000
commit0634fb5a1c6e78da47f480d5362ffa9823b6e637 (patch)
tree779bf2576b1d819bc959ad61b9c815dfc21425d7 /app-office
parentFix to automatically use fonts in /us/share/fonts (diff)
downloadgentoo-2-0634fb5a1c6e78da47f480d5362ffa9823b6e637.tar.gz
gentoo-2-0634fb5a1c6e78da47f480d5362ffa9823b6e637.tar.bz2
gentoo-2-0634fb5a1c6e78da47f480d5362ffa9823b6e637.zip
Fix to automatically use fonts in /usr/share/fonts
(Portage version: 2.0.51-r14)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog7
-rw-r--r--app-office/openoffice/files/1.1.4/ooffice-wrapper-1.3104
2 files changed, 15 insertions, 96 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 65088d4cbff2..fff971d62783 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.107 2005/01/22 16:03:20 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.108 2005/01/23 10:02:36 suka Exp $
+
+ 23 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
+ files/1.1.4/ooffice-wrapper-1.3:
+ Fix for wrapper-file to automatically find all fonts in /usr/share/fonts,
+ also remove some unneeded stuff
22 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
openoffice-1.1.4.ebuild:
diff --git a/app-office/openoffice/files/1.1.4/ooffice-wrapper-1.3 b/app-office/openoffice/files/1.1.4/ooffice-wrapper-1.3
index bb980f3f6082..9fa0ff5ede9f 100644
--- a/app-office/openoffice/files/1.1.4/ooffice-wrapper-1.3
+++ b/app-office/openoffice/files/1.1.4/ooffice-wrapper-1.3
@@ -76,41 +76,18 @@ if [ $? -eq 2 ] ; then
fi
##
-## Unset SESSION_MANAGER if gnome-session is the session manager
-## See http://www.openoffice.org/issues/show_bug.cgi?id=4494
+## Add /usr/share/fonts to font search path
##
-SMPID=`echo $SESSION_MANAGER | sed --quiet "s,local.*/,,p"`
-if [ -n "$SMPID" ] && [ -L /proc/"$SMPID"/exe ]; then
- SESMGR="`readlink -f /proc/$SMPID/exe`"
- case "$SESMGR" in
- /usr/bin/gnome-session*)
- echo "Gnome session manager detected - session management disabled"
- unset SESSION_MANAGER
- ;;
- esac
-fi
+# Default font path. This is used if SAL_FONTPATH_PRIVATE is not defined.
-##
-## Add known Debian fonts locations to search path
-##
-## Please report if you have problems with fonts, or know of non-defoma integrated packages that place fonts in other
-## paths.
-##
+GENTOO_FONTPATH=""
+for d in `find /usr/share/fonts -type d -maxdepth 1 -mindepth 1` ; do
+ GENTOO_FONTPATH="$GENTOO_FONTPATH;$d"
+done
-# Default font path. This is used if SAL_FONTPATH_USER is not defined.
-DEBOO_FONTPATH="/usr/lib/X11/fonts/misc/;/usr/lib/X11/fonts/cyrillic/;\
-/usr/lib/X11/fonts/100dpi/:unscaled;/usr/lib/X11/fonts/75dpi/:unscaled;\
-/usr/lib/X11/fonts/Type1/;/usr/lib/X11/fonts/CID;/usr/lib/X11/fonts/Speedo/;\
-/usr/lib/X11/fonts/100dpi/;/usr/lib/X11/fonts/75dpi/;\
-/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType;\
-/usr/lib/X11/fonts/TrueType;\
-/usr/share/fonts/truetype/kochi;\
-/usr/lib/X11/fonts/TrueType/larabie-straight;\
-/usr/lib/X11/fonts/TrueType/larabie-uncommon"
-
-SAL_FONTPATH_USER=${SAL_FONTPATH_USER:-"$DEBOO_FONTPATH"}
-export SAL_FONTPATH_USER
+SAL_FONTPATH_PRIVATE=${SAL_FONTPATH_PRIVATE:-"$GENTOO_FONTPATH"}
+export SAL_FONTPATH_PRIVATE
## search LOCALE
if [ -n "$LC_ALL" ]; then
@@ -138,15 +115,6 @@ if [ -z "$OOHOME" ] ; then
if [ -e /etc/openoffice/autoresponse-<pv>.conf ] && \
grep -q DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf ; then
-# Do not take old settings as migration results in broken behaviour
-#
-# UPDATEFLAG=""
-# if oldhome="`get_settings_dir "OpenOffice.org 1.0.3"`" ; then
-# OOHOME="$oldhome"
-# echo "Using settings from 1.0.3: /${oldhome}"
-# /bin/echo -e "OpenOffice.org <pv>=file://$oldhome\r" >> ~/.sversionrc
-# UPDATEFLAG="-update:/$oldhome"
-# fi
# first install
OOHOME=`grep DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf | \
sed -e 's/DESTINATIONPATH=//' -e "s|<home>|$HOME|"`
@@ -164,9 +132,6 @@ if [ -z "$OOHOME" ] ; then
exit 1
fi
-
-# fi
-
echo "Setup complete. Running openoffice.org..."
else
@@ -187,8 +152,8 @@ if [ $# = 0 ]; then
oodraw) set -- private:factory/sdraw;;
ooimpress) set -- private:factory/simpress;;
oomath) set -- private:factory/smath;;
+ ooweb) set -- private:factory/swriter/web;;
oowriter) set -- private:factory/swriter;;
- oohtml) set -- private:factory/swriter/web;;
oomaster) set -- private:factory/swriter/Global;;
esac
fi
@@ -196,23 +161,6 @@ fi
## Previous dead installation?
[ -d $HOME/.openoffice/user ] && echo "Warning: you have a user settings directory from 1.0.0 in ~/.openoffice/user - this is no longer used"
-# There is no locale import file
-## Change the ooLocale key in SETUPFILE acording to LOCALE
-#TMPFILE=`mktemp -t oooLocale.XXXXXXXXXX` && {
-# cat >${TMPFILE} <<EOF
-#<?xml version="1.0" encoding="UTF-8"?>
-#<oor:node xmlns:oor="http://openoffice.org/2001/registry" xmlns:xs="http://www.w3.org/2001/XMLSchema" oor:name="Setup" oor:package="org.openoffice">
-# <node oor:name="L10N">
-# <prop oor:name="ooLocale" oor:type="xs:string">
-# <value>$LOCALEOO</value>
-# </prop>
-# </node>
-#</oor:node>
-#EOF
-# ooconfigimport $TMPFILE >/dev/null
-# rm -f ${TMPFILE}
-#}
-
# Check whether the programs actually link to anything, or are from an old
# version.
@@ -243,37 +191,3 @@ case `basename $0` in
*) exec "$OOHOME/soffice" "$@"
;;
esac
-## Changelog
-# 2003/04/01 halls
-# * Version 1.1beta
-# 2003/02/03 halls
-# * Check for nonexistent ooLocale every run
-# 2003/01/09 halls
-# * Version 1.0.2
-# 12/15 saviot
-# * Change ooLocale at startup in Setup.xml
-# <ooLocale cfg:type="string"/> doesn't work for help.
-# 12/03 challs
-# * Add Debian font paths to user font path
-# 11/14 saviot
-# * correct handling of UI language
-# * don't change Linguistic.xml after first startup(#168780)
-# * TODO: provide better defaults on first startup
-# 10/03 challs
-# * Fix use with LC_ALL
-# 07/10 challs
-# * use 1.0.1 directory and improve error checking
-# 07/02 challs
-# * use readlink in /proc/PID/exe to get
-# real session manager name
-# 06/12 challs
-# * merge into main package
-# * change $@ to "$@"
-# * source configuration file:
-# /etc/openoffice/openoffice.conf
-# 06/12 mquinson
-# * strace only when DEBUG is set to yes
-# * readd the $@ to pass the args to soffice
-# 06/06 mquinson
-# * Make sure the OLDLOCALE is never empty
-# * handle the case where the locale is C