summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-12 10:49:59 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-12 10:49:59 +0000
commit0857b615d5e192d2ef1e9df80b6ba32d5ed60825 (patch)
treee8219b9c1c1e7c468ff3c70a1c443b6ed5f132d3 /app-office
parentDepend on boost per bug #398637. (diff)
downloadgentoo-2-0857b615d5e192d2ef1e9df80b6ba32d5ed60825.tar.gz
gentoo-2-0857b615d5e192d2ef1e9df80b6ba32d5ed60825.tar.bz2
gentoo-2-0857b615d5e192d2ef1e9df80b6ba32d5ed60825.zip
Version Bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-3.2.2-hunspell.patch190
-rw-r--r--app-office/texmaker/texmaker-3.2.2.ebuild70
3 files changed, 267 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 34dc49fef744..d45dfba94184 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.92 2012/01/05 08:17:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.93 2012/01/12 10:49:59 jlec Exp $
+
+*texmaker-3.2.2 (12 Jan 2012)
+
+ 12 Jan 2012; Justin Lecher <jlec@gentoo.org> +texmaker-3.2.2.ebuild,
+ +files/texmaker-3.2.2-hunspell.patch:
+ Version Bump
*texmaker-3.2.1 (05 Jan 2012)
diff --git a/app-office/texmaker/files/texmaker-3.2.2-hunspell.patch b/app-office/texmaker/files/texmaker-3.2.2-hunspell.patch
new file mode 100644
index 000000000000..b680f30d1aa4
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-3.2.2-hunspell.patch
@@ -0,0 +1,190 @@
+From 3ecb1391c92f1ba314c8ea2013b1b1136fb90f8f Mon Sep 17 00:00:00 2001
+Message-Id: <3ecb1391c92f1ba314c8ea2013b1b1136fb90f8f.1324552714.git.jlec@gentoo.org>
+From: Justin Lecher <jlec@gentoo.org>
+Date: Thu, 22 Dec 2011 12:09:32 +0100
+Subject: [PATCH] 3.1-hunspell.patch
+
+Conflicts:
+
+ latexeditor.h
+ texmaker.pro
+---
+ configdialog.cpp | 4 ++--
+ latexeditor.h | 2 +-
+ latexeditorview.h | 2 +-
+ latexhighlighter.h | 2 +-
+ spellerdialog.h | 2 +-
+ texmaker.h | 2 +-
+ texmaker.pro | 44 +++++++-------------------------------------
+ 7 files changed, 14 insertions(+), 44 deletions(-)
+
+diff --git a/configdialog.cpp b/configdialog.cpp
+index 144bddc..89e4059 100644
+--- a/configdialog.cpp
++++ b/configdialog.cpp
+@@ -187,9 +187,9 @@ void ConfigDialog::browseAspell()
+ QDir spelldir(QCoreApplication::applicationDirPath());
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QDir spelldir(PREFIX"/share/myspell/dicts");
++QDir spelldir("@GENTOO_PORTAGE_EPREFIX@/usr/share/myspell");
+ #else
+-QDir spelldir(PREFIX"/share/texmaker");
++QDir spelldir("@GENTOO_PORTAGE_EPREFIX@/usr/share/texmaker");
+ #endif
+ #endif
+
+diff --git a/latexeditor.h b/latexeditor.h
+index 40cc2f6..d46150f 100644
+--- a/latexeditor.h
++++ b/latexeditor.h
+@@ -28,7 +28,7 @@
+
+ #include "latexhighlighter.h"
+ #include "textblockselection.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ typedef int UserBookmarkList[3];
+
+diff --git a/latexeditorview.h b/latexeditorview.h
+index 283fd8a..1ba39cc 100644
+--- a/latexeditorview.h
++++ b/latexeditorview.h
+@@ -22,7 +22,7 @@
+ #include "gotolinewidget.h"
+ #include "replacewidget.h"
+ #include "minisplitter.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class LatexEditorView : public QWidget {
+ Q_OBJECT
+diff --git a/latexhighlighter.h b/latexhighlighter.h
+index 029c7ad..9fbb532 100644
+--- a/latexhighlighter.h
++++ b/latexhighlighter.h
+@@ -20,7 +20,7 @@
+ #include <QColor>
+ #include <QTextBlockUserData>
+ //#include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class QTextDocument;
+ class LatexEditor;
+diff --git a/spellerdialog.h b/spellerdialog.h
+index 83248ae..cd16dad 100644
+--- a/spellerdialog.h
++++ b/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff --git a/texmaker.h b/texmaker.h
+index b1a2c65..0806731 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -47,7 +47,7 @@
+ #include "symbollistwidget.h"
+ #include "xmltagslistwidget.h"
+ #include "logeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ #include "browser.h"
+ #include "pdfviewerwidget.h"
+ #include "pdfviewer.h"
+diff --git a/texmaker.pro b/texmaker.pro
+index 5d017ad..87fac99 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -4,7 +4,8 @@ TARGET = texmaker
+ QT += network \
+ xml \
+ webkit
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell
+ TEXMAKERVERSION=3.2.2
+ DEFINES += TEXMAKERVERSION=\\\"$${TEXMAKERVERSION}\\\"
+ DEFINES += HAVE_SPLASH
+@@ -65,25 +66,6 @@ HEADERS += texmaker.h \
+ scandialog.h \
+ synctex_parser.h \
+ synctex_parser_utils.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -110,7 +92,7 @@ HEADERS += texmaker.h \
+ encodingprober/nsSJISProber.h \
+ encodingprober/nsUniversalDetector.h \
+ encodingprober/qencodingprober.h \
+- encodingprober/UnicodeGroupProber.h
++ encodingprober/UnicodeGroupProber.h
+ SOURCES += main.cpp \
+ texmakerapp.cpp \
+ texmaker.cpp \
+@@ -167,18 +149,6 @@ SOURCES += main.cpp \
+ scandialog.cpp \
+ synctex_parser.c \
+ synctex_parser_utils.c \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
+@@ -271,13 +241,13 @@ isEmpty( ICONDIR ) {
+ ICONDIR=/usr/share/pixmaps
+ }
+
+-INCLUDEPATH += /usr/include/poppler/qt4
+-LIBS += -L/usr/lib -lpoppler-qt4
+-LIBS += -L/usr/lib -lz
++INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/poppler/qt4
++LIBS += -lpoppler-qt4
++LIBS += -lz
+ DEFINES += PREFIX=\\\"$${PREFIX}\\\"
+ target.path = $${PREFIX}/bin
+
+-#DEFINES += DEBIAN_SPELLDIR
++DEFINES += DEBIAN_SPELLDIR
+
+
+ INSTALLS = target
+--
+1.7.8.1
+
diff --git a/app-office/texmaker/texmaker-3.2.2.ebuild b/app-office/texmaker/texmaker-3.2.2.ebuild
new file mode 100644
index 000000000000..6e3e3280d458
--- /dev/null
+++ b/app-office/texmaker/texmaker-3.2.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-3.2.2.ebuild,v 1.1 2012/01/12 10:49:59 jlec Exp $
+
+EAPI="3"
+
+inherit base prefix qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/poppler[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/qt-gui-4.6.1:4
+ >=x11-libs/qt-core-4.6.1:4
+ >=x11-libs/qt-webkit-4.6.1:4
+ >=app-text/hunspell-1.2.4"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-hunspell.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+ eprefixify ${PN}.pro configdialog.cpp
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}