summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-06-23 15:34:31 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-06-23 15:34:31 +0000
commit1cf0e627d6628be240f39727bff89ec7539e15b9 (patch)
tree60f570665ebf3129e044c487b1b8fca6e9e9d6f7 /app-office
parentUse autotools-utils for out-of-source building, bug 474360. (diff)
downloadgentoo-2-1cf0e627d6628be240f39727bff89ec7539e15b9.tar.gz
gentoo-2-1cf0e627d6628be240f39727bff89ec7539e15b9.tar.bz2
gentoo-2-1cf0e627d6628be240f39727bff89ec7539e15b9.zip
Add l10n for 4.1 rc1 release.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice-l10n/ChangeLog8
-rw-r--r--app-office/libreoffice-l10n/files/lo_gen_langs.sh2
-rw-r--r--app-office/libreoffice-l10n/libreoffice-l10n-4.1.0.1.ebuild91
3 files changed, 99 insertions, 2 deletions
diff --git a/app-office/libreoffice-l10n/ChangeLog b/app-office/libreoffice-l10n/ChangeLog
index e50d0e84016f..5fb52b713b8c 100644
--- a/app-office/libreoffice-l10n/ChangeLog
+++ b/app-office/libreoffice-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice-l10n
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/ChangeLog,v 1.78 2013/06/20 11:37:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/ChangeLog,v 1.79 2013/06/23 15:34:31 scarabeus Exp $
+
+*libreoffice-l10n-4.1.0.1 (23 Jun 2013)
+
+ 23 Jun 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +libreoffice-l10n-4.1.0.1.ebuild, files/lo_gen_langs.sh:
+ Add l10n for 4.1 rc1 release.
*libreoffice-l10n-4.0.4.2 (20 Jun 2013)
diff --git a/app-office/libreoffice-l10n/files/lo_gen_langs.sh b/app-office/libreoffice-l10n/files/lo_gen_langs.sh
index 7c954605eb0c..eb02c365e5d6 100644
--- a/app-office/libreoffice-l10n/files/lo_gen_langs.sh
+++ b/app-office/libreoffice-l10n/files/lo_gen_langs.sh
@@ -7,7 +7,7 @@
# Find l10n packs for libreoffice and format it for use in ebuilds.
#
-VERSION=${1:-4.0.1}
+VERSION=${1:-4.1.0}
BASE_SRC_URI="http://download.documentfoundation.org/libreoffice/testing/${VERSION}/rpm/x86"
# needs lxml
diff --git a/app-office/libreoffice-l10n/libreoffice-l10n-4.1.0.1.ebuild b/app-office/libreoffice-l10n/libreoffice-l10n-4.1.0.1.ebuild
new file mode 100644
index 000000000000..f77457043cf2
--- /dev/null
+++ b/app-office/libreoffice-l10n/libreoffice-l10n-4.1.0.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/libreoffice-l10n-4.1.0.1.ebuild,v 1.1 2013/06/23 15:34:31 scarabeus Exp $
+
+EAPI=4
+
+inherit rpm eutils multilib versionator
+
+MY_PV=$(get_version_component_range 1-3)
+
+DESCRIPTION="Translations for the Libreoffice suite."
+HOMEPAGE="http://www.libreoffice.org"
+BASE_SRC_URI="http://download.documentfoundation.org/${PN/-l10n/}/testing/${MY_PV}/rpm"
+
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="offlinehelp"
+
+LANGUAGES_HELP="am ast bg bn_IN bn bo bs ca_XV ca cs da de dz el en_GB en en_ZA
+eo es et eu fi fr gl gu he hi hr hu id is it ja ka km ko mk nb ne nl nn om pl
+pt_BR pt ru si sk sl sq sv tg tr ug uk vi zh_CN zh_TW"
+LANGUAGES="${LANGUAGES_HELP} af ar as be br brx cy dgo fa ga gd kk kn kok ks ku
+lb lo lt lv mai ml mn mni mr my nr nso oc or pa_IN ro rw sa_IN sat sd sh sr
+ss st sw_TZ ta te th tn ts tt uz ve xh zu"
+
+for lang in ${LANGUAGES_HELP}; do
+ helppack=""
+ [[ ${lang} == en ]] && lang2=${lang/en/en_US} || lang2=${lang}
+ helppack="offlinehelp? ( ${BASE_SRC_URI}/x86/LibreOffice_${PV}_Linux_x86_rpm_helppack_${lang2/_/-}.tar.gz )"
+ SRC_URI+=" linguas_${lang}? ( ${helppack} )"
+done
+for lang in ${LANGUAGES}; do
+ langpack=""
+ [[ ${lang} == en ]] \
+ || langpack="${BASE_SRC_URI}/x86/LibreOffice_${PV}_Linux_x86_rpm_langpack_${lang/_/-}.tar.gz"
+ [[ -z ${langpack} ]] || SRC_URI+=" linguas_${lang}? ( ${langpack} )"
+ IUSE+=" linguas_${lang}"
+done
+unset lang helppack langpack lang2
+
+RDEPEND+="app-text/hunspell"
+
+RESTRICT="strip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+
+ local lang dir rpmdir i
+ local ooextused=()
+
+ for lang in ${LANGUAGES}; do
+ # break away if not enabled; paludis support
+ use_if_iuse linguas_${lang} || continue
+
+ dir=${lang/_/-}
+
+ # for english we provide just helppack, as translation is always there
+ if [[ ${lang} != en ]]; then
+ rpmdir="LibreOffice_${PV}_Linux_x86_rpm_langpack_${dir}/RPMS/"
+ [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
+ # First remove dictionaries, we want to use system ones.
+ rm -rf "${S}/${rpmdir}/"*dict*.rpm
+ rpm_unpack "./${rpmdir}/"*.rpm
+ fi
+ if [[ "${LANGUAGES_HELP}" =~ "${lang}" ]] && use offlinehelp; then
+ [[ ${lang} == en ]] && dir="en-US"
+ rpmdir="LibreOffice_${PV}_Linux_x86_rpm_helppack_${dir}/RPMS/"
+ [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
+ rpm_unpack ./"${rpmdir}/"*.rpm
+ fi
+ done
+}
+
+src_prepare() { :; }
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local dir="${S}"/opt/${PN/-l10n/}$(get_version_component_range 1-2)/
+ # Condition required for people that do not install anything eg no linguas
+ # or just english with no offlinehelp.
+ if [[ -d "${dir}" ]] ; then
+ insinto /usr/$(get_libdir)/${PN/-l10n/}/
+ doins -r "${dir}"/*
+ fi
+ # remove extensions that are in the l10n for some weird reason
+ rm -rf "${ED}"/usr/$(get_libdir)/${PN/-l10n/}/share/extensions/
+}