summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-12-27 22:15:03 +0000
committerPacho Ramos <pacho@gentoo.org>2012-12-27 22:15:03 +0000
commit34784df37478285d081abd9ae051561ddb1ec32b (patch)
tree4d677c98f8ef051a024b53e6663a681fef483752 /app-office
parentAdd local description for USE=bindist, bug #448922. (diff)
downloadgentoo-2-34784df37478285d081abd9ae051561ddb1ec32b.tar.gz
gentoo-2-34784df37478285d081abd9ae051561ddb1ec32b.tar.bz2
gentoo-2-34784df37478285d081abd9ae051561ddb1ec32b.zip
Version bump
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/gnumeric-1.12.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 390bb66b46be..2190e7002a74 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.235 2012/05/23 12:11:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.236 2012/12/27 22:15:03 pacho Exp $
+
+*gnumeric-1.12.0 (27 Dec 2012)
+
+ 27 Dec 2012; Pacho Ramos <pacho@gentoo.org> +gnumeric-1.12.0.ebuild:
+ Version bump
23 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> metadata.xml:
Drop unused local desc.
diff --git a/app-office/gnumeric/gnumeric-1.12.0.ebuild b/app-office/gnumeric/gnumeric-1.12.0.ebuild
new file mode 100644
index 000000000000..b0ad85ce2464
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.12.0.ebuild,v 1.1 2012/12/27 22:15:03 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://projects.gnome.org/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection perl python"
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, wait for next release
+# also fails tests due to 80-bit long story
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.28.0:2
+ >=gnome-extra/libgsf-1.14.24:=
+ >=x11-libs/goffice-0.10.0:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.0.0:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1.0.0:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.0.0:3 )
+"
+# libgda? (
+# >=gnome-extra/libgda-4.1.1:4.0
+# >=gnome-extra/libgnomedb-3.99.6:4.0 )
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ app-text/scrollkeeper"
+
+src_prepare() {
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --disable-static
+ --without-gda
+ --with-zlib
+ $(use_enable introspection)
+ $(use_with perl)
+ $(use_with python)"
+}