summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-24 23:12:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-24 23:12:23 +0000
commit4f85ef36b531654a326c2852dccdfc2597050019 (patch)
treea1c8fec7ce5c14259dccc8cb3ab3093933a7c44e /app-office
parentVersion bump (diff)
downloadgentoo-2-4f85ef36b531654a326c2852dccdfc2597050019.tar.gz
gentoo-2-4f85ef36b531654a326c2852dccdfc2597050019.tar.bz2
gentoo-2-4f85ef36b531654a326c2852dccdfc2597050019.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/orage/ChangeLog9
-rw-r--r--app-office/orage/orage-4.8.4.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index 6aa848981e05..4f1dbcfc55b3 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/orage
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.65 2012/11/28 12:33:42 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.66 2013/02/24 23:12:23 ssuominen Exp $
+
+*orage-4.8.4 (24 Feb 2013)
+
+ 24 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> +orage-4.8.4.ebuild:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> orage-4.8.3.ebuild:
EAPI5
diff --git a/app-office/orage/orage-4.8.4.ebuild b/app-office/orage/orage-4.8.4.ebuild
new file mode 100644
index 000000000000..d2958ff201f8
--- /dev/null
+++ b/app-office/orage/orage-4.8.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.8.4.ebuild,v 1.1 2013/02/24 23:12:23 ssuominen Exp $
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb dbus debug libnotify +xfce_plugins_clock"
+
+RDEPEND=">=dev-libs/libical-0.48:=
+ dev-libs/popt:=
+ >=x11-libs/gtk+-2.10:2
+ berkdb? ( >=sys-libs/db-4 )
+ dbus? ( >=dev-libs/dbus-glib-0.100 )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.10 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable xfce_plugins_clock libxfce4panel)
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+ # PM doesn't let directory to be replaced by a symlink, see src_install()
+ rm -rf "${EROOT}"/usr/share/${PN}/doc
+}
+
+src_install() {
+ xfconf_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ imagesdir="${EPREFIX}"/usr/share/doc/${PF}/html/images
+
+ # Create compability symlink for retarded path hardcoding in src/{mainbox,parameters}.c
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/doc/C
+}