summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-01-31 13:58:21 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-01-31 13:58:21 +0000
commit55d5779b67556186b84d6584e5c69c04b4672b2d (patch)
tree9d5e9b3e9a6aecf46448ab89f703fa1bab954975 /app-office
parentDrop the dependency over libo here. (diff)
downloadgentoo-2-55d5779b67556186b84d6584e5c69c04b4672b2d.tar.gz
gentoo-2-55d5779b67556186b84d6584e5c69c04b4672b2d.tar.bz2
gentoo-2-55d5779b67556186b84d6584e5c69c04b4672b2d.zip
Enforce dependency over same version translation. It should fix bug#454332.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/libreoffice-4.0.0.2.ebuild12
-rw-r--r--app-office/libreoffice/libreoffice-4.0.9999.ebuild12
-rw-r--r--app-office/libreoffice/libreoffice-9999-r2.ebuild12
4 files changed, 29 insertions, 13 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index e83950a9d7f8..9b3102da08c9 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.438 2013/01/28 18:04:28 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.439 2013/01/31 13:58:21 scarabeus Exp $
+
+ 31 Jan 2013; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-4.0.0.2.ebuild,
+ libreoffice-4.0.9999.ebuild, libreoffice-9999-r2.ebuild:
+ Enforce dependency over same version translation. It should fix bug#454332.
28 Jan 2013; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-4.0.9999.ebuild,
libreoffice-9999-r2.ebuild:
diff --git a/app-office/libreoffice/libreoffice-4.0.0.2.ebuild b/app-office/libreoffice/libreoffice-4.0.0.2.ebuild
index 1718646ec334..e68e0c7f9216 100644
--- a/app-office/libreoffice/libreoffice-4.0.0.2.ebuild
+++ b/app-office/libreoffice/libreoffice-4.0.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.0.0.2.ebuild,v 1.3 2013/01/27 08:23:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.0.0.2.ebuild,v 1.4 2013/01/31 13:58:21 scarabeus Exp $
EAPI=5
@@ -180,9 +180,13 @@ RDEPEND="${COMMON_DEPEND}
java? ( >=virtual/jre-1.6 )
"
-PDEPEND="
- =app-office/libreoffice-l10n-4.0*
-"
+if [[ ${PV} != *9999* ]]; then
+ PDEPEND="~app-office/libreoffice-l10n-${PV}"
+else
+ # Translations are not reliable on live ebuilds
+ # rather force people to use english only.
+ PDEPEND="!app-office/libreoffice-l10n"
+fi
# FIXME: cppunit should be moved to test conditional
# after everything upstream is under gbuild
diff --git a/app-office/libreoffice/libreoffice-4.0.9999.ebuild b/app-office/libreoffice/libreoffice-4.0.9999.ebuild
index a79e30e251a6..38c1d126c896 100644
--- a/app-office/libreoffice/libreoffice-4.0.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-4.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.0.9999.ebuild,v 1.19 2013/01/28 18:04:28 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.0.9999.ebuild,v 1.20 2013/01/31 13:58:21 scarabeus Exp $
EAPI=5
@@ -181,9 +181,13 @@ RDEPEND="${COMMON_DEPEND}
java? ( >=virtual/jre-1.6 )
"
-PDEPEND="
- =app-office/libreoffice-l10n-4.0*
-"
+if [[ ${PV} != *9999* ]]; then
+ PDEPEND="~app-office/libreoffice-l10n-${PV}"
+else
+ # Translations are not reliable on live ebuilds
+ # rather force people to use english only.
+ PDEPEND="!app-office/libreoffice-l10n"
+fi
# FIXME: cppunit should be moved to test conditional
# after everything upstream is under gbuild
diff --git a/app-office/libreoffice/libreoffice-9999-r2.ebuild b/app-office/libreoffice/libreoffice-9999-r2.ebuild
index 9bf57f7cdeb8..d7c60326195a 100644
--- a/app-office/libreoffice/libreoffice-9999-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.157 2013/01/28 18:04:28 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.158 2013/01/31 13:58:21 scarabeus Exp $
EAPI=5
@@ -180,9 +180,13 @@ RDEPEND="${COMMON_DEPEND}
java? ( >=virtual/jre-1.6 )
"
-PDEPEND="
- =app-office/libreoffice-l10n-4.0*
-"
+if [[ ${PV} != *9999* ]]; then
+ PDEPEND="~app-office/libreoffice-l10n-${PV}"
+else
+ # Translations are not reliable on live ebuilds
+ # rather force people to use english only.
+ PDEPEND="!app-office/libreoffice-l10n"
+fi
# FIXME: cppunit should be moved to test conditional
# after everything upstream is under gbuild