summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
commit57cfcbec70fd3ce8babfc5de34d5625964a04295 (patch)
treecd9d7a36b1389f7e6327a7101803aecbf8662d58 /app-office
parent- bah. forgot digest. (diff)
downloadgentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.tar.gz
gentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.tar.bz2
gentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/dia/dia-0.88.1.ebuild47
1 files changed, 32 insertions, 15 deletions
diff --git a/app-office/dia/dia-0.88.1.ebuild b/app-office/dia/dia-0.88.1.ebuild
index 1b1349b7ae7b..05f7e0765c5a 100644
--- a/app-office/dia/dia-0.88.1.ebuild
+++ b/app-office/dia/dia-0.88.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1.ebuild,v 1.1 2001/06/04 10:34:15 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1.ebuild,v 1.2 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,33 +9,50 @@ DESCRIPTION="Diagram Creation Program"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
-DEPEND=">=gnome-base/gnome-print-0.24
- >=app-arch/rpm-3.0.5
- bonobo? ( gnome-base/bonobo )
+DEPEND=">=gnome-base/libxml-1.8.13 nls? ( sys-devel/gettext )
+ >=gnome-base/gdk-pixbuf-0.11.0
+ >=app-arch/rpm-3.0.6
+ bonobo? ( >=gnome-base/bonobo-1.0.4 )
python? ( dev-lang/python-2.0 )"
-
+RDEPEND=">=gnome-base/libxml-1.8.13
+ >=gnome-base/gdk-pixbuf-0.11.0
+ >=app-arch/rpm-3.0.6
+ bonobo? ( >=gnome-base/bonobo-1.0.4 )"
src_compile() {
local myconf
- if [ "`use bonobo`" ]
- then
- myconf="--enable-bonobo"
+ local myprefix
+ myprefix="--prefix=/usr/X11R6 --sysconfdir=/etc/X11"
+ if [ "`use gnome`" ] ; then
+ myconf="--enable-gnome"
+ myprefix="--prefix=/opt/gnome --sysconfdir=/etc/opt/gnome"
+ else
+ myconf=""
+ fi
+
+ if [ "`use bonobo`" ]; then
+ myconf="--enable-gnome --enable-bonobo"
fi
-# if [ "`use python`" ]
-# then
+# if [ "`use python`" ] ; then
# myconf="$myconf --with-python"
# fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --sysconfdir=/etc/opt/gnome \
- --enable-gnome --enable-gnome-print ${myconf}
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ try ./configure --host=${CHOST} ${myprefix} ${myconf}
+ # enable-gnome-print not recoomended
try make
}
src_install () {
-
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+ myprefix="prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/X11"
+ if [ "`use gnome`" ] ; then
+ myconf="--enable-gnome"
+ myprefix="prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome"
+ fi
+ try make $myprefix install
dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
}