summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-06 13:07:55 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-06 13:07:55 +0000
commit610aef04583b39b290cb807762d5aea8c69d12c4 (patch)
tree721150fa1420e06a3e54340e3010dfde012ac75b /app-office
parentFix unpacking help for not-supported langs. Fixes bug #382031. (diff)
downloadgentoo-2-610aef04583b39b290cb807762d5aea8c69d12c4.tar.gz
gentoo-2-610aef04583b39b290cb807762d5aea8c69d12c4.tar.bz2
gentoo-2-610aef04583b39b290cb807762d5aea8c69d12c4.zip
Apply patch to disable striping, we handle it by PM.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/files/libreoffice-honor-strip.patch44
-rw-r--r--app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild3
-rw-r--r--app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild3
4 files changed, 54 insertions, 3 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index c7afc66b0252..31a4d9c41a45 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.128 2011/09/05 17:01:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.129 2011/09/06 13:07:55 scarabeus Exp $
+
+ 06 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libreoffice-3.4.3.2-r1.ebuild, libreoffice-3.4.9999-r1.ebuild,
+ +files/libreoffice-honor-strip.patch:
+ Apply patch to disable striping, we handle it by PM.
05 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
libreoffice-3.4.3.2-r1.ebuild, libreoffice-3.4.9999-r1.ebuild,
diff --git a/app-office/libreoffice/files/libreoffice-honor-strip.patch b/app-office/libreoffice/files/libreoffice-honor-strip.patch
new file mode 100644
index 000000000000..1d15802ede49
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-honor-strip.patch
@@ -0,0 +1,44 @@
+From dcdcc53e25fce09be486d4ea700f8a72895a1e69 Mon Sep 17 00:00:00 2001
+From: Stephan Bergmann <sbergman@redhat.com>
+Date: Tue, 06 Sep 2011 07:39:07 +0000
+Subject: Honor --disable-strip in gbuild.
+
+---
+diff --git a/solenv/gbuild/gbuild.mk b/solenv/gbuild/gbuild.mk
+index 48bebeb..329eefa 100644
+--- a/solenv/gbuild/gbuild.mk
++++ b/solenv/gbuild/gbuild.mk
+@@ -87,6 +87,12 @@ else
+ gb_SYMBOL := $(false)
+ endif
+
++ifeq ($(strip $(DISABLE_STRIP)$(disable_strip)),)
++gb_STRIP := $(true)
++else
++gb_STRIP := $(false)
++endif
++
+ gb_DEBUGLEVEL := 0
+ ifneq ($(strip $(DEBUG)$(debug)),)
+ gb_DEBUGLEVEL := 1
+diff --git a/solenv/gbuild/platform/unxgcc.mk b/solenv/gbuild/platform/unxgcc.mk
+index 4234c71..5c71bd4 100644
+--- a/solenv/gbuild/platform/unxgcc.mk
++++ b/solenv/gbuild/platform/unxgcc.mk
+@@ -163,9 +163,11 @@ gb_LinkTarget_LDFLAGS += \
+ endif
+
+ ifneq ($(gb_SYMBOL),$(true))
+-gb_LinkTarget_LDFLAGS += \
+- -Wl,--strip-all \
+-
++ifeq ($(gb_STRIP),$(true))
++gb_LinkTarget_LDFLAGS += -Wl,--strip-all
++else
++gb_LinkTarget_LDFLAGS += -Wl,--strip-debug
++endif
+ endif
+
+ ifneq ($(gb_DEBUGLEVEL),0)
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
index eb13e002b5d7..cf6faf4fbfb0 100644
--- a/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.5 2011/09/05 17:01:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild,v 1.6 2011/09/06 13:07:55 scarabeus Exp $
EAPI=3
@@ -226,6 +226,7 @@ PATCHES=(
"${FILESDIR}/${PN}-32b-qt4-libdir.patch"
"${FILESDIR}/${PN}-binfilter-as-needed.patch"
"${FILESDIR}/${PN}-kill-cppunit.patch"
+ "${FILESDIR}/${PN}-honor-strip.patch"
)
# Uncoment me when updating to eapi4
diff --git a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
index 557fcbf7168f..53d7c26eda28 100644
--- a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.5 2011/09/05 17:01:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.6 2011/09/06 13:07:55 scarabeus Exp $
EAPI=3
@@ -226,6 +226,7 @@ PATCHES=(
"${FILESDIR}/${PN}-32b-qt4-libdir.patch"
"${FILESDIR}/${PN}-binfilter-as-needed.patch"
"${FILESDIR}/${PN}-kill-cppunit.patch"
+ "${FILESDIR}/${PN}-honor-strip.patch"
)
# Uncoment me when updating to eapi4