summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-02-03 20:31:01 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-02-03 20:31:01 +0000
commit77a5a12ce5b079658833125339ae5f10abceafbd (patch)
tree0fb43d2940ee16222cec86ecdb358a9e72cd71d1 /app-office
parentUpdate version; Also update version of 1.7 versions to 1.7.9 (Manifest recom... (diff)
downloadgentoo-2-77a5a12ce5b079658833125339ae5f10abceafbd.tar.gz
gentoo-2-77a5a12ce5b079658833125339ae5f10abceafbd.tar.bz2
gentoo-2-77a5a12ce5b079658833125339ae5f10abceafbd.zip
remove cruft and a shot at fixing distcc
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-ximian/ChangeLog14
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.1.50.ebuild44
-rw-r--r--app-office/openoffice/ChangeLog13
-rw-r--r--app-office/openoffice/openoffice-1.1.0-r3.ebuild45
4 files changed, 29 insertions, 87 deletions
diff --git a/app-office/openoffice-ximian/ChangeLog b/app-office/openoffice-ximian/ChangeLog
index 9ffc473f3b3d..488a0f9cdb96 100644
--- a/app-office/openoffice-ximian/ChangeLog
+++ b/app-office/openoffice-ximian/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-office/openoffice-ximian
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.19 2004/01/28 13:56:56 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.20 2004/02/03 20:27:41 suka Exp $
+
+ 03 Feb 2004; suka <suka@gentoo.org> openoffice-ximian-1.1.50.ebuild:
+ This update further simplifies the ebuild and aims to fix the distcc
+ problems. Even better parallel build COULD now work for you, at least it does
+ for me, as it is not tested enough you will have to explicitely force the
+ ebuild to build in parallel / use more cpus. If you dare to try out emerge the
+ ebuild like:
+
+ 'ECPUS="n" emerge openoffice-ximian'
+
+ where n has to be exchanged with the number of processes / CPUs you want to
+ use. No guarantee whatsoever that it will work for you :-)
28 Jan 2004; suka <suka@gentoo.org> openoffice-ximian-1.1.46.ebuild,
openoffice-ximian-1.1.47.3.ebuild, openoffice-ximian-1.1.49.2-r1.ebuild,
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.1.50.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.1.50.ebuild
index 9493f002d723..3ccf6c6665d7 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.1.50.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.1.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.50.ebuild,v 1.3 2004/01/28 13:56:56 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.50.ebuild,v 1.4 2004/02/03 20:27:41 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -269,15 +269,6 @@ src_unpack() {
perl -pi -e "s|^CFLAGSCXX=.*|CFLAGSCXX=${CXXFLAGS}|g" \
${S}/solenv/inc/unxlngi4.mk
- # Some makefiles are not multiprocess ready (Mandrake)
- cd ${S}; einfo "Fixing makefiles for multiprocess builds..."
- for x in io/source/stm dtrans/source/X11 idlc/source nas zlib toolkit/util \
- comphelper/util padmin/source svtools/util bridges/source/prot_uno \
- framework/util framework/source/unotypes
- do
- perl -pi -e "s/^(PRJNAME)/MAXPROCESS=1\n\1/" ${x}/makefile.mk
- done
-
#Do our own branding by setting gentoo linux as the vendor
sed -i -e "s,\(//\)\(.*\)\(my company\),\2Gentoo Linux," ${S}/offmgr/source/offapp/intro/ooo.src
}
@@ -306,37 +297,6 @@ src_compile() {
oo_setup
- # Setup default compilers (We overide gcc2 if that is default here)
- export CC="$(gcc-getCC)"
- export CXX="$(gcc-getCXX)"
-
- # Enable new ccache for this build
- if [ "${FEATURES/-ccache/}" = "${FEATURES}" -a \
- "${FEATURES/ccache/}" != "${FEATURES}" -a \
- -x /usr/bin/ccache -a ! -d /usr/bin/ccache ]
- then
- einfo "We're using ccache for this build..."
- # Build uses its own env with $PATH, etc, so
- # we take the easy way out. (Az)
- export CC="/usr/bin/ccache ${CC}"
- export CXX="/usr/bin/ccache ${CXX}"
- fi
-
- # Enable distcc for this build (Az)
- if [ "${FEATURES/-distcc/}" = "${FEATURES}" -a \
- "${FEATURES/distcc/}" != "${FEATURES}" -a \
- -x /usr/bin/distcc ]
- then
- einfo "We're using distcc for this build..."
- # Do not bump ECPUS if the user did not touch it, as currently
- # it -PP do not work properly (segfaulting). (Az)
- [ "$(echo ${DISTCC_HOSTS} | wc -w)" -gt 1 -a "${ECPUS}" -qt 1 ] && \
- export ECPUS="$(echo ${DISTCC_HOSTS} | wc -w)"
-
- export CC="distcc ${CC}"
- export CXX="distcc ${CXX}"
- fi
-
# dmake security patch
cd ${S}/dmake
autoconf || die
@@ -370,7 +330,7 @@ src_compile() {
# Should the build use multiprocessing?
if [ "${ECPUS}" -gt 1 ]
then
- buildcmd="${S}/solenv/bin/build.pl --all -P ${ECPUS} product=full --dlv_switch link"
+ buildcmd="${S}/solenv/bin/build.pl --all -P${ECPUS} product=full --dlv_switch link"
else
buildcmd="${S}/solenv/bin/build.pl --all product=full --dlv_switch link"
fi
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 2eb9dbd7a11b..95992c2b7f73 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.54 2004/01/24 11:19:26 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.55 2004/02/03 20:31:01 suka Exp $
+
+ 03 Feb 2004; suka <suka@gentoo.org> openoffice-1.1.0-r3.ebuild:
+ This update further simplifies the ebuild and aims to fix the distcc problems.
+ Even better parallel build COULD now work for you, at least it does for me, as
+ it is not tested enough you will have to explicitely force the ebuild to build
+ in parallel / use more cpus. If you dare to try out emerge the ebuild like:
+
+ 'ECPUS="n" emerge openoffice'
+
+ where n has to be exchanged with the number of processes / CPUs you want to
+ use. No guarantee whatsoever that it will work for you :-)
24 Jan 2004; <paul@gentoo.org> openoffice-1.1.0-r1.ebuild,
openoffice-1.1.0.ebuild:
diff --git a/app-office/openoffice/openoffice-1.1.0-r3.ebuild b/app-office/openoffice/openoffice-1.1.0-r3.ebuild
index ada700f429e6..72269b6d9fa5 100644
--- a/app-office/openoffice/openoffice-1.1.0-r3.ebuild
+++ b/app-office/openoffice/openoffice-1.1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r3.ebuild,v 1.4 2004/01/24 14:53:52 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r3.ebuild,v 1.5 2004/02/03 20:31:01 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -281,16 +281,6 @@ src_unpack() {
perl -pi -e "s|^CFLAGSCXX=.*|CFLAGSCXX=${CXXFLAGS}|g" \
${S}/solenv/inc/unxlngi4.mk
-
- # Some makefiles are not multiprocess ready (Mandrake)
- cd ${S}; einfo "Fixing makefiles for multiprocess builds..."
- for x in io/source/stm dtrans/source/X11 idlc/source nas zlib toolkit/util \
- comphelper/util padmin/source svtools/util bridges/source/prot_uno \
- framework/util framework/source/unotypes
- do
- perl -pi -e "s/^(PRJNAME)/MAXPROCESS=1\n\1/" ${x}/makefile.mk
- done
-
#Do our own branding by setting gentoo linux as the vendor
sed -i -e "s,\(//\)\(.*\)\(my company\),\2Gentoo Linux," ${S}/offmgr/source/offapp/intro/ooo.src
}
@@ -320,37 +310,6 @@ src_compile() {
oo_setup
- # Setup default compilers (We overide gcc2 if that is default here)
- export CC="$(gcc-getCC)"
- export CXX="$(gcc-getCXX)"
-
- # Enable new ccache for this build
- if [ "${FEATURES/-ccache/}" = "${FEATURES}" -a \
- "${FEATURES/ccache/}" != "${FEATURES}" -a \
- -x /usr/bin/ccache -a ! -d /usr/bin/ccache ]
- then
- einfo "We're using ccache for this build..."
- # Build uses its own env with $PATH, etc, so
- # we take the easy way out. (Az)
- export CC="/usr/bin/ccache ${CC}"
- export CXX="/usr/bin/ccache ${CXX}"
- fi
-
- # Enable distcc for this build (Az)
- if [ "${FEATURES/-distcc/}" = "${FEATURES}" -a \
- "${FEATURES/distcc/}" != "${FEATURES}" -a \
- -x /usr/bin/distcc ]
- then
- einfo "We're using distcc for this build..."
- # Do not bump ECPUS if the user did not touch it, as currently
- # it -PP do not work properly (segfaulting). (Az)
- [ "$(echo ${DISTCC_HOSTS} | wc -w)" -gt 1 -a "${ECPUS}" -qt 1 ] && \
- export ECPUS="$(echo ${DISTCC_HOSTS} | wc -w)"
-
- export CC="distcc ${CC}"
- export CXX="distcc ${CXX}"
- fi
-
# Do NOT compile with a external STLport, as gcc-2.95.3 users will
# get linker errors due to the ABI being different (STLport will be
# compiled with 2.95.3, while OO is compiled with 3.x). (Az)
@@ -372,7 +331,7 @@ src_compile() {
# We use build.pl directly, as dmake tends to segfault. (Az)
if [ "${ECPUS}" -gt 1 ]
then
- buildcmd="${S}/solenv/bin/build.pl --all -P ${ECPUS} product=full"
+ buildcmd="${S}/solenv/bin/build.pl --all -P${ECPUS} product=full"
else
buildcmd="${S}/solenv/bin/build.pl --all product=full"
fi