summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 16:34:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 16:34:58 +0000
commit79c6b38c062025fc735f2946707b076f529ddc42 (patch)
tree598b234a16f09cd208bf4fa8d986acfb09a02615 /app-office
parentUpdate to 1.6.0 final. (diff)
downloadgentoo-2-79c6b38c062025fc735f2946707b076f529ddc42.tar.gz
gentoo-2-79c6b38c062025fc735f2946707b076f529ddc42.tar.bz2
gentoo-2-79c6b38c062025fc735f2946707b076f529ddc42.zip
Update to 1.6.0 final.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice-libs/ChangeLog9
-rw-r--r--app-office/koffice-libs/files/digest-koffice-libs-1.6.03
-rw-r--r--app-office/koffice-libs/koffice-libs-1.6.0.ebuild64
3 files changed, 75 insertions, 1 deletions
diff --git a/app-office/koffice-libs/ChangeLog b/app-office/koffice-libs/ChangeLog
index b9e155ab90c1..8a2776a81b41 100644
--- a/app-office/koffice-libs/ChangeLog
+++ b/app-office/koffice-libs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/koffice-libs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.58 2006/10/17 20:22:13 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.59 2006/10/19 16:34:57 flameeyes Exp $
+
+*koffice-libs-1.6.0 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -koffice-libs-1.6_beta1.ebuild, -koffice-libs-1.6_rc1.ebuild,
+ +koffice-libs-1.6.0.ebuild:
+ Update to 1.6.0 final.
17 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
koffice-libs-1.5.2.ebuild:
diff --git a/app-office/koffice-libs/files/digest-koffice-libs-1.6.0 b/app-office/koffice-libs/files/digest-koffice-libs-1.6.0
new file mode 100644
index 000000000000..2e01d4cedd36
--- /dev/null
+++ b/app-office/koffice-libs/files/digest-koffice-libs-1.6.0
@@ -0,0 +1,3 @@
+MD5 e669cf19b2e1c7db7029c0772c527c0d koffice-1.6.0.tar.bz2 56718478
+RMD160 be09c18005eb33f6dc35ab0359cc97a8a658ce7c koffice-1.6.0.tar.bz2 56718478
+SHA256 9eddaae640ada9bd184f001e2489854daf7094b73e5f15b0b8deffb4cc654ae2 koffice-1.6.0.tar.bz2 56718478
diff --git a/app-office/koffice-libs/koffice-libs-1.6.0.ebuild b/app-office/koffice-libs/koffice-libs-1.6.0.ebuild
new file mode 100644
index 000000000000..11c0629ebeef
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-1.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-1.6.0.ebuild,v 1.1 2006/10/19 16:34:57 flameeyes Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+KMMODULE=lib
+inherit kde-meta eutils
+
+DESCRIPTION="Shared KOffice libraries."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-data)
+ virtual/python
+ dev-lang/ruby"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+KMEXTRA="interfaces/
+ plugins/
+ tools/
+ filters/olefilters/
+ filters/xsltfilter/
+ filters/generic_wrapper/
+ kounavail/
+ doc/api/
+ doc/koffice/
+ doc/thesaurus/"
+
+KMEXTRACTONLY="
+ kchart/kdchart/"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # Force the compilation of libkopainter.
+ sed -i 's:$(KOPAINTERDIR):kopainter:' $S/lib/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}
+
+src_compile() {
+ local myconf="--enable-scripting --with-pythonfir=${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ kde-meta_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde-meta_src_install
+ if use doc; then
+ make DESTDIR=${D} install-apidox || die
+ fi
+}