summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 22:54:26 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 22:54:26 +0000
commit8d857a180eef3fb9e130bd6a4ce0683061ff9bc5 (patch)
treec1f2bb93649f66b887fd1388da2e4ecdff01fc2e /app-office
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadgentoo-2-8d857a180eef3fb9e130bd6a4ce0683061ff9bc5.tar.gz
gentoo-2-8d857a180eef3fb9e130bd6a4ce0683061ff9bc5.tar.bz2
gentoo-2-8d857a180eef3fb9e130bd6a4ce0683061ff9bc5.zip
Changed einstall||die to einstall
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/gnucash-1.6.8.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/app-office/gnucash/gnucash-1.6.8.ebuild b/app-office/gnucash/gnucash-1.6.8.ebuild
index a937fd353577..398f5ea0b5c2 100644
--- a/app-office/gnucash/gnucash-1.6.8.ebuild
+++ b/app-office/gnucash/gnucash-1.6.8.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.8.ebuild,v 1.3 2002/11/06 15:02:09 leonardop Exp $
-
-IUSE="nls postgres"
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.8.ebuild,v 1.4 2002/11/30 22:54:26 vapier Exp $
inherit flag-o-matic
-
-S=${WORKDIR}/${P}
DESCRIPTION="A personal finance manager"
SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnucash.org/"
+
KEYWORDS="x86 ppc"
SLOT="0"
LICENSE="GPL-2"
+IUSE="nls postgres"
RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
>=dev-libs/libxml-1.8.3
@@ -22,7 +20,6 @@ RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
>=gnome-extra/guppi-0.35.5-r2
>=gnome-base/gnome-print-0.21
postgres? ( dev-db/postgresql )"
-
DEPEND="${RDEPEND}
>=sys-devel/perl-5
>=dev-libs/slib-2.3.8
@@ -34,7 +31,6 @@ DEPEND="${RDEPEND}
gnome-base/libghttp
nls? ( sys-devel/gettext )"
-
# won't configure with this
filter-flags -fomit-frame-pointer
@@ -62,14 +58,12 @@ src_compile() {
use nls || myconf="--disable-nls"
use postgres && myconf="$myconf --enable-sql"
- econf --enable-rpc \
- $myconf || die "Configuration failed"
+ econf --enable-rpc ${myconf}
make || die # Doesn't work with make -j 4 (hallski)
}
-src_install () {
- einstall || die "Installation failed"
-
- dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+src_install() {
+ einstall
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
}