summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-08-14 15:53:14 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-08-14 15:53:14 +0000
commitbfee8295642a7d709e2f44d985a75b9d854788c7 (patch)
tree56a92f35f754cff74fed4edcc0acfdbf3624a43b /app-office
parentadd 2.*.29 (diff)
downloadgentoo-2-bfee8295642a7d709e2f44d985a75b9d854788c7.tar.gz
gentoo-2-bfee8295642a7d709e2f44d985a75b9d854788c7.tar.bz2
gentoo-2-bfee8295642a7d709e2f44d985a75b9d854788c7.zip
Added taxbird 0.10 to the tree.
(Portage version: 2.1.2.11)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/taxbird/ChangeLog7
-rw-r--r--app-office/taxbird/files/digest-taxbird-0.103
-rw-r--r--app-office/taxbird/taxbird-0.10.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/app-office/taxbird/ChangeLog b/app-office/taxbird/ChangeLog
index c2d8c879799e..31e2bfc3b383 100644
--- a/app-office/taxbird/ChangeLog
+++ b/app-office/taxbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taxbird
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.7 2007/02/21 22:51:24 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.8 2007/08/14 15:53:14 wrobel Exp $
+
+*taxbird-0.10 (14 Aug 2007)
+
+ 14 Aug 2007; wrobel@gentoo.org +taxbird-0.10.ebuild:
+ Added taxbird 0.10 to the tree.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-office/taxbird/files/digest-taxbird-0.10 b/app-office/taxbird/files/digest-taxbird-0.10
new file mode 100644
index 000000000000..5aadddd96f5c
--- /dev/null
+++ b/app-office/taxbird/files/digest-taxbird-0.10
@@ -0,0 +1,3 @@
+MD5 e2cbe8409bf2c5149b1787a9f4409176 taxbird-0.10.tar.gz 249874
+RMD160 adccf174046b63a59467129f24942df96af1ea19 taxbird-0.10.tar.gz 249874
+SHA256 2178b3dc3174b743d6c76970709045dcef462973af5b6244d4a471e1e99b73fe taxbird-0.10.tar.gz 249874
diff --git a/app-office/taxbird/taxbird-0.10.ebuild b/app-office/taxbird/taxbird-0.10.ebuild
new file mode 100644
index 000000000000..84e610ae7e2f
--- /dev/null
+++ b/app-office/taxbird/taxbird-0.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.10.ebuild,v 1.1 2007/08/14 15:53:14 wrobel Exp $
+
+inherit eutils fdo-mime flag-o-matic
+
+DESCRIPTION="Taxbird provides a GUI to submit tax forms to the german digital tax project ELSTER."
+HOMEPAGE="http://www.taxbird.de/"
+
+SRC_URI="http://www.taxbird.de/download/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+dev-libs/libgeier
+dev-libs/openssl
+=gnome-extra/gtkhtml-2*
+gnome-base/libgnomeui
+sys-devel/gettext
+dev-scheme/guile"
+
+pkg_setup() {
+ filter-ldflags -Wl,--as-needed --as-needed
+}
+
+src_compile() {
+
+ econf || die "Configure failed!"
+ emake || die "Make failed!"
+
+}
+
+src_install() {
+
+ dodoc README*
+
+ einstall || die "Installation failed!"
+
+ # clean out the installed mime files, those get recreated in the pkg_postinst function
+ einfo "Deleting mime files in ${D}/usr/share/mime"
+ rm -f ${D}/usr/share/mime/{aliases,globs,magic,mime.cache,subclasses,XMLnamespaces}
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}