summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-06 16:55:51 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-06 16:55:51 +0000
commitc1b705882df70924a622b831d47965ae736b2306 (patch)
tree6c2a403a87d7c1d2d94d4797ce6461007dfa26b3 /app-office
parent*** empty log message *** (diff)
downloadgentoo-2-c1b705882df70924a622b831d47965ae736b2306.tar.gz
gentoo-2-c1b705882df70924a622b831d47965ae736b2306.tar.bz2
gentoo-2-c1b705882df70924a622b831d47965ae736b2306.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/gnumeric-0.65.ebuild65
1 files changed, 48 insertions, 17 deletions
diff --git a/app-office/gnumeric/gnumeric-0.65.ebuild b/app-office/gnumeric/gnumeric-0.65.ebuild
index 9df77e53551d..e88abe808b69 100644
--- a/app-office/gnumeric/gnumeric-0.65.ebuild
+++ b/app-office/gnumeric/gnumeric-0.65.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.65.ebuild,v 1.1 2001/06/04 10:34:15 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.65.ebuild,v 1.2 2001/06/06 16:55:51 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,13 +9,22 @@ DESCRIPTION="gnumeric"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
-DEPEND=">=sys-devel/perl-5
- >=dev-lang/python-2.0
- >=gnome-base/gal-0.3.0
- >=gnome-libs/gb-0.0.17
- >=gnome-libs/libole2-0.1.7
- bonobo? ( >=gnome-base/bonobo-0.28
- >=gnome-libs/libgda-0.2.0 ) "
+DEPEND=">=gnome-base/gnome-print-0.29
+ >=gnome-base/gal-0.8.0
+ >=gnome-libs/libole2-0.2.3
+ >=dev-util/xml-i18n-tools-0.8.4
+ perl? ( >=sys-devel/perl-5 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( >=gnome-libs/gb-0.0.19 )
+ libgda? ( >=gnome-libs/libgda-0.2.9 )
+ nls? ( sys-devel/gettext )
+ bonobo? ( >=gnome-base/bonobo-1.0 )"
+
+RDEPEND=">=gnome-base/gnome-print-0.29
+ >=gnome-base/gal-0.8.0
+ gb? ( >=gnome-libs/gb-0.0.19 )
+ libgda? ( >=gnome-libs/libgda-0.2.9 )
+ bonobo? ( >=gnome-base/bonobo-1.0 ) "
src_unpack() {
unpack ${A}
@@ -24,21 +33,43 @@ src_unpack() {
sed -e 's:"%d,:"%d",:' configure.orig > configure
}
-src_compile() {
- cd ${S}
+src_compile() {
local myconf
- if [ "`use bonobo`" ]
- then
- myconf="--with-bonobo"
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ "`use bonobo`" ] ; then
+ myconf="$myconf --with-bonobo"
+ else
+ myconf="$myconf --without-bonobo"
+ fi
+ if [ "`use gb`" ]; then
+ #does not work atm
+ myconf="$myconf --without-gb"
+ else
+ myconf="$myconf --without-gb"
fi
- LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
- ${myconf} --with-gb
+ if [ "`use perl`" ]; then
+ myconf="$myconf --with-perl"
+ else
+ myconf="$myconf --without-perl"
+ fi
+ if [ "`use python`" ]; then
+ myconf="$myconf --with-python"
+ else
+ myconf="$myconf --without-python"
+ fi
+ if [ "`use libgda`" ]; then
+ myconf="$myconf --with-gda"
+ else
+ myconf="$myconf --without-gda"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome ${myconf}
cd ${S}
try make
}
-src_install() {
- cd ${S}
+src_install() {
try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO