summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-24 18:42:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-24 18:42:02 +0000
commitcb8eede9aa7e998629acb747bd8b7923cc7eb0dd (patch)
tree7512d6f1c530858e02bc00dcdca600db0b9d0405 /app-office
parentversion bump (diff)
downloadgentoo-2-cb8eede9aa7e998629acb747bd8b7923cc7eb0dd.tar.gz
gentoo-2-cb8eede9aa7e998629acb747bd8b7923cc7eb0dd.tar.bz2
gentoo-2-cb8eede9aa7e998629acb747bd8b7923cc7eb0dd.zip
Enable both sqlite and mysql by default to ease user transition
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/akonadi-server/ChangeLog7
-rw-r--r--app-office/akonadi-server/akonadi-server-1.9.0.ebuild19
-rw-r--r--app-office/akonadi-server/akonadi-server-1.9.1-r1.ebuild19
-rw-r--r--app-office/akonadi-server/akonadi-server-1.9.1.ebuild19
4 files changed, 42 insertions, 22 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index e82ff0ac3dd2..0f0bb6cdbc4d 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.103 2013/03/20 13:38:54 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.104 2013/03/24 18:42:02 dilfridge Exp $
+
+ 24 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ akonadi-server-1.9.0.ebuild, akonadi-server-1.9.1.ebuild,
+ akonadi-server-1.9.1-r1.ebuild:
+ Enable both sqlite and mysql by default to ease user transition
*akonadi-server-1.9.1-r1 (20 Mar 2013)
diff --git a/app-office/akonadi-server/akonadi-server-1.9.0.ebuild b/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
index c9c3fa6f08b8..c233e2d12c04 100644
--- a/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.0.ebuild,v 1.5 2013/03/02 19:34:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.0.ebuild,v 1.6 2013/03/24 18:42:02 dilfridge Exp $
EAPI=4
@@ -22,7 +22,7 @@ HOMEPAGE="http://pim.kde.org/akonadi"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+mysql postgres sqlite test"
+IUSE="+mysql postgres +sqlite test"
CDEPEND="
dev-libs/boost
@@ -72,13 +72,18 @@ pkg_setup() {
fi
# Notify about MySQL not being default anymore
- if ! use sqlite && has_version "<=${CATEGORY}/${PN}-1.9.0[sqlite]"; then
+ if has_version "<=${CATEGORY}/${PN}-1.9.0[sqlite]"; then
ewarn
- ewarn "The default storage drive has changed from SQLite to MySQL."
- ewarn "If you want to stay with SQLite, enable the sqlite USE flag and reinstall"
- ewarn "${CATEGORY}/${PN}."
- ewarn "Otherwise, select a different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "In particular, kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ ewarn "To ease the transition, this akonadi-server ebuild has enabled both sqlite"
+ ewarn "and mysql backend by default. Future stable versions will by default"
+ ewarn "disable the sqlite backend."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
fi
}
diff --git a/app-office/akonadi-server/akonadi-server-1.9.1-r1.ebuild b/app-office/akonadi-server/akonadi-server-1.9.1-r1.ebuild
index 5557d1055deb..88fea28624d3 100644
--- a/app-office/akonadi-server/akonadi-server-1.9.1-r1.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.9.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.1-r1.ebuild,v 1.1 2013/03/20 13:38:54 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.1-r1.ebuild,v 1.2 2013/03/24 18:42:02 dilfridge Exp $
EAPI=4
@@ -22,7 +22,7 @@ HOMEPAGE="http://pim.kde.org/akonadi"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+mysql postgres sqlite test"
+IUSE="+mysql postgres +sqlite test"
CDEPEND="
dev-libs/boost
@@ -72,13 +72,18 @@ pkg_setup() {
fi
# Notify about MySQL not being default anymore
- if ! use sqlite && has_version "<=${CATEGORY}/${PN}-1.9.0[sqlite]"; then
+ if has_version "<=${CATEGORY}/${PN}-1.9.0[sqlite]"; then
ewarn
- ewarn "The default storage drive has changed from SQLite to MySQL."
- ewarn "If you want to stay with SQLite, enable the sqlite USE flag and reinstall"
- ewarn "${CATEGORY}/${PN}."
- ewarn "Otherwise, select a different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "In particular, kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ ewarn "To ease the transition, this akonadi-server ebuild has enabled both sqlite"
+ ewarn "and mysql backend by default. Future stable versions will by default"
+ ewarn "disable the sqlite backend."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
fi
}
diff --git a/app-office/akonadi-server/akonadi-server-1.9.1.ebuild b/app-office/akonadi-server/akonadi-server-1.9.1.ebuild
index 4c4647f6ac17..932575c8c0c8 100644
--- a/app-office/akonadi-server/akonadi-server-1.9.1.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.1.ebuild,v 1.2 2013/03/04 19:14:29 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.9.1.ebuild,v 1.3 2013/03/24 18:42:02 dilfridge Exp $
EAPI=4
@@ -22,7 +22,7 @@ HOMEPAGE="http://pim.kde.org/akonadi"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+mysql postgres sqlite test"
+IUSE="+mysql postgres +sqlite test"
CDEPEND="
dev-libs/boost
@@ -72,13 +72,18 @@ pkg_setup() {
fi
# Notify about MySQL not being default anymore
- if ! use sqlite && has_version "<=${CATEGORY}/${PN}-1.9.0[sqlite]"; then
+ if has_version "<=${CATEGORY}/${PN}-1.9.0[sqlite]"; then
ewarn
- ewarn "The default storage drive has changed from SQLite to MySQL."
- ewarn "If you want to stay with SQLite, enable the sqlite USE flag and reinstall"
- ewarn "${CATEGORY}/${PN}."
- ewarn "Otherwise, select a different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "In particular, kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ ewarn "To ease the transition, this akonadi-server ebuild has enabled both sqlite"
+ ewarn "and mysql backend by default. Future stable versions will by default"
+ ewarn "disable the sqlite backend."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
fi
}