summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-31 14:53:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-31 14:53:31 +0000
commitcce2b4b736832251edf49b1e180dd844f7dcba7e (patch)
treeed667ea6e914283c95839973538598ccfea7f7c9 /app-office
parentStable on amd64 and x86. Way way better than mtpfs itself. (diff)
downloadgentoo-2-cce2b4b736832251edf49b1e180dd844f7dcba7e.tar.gz
gentoo-2-cce2b4b736832251edf49b1e180dd844f7dcba7e.tar.bz2
gentoo-2-cce2b4b736832251edf49b1e180dd844f7dcba7e.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/gnumeric-1.12.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index ba4c0bda9bd6..8ea7d37af744 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.244 2013/03/29 13:21:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.245 2013/03/31 14:53:31 eva Exp $
+
+*gnumeric-1.12.1 (31 Mar 2013)
+
+ 31 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> +gnumeric-1.12.1.ebuild:
+ Version bump.
29 Mar 2013; Agostino Sarubbo <ago@gentoo.org> gnumeric-1.12.0-r1.ebuild:
Stable for ia64, wrt bug #458984
diff --git a/app-office/gnumeric/gnumeric-1.12.1.ebuild b/app-office/gnumeric/gnumeric-1.12.1.ebuild
new file mode 100644
index 000000000000..87a8b7cbbd58
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.12.1.ebuild,v 1.1 2013/03/31 14:53:31 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://projects.gnome.org/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection perl python"
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, wait for next release
+# also fails tests due to 80-bit long story
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.28:2
+ >=gnome-extra/libgsf-1.14.24:=
+ >=x11-libs/goffice-0.10.1:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+"
+# libgda? (
+# >=gnome-extra/libgda-4.1.1:4.0
+# >=gnome-extra/libgnomedb-3.99.6:4.0 )
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-ssindex \
+ --disable-static \
+ --without-gda \
+ --with-zlib \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}