summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-06-01 06:34:09 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-06-01 06:34:09 +0000
commitd2ecc90646a7cce1361bb6f76dab2a0f3f2692c4 (patch)
treeb67dd6809cbef5286ad93ef65e5ce4d211d4867a /app-office
parentbump (diff)
downloadgentoo-2-d2ecc90646a7cce1361bb6f76dab2a0f3f2692c4.tar.gz
gentoo-2-d2ecc90646a7cce1361bb6f76dab2a0f3f2692c4.tar.bz2
gentoo-2-d2ecc90646a7cce1361bb6f76dab2a0f3f2692c4.zip
bump
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/Manifest4
-rw-r--r--app-office/abiword/abiword-1.0.6.ebuild85
-rw-r--r--app-office/abiword/files/digest-abiword-1.0.61
4 files changed, 94 insertions, 3 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index fc4eeb4eb7b4..2a096402c92b 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.35 2003/05/16 16:25:00 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.36 2003/06/01 06:34:06 lostlogic Exp $
+
+*abiword-1.0.6 (01 Jun 2003)
+
+ 01 Jun 2003; Brandon Low <lostlogic@gentoo.org> abiword-1.0.6.ebuild:
+ Bump
*abiword-1.9.1 (16 May 2003)
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index 1ebed0d9985e..f22a92c81194 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,8 +1,8 @@
MD5 abc2e2533728780d556f1b3b4f76208b abiword-1.0.2-r1.ebuild 4692
-MD5 24e5e79582e10e3a1bde1472b096c790 abiword-1.0.6.ebuild 2012
+MD5 c5ae3337735d638b699db192edaf03b0 abiword-1.0.6.ebuild 2017
MD5 621e5db238b3aea21cf8dbb65aa6f5fb abiword-1.0.3.ebuild 4648
MD5 2b025fa06432cfef4ab76f015d7af6af abiword-1.9.1.ebuild 2385
-MD5 66587de07ad9c7a8ee5dfa7b111d1eaf ChangeLog 5871
+MD5 84ae01c6ff5a9ac56d79130ff30a2014 ChangeLog 5985
MD5 24e5e79582e10e3a1bde1472b096c790 abiword-1.0.5.ebuild 2012
MD5 4ab387fa04b0102a395a4b654f0714df files/abiword-1.1.4-wv_configure_fooling.patch 1575
MD5 ec999635047cabecdcece23cd40d4bd9 files/digest-abiword-1.0.3 67
diff --git a/app-office/abiword/abiword-1.0.6.ebuild b/app-office/abiword/abiword-1.0.6.ebuild
new file mode 100644
index 000000000000..381ad2088d2e
--- /dev/null
+++ b/app-office/abiword/abiword-1.0.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.0.6.ebuild,v 1.1 2003/06/01 06:34:06 lostlogic Exp $
+
+inherit flag-o-matic
+
+replace-flags "-O?" "-O1"
+IUSE="nls build spell jpeg xml2"
+
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Word processor"
+SRC_URI="mirror://sourceforge/abiword/${P}.tar.gz"
+HOMEPAGE="http://www.abisource.com"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="GPL-2"
+SLOT="1"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=dev-libs/libunicode-0.4-r1
+ =x11-libs/gtk+-1.2*
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ spell? ( >=app-text/aspell-0.50.2-r1 )
+ !app-shells/bash-completion"
+
+# gnome build seems broken <foser@gentoo.org>
+# gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+# >=gnome-extra/gal-0.13-r1
+# >=gnome-base/bonobo-1.0.9-r1 )
+
+src_compile() {
+ local myconf
+
+# use gnome \
+# && myconf="${myconf} --with-gnome --enable-gnome"; \
+# export ABI_OPT_BONOBO=1
+
+ use spell \
+ && myconf="${myconf} --with-pspell --disable-static"
+
+ use xml2 \
+ && myconf="${myconf} --with-libxml2" \
+ || myconf="${myconf} --without-libxml2"
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use nls \
+ && myconf="${myconf} --enable-bidi"
+
+ ./autogen.sh
+
+ einfo "Ignore above ERROR as it does not cause build to fail."
+
+ CFLAGS="${CFLAGS} `gdk-pixbuf-config --cflags`"
+
+ # we got enough of the perl problems for now
+ econf ${myconf} --disable-scripting
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ einstall
+
+ dosed "s:${D}::g" /usr/bin/AbiWord
+
+ rm -f ${D}/usr/bin/abiword
+ dosym /usr/bin/AbiWord /usr/bin/abiword
+
+ dodoc BUILD COPYING *.txt, *.TXT
+
+ # Install icon and .desktop for menu entry
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ )
+}
diff --git a/app-office/abiword/files/digest-abiword-1.0.6 b/app-office/abiword/files/digest-abiword-1.0.6
new file mode 100644
index 000000000000..d59fce8ca11e
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.0.6
@@ -0,0 +1 @@
+MD5 a047d528a14c9b343b63784d11cb1676 abiword-1.0.6.tar.gz 16594516