summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-12 13:18:45 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-12 13:18:45 +0000
commit39ce3a5dcaebadd1b27c3a749bcaa7f303010332 (patch)
treed38e4e99dc97af9fc857d4450afdeda5aa2e0af2 /app-pda/iripdb
parentVersion Bump, fix for missing LDFLAGS 335299 (diff)
downloadgentoo-2-39ce3a5dcaebadd1b27c3a749bcaa7f303010332.tar.gz
gentoo-2-39ce3a5dcaebadd1b27c3a749bcaa7f303010332.tar.bz2
gentoo-2-39ce3a5dcaebadd1b27c3a749bcaa7f303010332.zip
Make this respect LDFLAGS, bug #334463 by Diego E. 'Flameeyes' Pettenò. Thanks a lot to Dane Smith for the fix. Make DESCRIPTION shorter to make repoman happier.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/iripdb')
-rw-r--r--app-pda/iripdb/ChangeLog9
-rw-r--r--app-pda/iripdb/iripdb-0.1.3b.ebuild14
2 files changed, 14 insertions, 9 deletions
diff --git a/app-pda/iripdb/ChangeLog b/app-pda/iripdb/ChangeLog
index 6a0047e759e2..f880f302ca9d 100644
--- a/app-pda/iripdb/ChangeLog
+++ b/app-pda/iripdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/iripdb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/ChangeLog,v 1.14 2009/08/13 21:13:07 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/ChangeLog,v 1.15 2010/09/12 13:18:45 pacho Exp $
+
+ 12 Sep 2010; Pacho Ramos <pacho@gentoo.org> iripdb-0.1.3b.ebuild:
+ Make this respect LDFLAGS, bug #334463 by Diego E. 'Flameeyes' Pettenò.
+ Thanks a lot to Dane Smith for the fix. Make DESCRIPTION shorter to make
+ repoman happier.
13 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> iripdb-0.1.3b.ebuild:
Remove filter-flags for GCC 3.3+.
diff --git a/app-pda/iripdb/iripdb-0.1.3b.ebuild b/app-pda/iripdb/iripdb-0.1.3b.ebuild
index 62c3e78e595f..d069e3541ba0 100644
--- a/app-pda/iripdb/iripdb-0.1.3b.ebuild
+++ b/app-pda/iripdb/iripdb-0.1.3b.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/iripdb-0.1.3b.ebuild,v 1.5 2009/08/13 21:13:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/iripdb-0.1.3b.ebuild,v 1.6 2010/09/12 13:18:44 pacho Exp $
inherit eutils toolchain-funcs
MY_P=${P/iripdb/iRipDB}
S=${WORKDIR}/${PN}
-DESCRIPTION="iRipDB allows generating the DB files necessary for the iRiver iHP-1xx series of MP3/Ogg HD Player on Linux and Windows."
+DESCRIPTION="iRipDB allows generating the DB files necessary for the iRiver iHP-1xx series of MP3/Ogg HD Players."
HOMEPAGE="http://www.fataltourist.com/iripdb/"
SRC_URI="http://www.fataltourist.com/iripdb/${MY_P}.zip"
@@ -24,11 +24,11 @@ DEPEND="${RDEPEND}
src_compile() {
echo "$(tc-getCXX) ${CXXFLAGS} -c -o main.o main.cpp"
$(tc-getCXX) ${CXXFLAGS} -c -o main.o -I/usr/include/taglib main.cpp
- echo "$(tc-getCC) ${CFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++"
- $(tc-getCC) ${CFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++
}
src_install() {
- dobin iripdb
- dodoc AUTHORS README doc/iRivDB_structure
+ dobin iripdb || die
+ dodoc AUTHORS README doc/iRivDB_structure || die
}