summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-13 21:13:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-13 21:13:07 +0000
commitd1a75fd9209e864a99d619fed9b913e482e36ff3 (patch)
tree83022d9a3a10d6ebfbfca2dc0fdde189dc0d4e6f /app-pda/iripdb
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-d1a75fd9209e864a99d619fed9b913e482e36ff3.tar.gz
gentoo-2-d1a75fd9209e864a99d619fed9b913e482e36ff3.tar.bz2
gentoo-2-d1a75fd9209e864a99d619fed9b913e482e36ff3.zip
Remove filter-flags for GCC 3.3+.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/iripdb')
-rw-r--r--app-pda/iripdb/ChangeLog7
-rw-r--r--app-pda/iripdb/iripdb-0.1.3b.ebuild27
2 files changed, 10 insertions, 24 deletions
diff --git a/app-pda/iripdb/ChangeLog b/app-pda/iripdb/ChangeLog
index 0dde12c3e7f0..6a0047e759e2 100644
--- a/app-pda/iripdb/ChangeLog
+++ b/app-pda/iripdb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-pda/iripdb
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/ChangeLog,v 1.13 2008/04/21 17:00:18 phreak Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/ChangeLog,v 1.14 2009/08/13 21:13:07 ssuominen Exp $
+
+ 13 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> iripdb-0.1.3b.ebuild:
+ Remove filter-flags for GCC 3.3+.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-pda/iripdb/iripdb-0.1.3b.ebuild b/app-pda/iripdb/iripdb-0.1.3b.ebuild
index 0fa1cc7b7bb6..62c3e78e595f 100644
--- a/app-pda/iripdb/iripdb-0.1.3b.ebuild
+++ b/app-pda/iripdb/iripdb-0.1.3b.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/iripdb-0.1.3b.ebuild,v 1.4 2007/07/15 05:41:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/iripdb-0.1.3b.ebuild,v 1.5 2009/08/13 21:13:07 ssuominen Exp $
-inherit eutils flag-o-matic toolchain-funcs
+inherit eutils toolchain-funcs
MY_P=${P/iripdb/iRipDB}
S=${WORKDIR}/${PN}
@@ -10,34 +10,17 @@ S=${WORKDIR}/${PN}
DESCRIPTION="iRipDB allows generating the DB files necessary for the iRiver iHP-1xx series of MP3/Ogg HD Player on Linux and Windows."
HOMEPAGE="http://www.fataltourist.com/iripdb/"
SRC_URI="http://www.fataltourist.com/iripdb/${MY_P}.zip"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
-
IUSE=""
+
RDEPEND="media-libs/taglib
sys-libs/zlib"
-
DEPEND="${RDEPEND}
app-arch/unzip"
-pkg_setup() {
- if test_version_info 3.3
- then
- einfo "Using gcc 3.3*"
- # gcc 3.3 doesn't support certain 3.4.1 options,
- # as well as having less specific -march options
- replace-flags -march=pentium-m -march=pentium3
- filter-flags -march=k8
- filter-flags -march=athlon64
- filter-flags -march=opteron
- strip-unsupported-flags
- elif test_version_info 3.4
- then
- einfo "Using gcc 3.4*"
- fi
-}
-
src_compile() {
echo "$(tc-getCXX) ${CXXFLAGS} -c -o main.o main.cpp"
$(tc-getCXX) ${CXXFLAGS} -c -o main.o -I/usr/include/taglib main.cpp