summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-02-12 20:59:31 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-02-12 20:59:31 +0000
commitccc468be244ebc34503061fea124ebe9c0d7dfac (patch)
tree589afc5d43d63d3a435d7dda5ac0a9a879d21e74 /app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.21.ebuild
parent- version bump. Make sure we do not strip objects before installing them. por... (diff)
downloadgentoo-2-ccc468be244ebc34503061fea124ebe9c0d7dfac.tar.gz
gentoo-2-ccc468be244ebc34503061fea124ebe9c0d7dfac.tar.bz2
gentoo-2-ccc468be244ebc34503061fea124ebe9c0d7dfac.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.21.ebuild')
-rw-r--r--app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.21.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.21.ebuild b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.21.ebuild
new file mode 100644
index 000000000000..d2d8425c5068
--- /dev/null
+++ b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.21.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.21.ebuild,v 1.1 2007/02/12 20:59:31 peper Exp $
+
+inherit eutils
+
+DESCRIPTION="OpenSync IrMC plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="bluetooth irda"
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=dev-libs/openobex-1.0
+ bluetooth? ( net-wireless/bluez-libs )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use irda && ! use bluetooth; then
+ eerror "${CATEGORY}/${P} without support for bluetooth nor irda is unusable."
+ einfo "Please enable \"bluetooth\" or/and \"irda\" USE flags."
+ die "Please enable \"bluetoot\" or/and \"irda\" USE flags."
+ fi
+
+ if use bluetooth && ! built_with_use dev-libs/openobex bluetooth; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but dev-libs/openobex was built without"
+ eerror "the \"bluetooth\" USE flag."
+ einfo "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ fi
+
+ if use irda && ! built_with_use dev-libs/openobex irda; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"irda\""
+ eerror "USE flag, but dev-libs/openobex was built without"
+ eerror "the \"irda\" USE flag."
+ einfo "Please rebuild dev-libs/openobex with \"irda\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"irda\" USE flag."
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable irda) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+}