summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-11-15 22:31:27 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-11-15 22:31:27 +0000
commit57cc275d5a5aff9714617d577dfb9c4550e3fde4 (patch)
treec8c73e3feec7bb86c3b1f55e29fbda3eaf3cfbc7 /app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild
parentVersion bump. Sync live ebuild. Clean up old revisions. (diff)
downloadgentoo-2-57cc275d5a5aff9714617d577dfb9c4550e3fde4.tar.gz
gentoo-2-57cc275d5a5aff9714617d577dfb9c4550e3fde4.tar.bz2
gentoo-2-57cc275d5a5aff9714617d577dfb9c4550e3fde4.zip
Version bump. Restrict tests in 0.39. Clean up 0.36 due to removed libsyncml-0.4.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild')
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild
new file mode 100644
index 000000000000..b96218463a69
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild,v 1.1 2009/11/15 22:31:27 eva Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSync SyncML Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="http +obex"
+
+RDEPEND="=app-pda/libopensync-${PV}*
+ dev-libs/glib:2
+ dev-libs/libxml2
+ >=app-pda/libsyncml-0.5.0[obex?,http?]"
+DEPEND="${RDEPEND}"
+
+# FIXME: % tests passed, 2 tests failed out of 2
+RESTRICT="test"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+}
+
+src_configure() {
+ DOCS="AUTHORS"
+
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)"
+
+ cmake-utils_src_configure
+}