summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-27 13:57:36 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-27 13:57:36 +0000
commit05960dfd7ed219b3c4339accacffea4cc135bdf0 (patch)
tree82b17630ca1368ef5b6a68b675d001e5f84c1fdf /app-pda
parentRevert/reapply -r1.171{3,4}, since that commit was made by someone (diff)
downloadgentoo-2-05960dfd7ed219b3c4339accacffea4cc135bdf0.tar.gz
gentoo-2-05960dfd7ed219b3c4339accacffea4cc135bdf0.tar.bz2
gentoo-2-05960dfd7ed219b3c4339accacffea4cc135bdf0.zip
Fix for gcc-4.3 bug #227269.
(Portage version: 2.2_rc3/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/ChangeLog7
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.11.8-gcc43.patch12
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild7
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8.ebuild6
4 files changed, 27 insertions, 5 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index c245cc44d13f..4c7c0edab391 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/pilot-link
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.41 2008/05/15 14:36:00 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.42 2008/07/27 13:57:36 loki_val Exp $
+
+ 27 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/pilot-link-0.11.8-gcc43.patch, pilot-link-0.11.8.ebuild,
+ pilot-link-0.11.8-r1.ebuild:
+ Fix for gcc-4.3 bug #227269.
15 May 2008; Markus Rothe <corsair@gentoo.org> pilot-link-0.12.3.ebuild:
Stable on ppc64; bug #221063
diff --git a/app-pda/pilot-link/files/pilot-link-0.11.8-gcc43.patch b/app-pda/pilot-link/files/pilot-link-0.11.8-gcc43.patch
new file mode 100644
index 000000000000..255e732e3aa1
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.11.8-gcc43.patch
@@ -0,0 +1,12 @@
+diff -aur src.old/ccexample.cc src/ccexample.cc
+--- src.old/ccexample.cc 2008-07-11 23:06:47.000000000 +0200
++++ src/ccexample.cc 2008-07-11 23:07:13.000000000 +0200
+@@ -2,7 +2,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-#include <iostream.h>
++#include <iostream>
+ using namespace std;
+
+ #include <unistd.h>
diff --git a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
index e72881b943e9..3c2b40a53e64 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.20 2007/10/07 17:15:16 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.21 2008/07/27 13:57:36 loki_val Exp $
inherit perl-module eutils
@@ -42,6 +42,9 @@ src_unpack() {
# fixes bug 162209
epatch "${FILESDIR}/${P}-missing-include.patch"
+ # bug 227269
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+
# bug #62873
cd "${S}/libpisock"; epatch "${FILESDIR}/${P}-netsync.patch"
}
diff --git a/app-pda/pilot-link/pilot-link-0.11.8.ebuild b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
index 1094c31f7888..c8f7797faa08 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.17 2007/10/07 17:15:16 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.18 2008/07/27 13:57:36 loki_val Exp $
inherit perl-module eutils
@@ -23,7 +23,9 @@ DEPEND="sys-libs/ncurses
src_unpack() {
unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}/${P}-java_install_all.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
}
src_compile() {