summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-28 09:44:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-28 09:44:42 +0000
commit93e380cd5e681459e784a7fc1f4561ded7e77a73 (patch)
tree8c0f2d45d44e417870849cc4176d0c70fb9b6e4c /app-pda
parentBump version to 0.8.1. Added Gentoo specyfic (GSoC 2010) ifnet plugin by Qiao Mu (diff)
downloadgentoo-2-93e380cd5e681459e784a7fc1f4561ded7e77a73.tar.gz
gentoo-2-93e380cd5e681459e784a7fc1f4561ded7e77a73.tar.bz2
gentoo-2-93e380cd5e681459e784a7fc1f4561ded7e77a73.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/synce-libsynce/ChangeLog10
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.15.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/app-pda/synce-libsynce/ChangeLog b/app-pda/synce-libsynce/ChangeLog
index e34a775505ba..75dc8a4ad515 100644
--- a/app-pda/synce-libsynce/ChangeLog
+++ b/app-pda/synce-libsynce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-libsynce
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/ChangeLog,v 1.29 2009/08/06 12:24:25 mescalinum Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/ChangeLog,v 1.30 2010/07/28 09:44:42 ssuominen Exp $
+
+*synce-libsynce-0.15 (28 Jul 2010)
+
+ 28 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +synce-libsynce-0.15.ebuild:
+ Version bump.
*synce-libsynce-0.14 (06 Aug 2009)
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.15.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.15.ebuild
new file mode 100644
index 000000000000..65924b28949f
--- /dev/null
+++ b/app-pda/synce-libsynce/synce-libsynce-0.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.15.ebuild,v 1.1 2010/07/28 09:44:42 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="SynCE - common library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/libsynce-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus static-libs"
+
+RDEPEND=">=dev-libs/check-0.9
+ dbus? ( >=dev-libs/dbus-glib-0.60 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/libsynce-${PV}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ --enable-dccm-file-support \
+ $(use_enable dbus odccm-support) \
+ --disable-hal-support
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+ find "${D}" -name '*.la' -delete
+}