summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-23 08:46:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-23 08:46:39 +0000
commita613a7152cf54386cd5e2b4e1fabd4ef56f4df00 (patch)
treedfd2b26df9ef44821a66dcbc786b1415596584a8 /app-pda
parentStable for sparc, wrt bug #458122 (diff)
downloadgentoo-2-a613a7152cf54386cd5e2b4e1fabd4ef56f4df00.tar.gz
gentoo-2-a613a7152cf54386cd5e2b4e1fabd4ef56f4df00.tar.bz2
gentoo-2-a613a7152cf54386cd5e2b4e1fabd4ef56f4df00.zip
Add patch to avoid multi-byte characters from being stripped
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libimobiledevice/ChangeLog10
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch27
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild57
3 files changed, 93 insertions, 1 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index fd74e23d84a4..2912267a11e2 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-pda/libimobiledevice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.40 2013/02/02 22:23:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.41 2013/02/23 08:46:39 ssuominen Exp $
+
+*libimobiledevice-1.1.4-r4 (23 Feb 2013)
+
+ 23 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +libimobiledevice-1.1.4-r4.ebuild,
+ +files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-ch
+ aract.patch:
+ Add patch to avoid multi-byte characters from being stripped
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org>
libimobiledevice-1.1.4-r2.ebuild:
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch
new file mode 100644
index 000000000000..7711839bb0a7
--- /dev/null
+++ b/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-property_list_service-do-not-strip-non-ASCII-charact.patch
@@ -0,0 +1,27 @@
+From 060e3f2683ed2b0b08e1a31deb9608a99e193b4a Mon Sep 17 00:00:00 2001
+From: Christophe Fergeau <teuf@gnome.org>
+Date: Tue, 26 Jun 2012 00:03:30 +0200
+Subject: [PATCH] property_list_service: do not strip non-ASCII characters from
+ XML plists
+
+'content' is declared as char content[] so if char is signed, all characters with the high bit set will be negative so they will be < 0x20. This means the code will strip all non-ASCII (multi-byte) UTF-8 characters and replace them with spaces. This commit fixes it now by really only considering ASCII characters.
+---
+ src/property_list_service.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/property_list_service.c b/src/property_list_service.c
+index 8634864..c9a8edf 100644
+--- a/src/property_list_service.c
++++ b/src/property_list_service.c
+@@ -250,7 +250,7 @@ static property_list_service_error_t internal_plist_receive_timeout(property_lis
+ } else {
+ /* iOS 4.3+ hack: plist data might contain invalid characters, thus we convert those to spaces */
+ for (bytes = 0; bytes < pktlen-1; bytes++) {
+- if ((content[bytes] < 0x20) && (content[bytes] != 0x09) && (content[bytes] != 0x0a) && (content[bytes] != 0x0d))
++ if ((content[bytes] >= 0) && (content[bytes] < 0x20) && (content[bytes] != 0x09) && (content[bytes] != 0x0a) && (content[bytes] != 0x0d))
+ content[bytes] = 0x20;
+ }
+ plist_from_xml(content, pktlen, plist);
+--
+1.8.1.2
+
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild
new file mode 100644
index 000000000000..81111436faf1
--- /dev/null
+++ b/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.4-r4.ebuild,v 1.1 2013/02/23 08:46:39 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gnutls"
+
+RDEPEND=">=app-pda/libplist-1.8-r1
+ >=app-pda/usbmuxd-1.0.8
+ gnutls? (
+ dev-libs/libgcrypt
+ >=dev-libs/libtasn1-1.1
+ >=net-libs/gnutls-2.2.0
+ )
+ !gnutls? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-openssl.patch \
+ "${FILESDIR}"/${P}-HOME-segfault.patch \
+ "${FILESDIR}"/${P}-property_list_service-do-not-strip-non-ASCII-charact.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ # Disable python support wrt #451044, look at -1.1.4-r2
+ # from Attic if you need to restore it.
+
+ local myconf
+ use gnutls && myconf='--disable-openssl'
+
+ econf \
+ --disable-static \
+ --without-cython \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dohtml docs/html/*
+
+ prune_libtool_files --all
+}