summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-02-04 09:18:43 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-02-04 09:18:43 +0000
commit0fa7ff6f3a7ac4cba49b76e692e0fbac618c89bb (patch)
treef393f88cc781cc5f105cc1961990f15a86e45805 /app-portage
parentreadd config file (diff)
downloadgentoo-2-0fa7ff6f3a7ac4cba49b76e692e0fbac618c89bb.tar.gz
gentoo-2-0fa7ff6f3a7ac4cba49b76e692e0fbac618c89bb.tar.bz2
gentoo-2-0fa7ff6f3a7ac4cba49b76e692e0fbac618c89bb.zip
rework fix for segfault, thanks Michał Kiedrowicz <esqualante AT o2 DOT pl> for providing the better fix; split up fixes for two separate bugs in two separate patches; add Vi like movement keys; clean old revision
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elogv/ChangeLog13
-rw-r--r--app-portage/elogv/elogv-0.6.1-r2.ebuild (renamed from app-portage/elogv/elogv-0.6.1-r1.ebuild)7
-rw-r--r--app-portage/elogv/files/elogv-0.6.1-refresh_screen.patch24
-rw-r--r--app-portage/elogv/files/elogv-0.6.1-segfault_delete.patch22
-rw-r--r--app-portage/elogv/files/elogv-0.6.1-vi_movement.patch30
5 files changed, 77 insertions, 19 deletions
diff --git a/app-portage/elogv/ChangeLog b/app-portage/elogv/ChangeLog
index e8872526b03d..031caafc2b13 100644
--- a/app-portage/elogv/ChangeLog
+++ b/app-portage/elogv/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-portage/elogv
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/elogv/ChangeLog,v 1.26 2008/02/02 16:22:47 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/elogv/ChangeLog,v 1.27 2008/02/04 09:18:42 opfer Exp $
+
+*elogv-0.6.1-r2 (04 Feb 2008)
+
+ 04 Feb 2008; Christian Faulhammer <opfer@gentoo.org>
+ files/elogv-0.6.1-refresh_screen.patch,
+ +files/elogv-0.6.1-segfault_delete.patch,
+ +files/elogv-0.6.1-vi_movement.patch, -elogv-0.6.1-r1.ebuild,
+ +elogv-0.6.1-r2.ebuild:
+ rework fix for segfault, thanks Michał Kiedrowicz <esqualante AT o2 DOT pl>
+ for providing the better fix; split up fixes for two separate bugs in two
+ separate patches; add Vi like movement keys; clean old revision
*elogv-0.6.1-r1 (02 Feb 2008)
diff --git a/app-portage/elogv/elogv-0.6.1-r1.ebuild b/app-portage/elogv/elogv-0.6.1-r2.ebuild
index f62b64d3aaa3..9d84cda26639 100644
--- a/app-portage/elogv/elogv-0.6.1-r1.ebuild
+++ b/app-portage/elogv/elogv-0.6.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/elogv/elogv-0.6.1-r1.ebuild,v 1.1 2008/02/02 16:22:47 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/elogv/elogv-0.6.1-r2.ebuild,v 1.1 2008/02/04 09:18:42 opfer Exp $
inherit eutils
@@ -29,7 +29,12 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ # bug 195429
+ epatch "${FILESDIR}/${P}-segfault_delete.patch"
+ # bug 208524
epatch "${FILESDIR}/${P}-refresh_screen.patch"
+ # on user request
+ epatch "${FILESDIR}/${P}-vi_movement.patch"
}
src_compile() {
einfo "Nothing to compile"
diff --git a/app-portage/elogv/files/elogv-0.6.1-refresh_screen.patch b/app-portage/elogv/files/elogv-0.6.1-refresh_screen.patch
index 4784c0c98b49..a6863292295e 100644
--- a/app-portage/elogv/files/elogv-0.6.1-refresh_screen.patch
+++ b/app-portage/elogv/files/elogv-0.6.1-refresh_screen.patch
@@ -1,31 +1,21 @@
---- elogv.py 2007-09-16 20:32:52.000000000 +0200
-+++ elogv 2008-02-02 17:17:45.000000000 +0100
-@@ -129,13 +129,16 @@
+--- elogv.py.orig 2008-02-04 10:14:58.000000000 +0100
++++ elogv.py 2008-02-04 10:15:48.000000000 +0100
+@@ -129,12 +129,18 @@
elif c == ord("a"):
self.sort_method[0] = "alphabetical"
+ self.init_screen()
++ self.show_log()
elif c == ord("t"):
self.sort_method[0] = "date"
+ self.init_screen()
++ self.show_log()
elif c == ord("r"):
self.sort_method[1] = not self.sort_method[1]
--
+ self.init_screen()
-+
++ self.show_log()
+
elif c == ord(" "):
# Now is used only for scrolling the text
- self.show_log()
-@@ -171,7 +174,9 @@
- self.remove_file(n)
- self.file_pad.clear()
- self.fill_file_pad()
-- self.refresh_file_pad()
-+ self.change_usel(-1)
-+ self.change_usel(+1)
-+ self.init_screen()
-
- elif c == ord("/"):
- word = ""
diff --git a/app-portage/elogv/files/elogv-0.6.1-segfault_delete.patch b/app-portage/elogv/files/elogv-0.6.1-segfault_delete.patch
new file mode 100644
index 000000000000..51c81022be8d
--- /dev/null
+++ b/app-portage/elogv/files/elogv-0.6.1-segfault_delete.patch
@@ -0,0 +1,22 @@
+--- elogv.py.orig 2008-02-04 10:10:40.000000000 +0100
++++ elogv.py 2008-02-04 10:12:01.000000000 +0100
+@@ -172,6 +172,7 @@
+ self.file_pad.clear()
+ self.fill_file_pad()
+ self.refresh_file_pad()
++ self.show_log()
+
+ elif c == ord("/"):
+ word = ""
+@@ -274,6 +275,11 @@
+ # so this will prevent a crash
+ if self.usel >= len(self.file_list):
+ self.usel = len(self.file_list)-1
++ # We also have to update self.pposy
++ if self.pposy > self.usel:
++ self.pposy = self.usel - 10
++ if self.pposy < 0:
++ self.pposy = 0
+
+ # Sort the list
+ if self.sort_method[0] == "alphabetical":
diff --git a/app-portage/elogv/files/elogv-0.6.1-vi_movement.patch b/app-portage/elogv/files/elogv-0.6.1-vi_movement.patch
new file mode 100644
index 000000000000..cfa49b7e1021
--- /dev/null
+++ b/app-portage/elogv/files/elogv-0.6.1-vi_movement.patch
@@ -0,0 +1,30 @@
+--- elogv.py.orig 2008-02-04 09:56:41.000000000 +0100
++++ elogv.py 2008-02-04 10:03:16.000000000 +0100
+@@ -33,10 +33,10 @@
+ Elogv is a portage elog viewer based on curses and python,
+ you can use these keys to control the behavior of the program:
+
+- - Down arrow -> Scroll the list of files down by 1 unit
+- - Up arrow -> opposite of Down arrow
+- - Pag Down -> Scroll the list down by 10 unit
+- - Pag Up -> opposite of Pag Down
++ - Down arrow or k -> Scroll the list of files down by 1 unit
++ - Up arrow or j -> opposite of Down arrow
++ - PageDown -> Scroll the list down by 10 unit
++ - PageUp -> opposite of Pag Down
+ - End -> Go to the last file of the list
+ - Home -> Go to the first file of the list
+ - t -> order the list of files by date, most recent on top
+@@ -108,10 +108,10 @@
+ sys.exit()
+
+ ## Scrolling keys ##
+- elif c == curses.KEY_DOWN:
++ elif c == curses.KEY_DOWN or c == ord("k"):
+ self.change_usel(1)
+
+- elif c == curses.KEY_UP:
++ elif c == curses.KEY_UP or c == ord("j"):
+ self.change_usel(-1)
+
+ elif c == curses.KEY_NPAGE: