summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-08 23:02:16 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-08 23:02:16 +0000
commit685d6cb67fd2b912d8ab45ab37a5383cb1471356 (patch)
tree3efe245638b85cf3251b5939856b811d1294d703 /app-portage
parentVersion bump. Brings bugfixes for Python 3 support and environment file sourc... (diff)
downloadgentoo-2-685d6cb67fd2b912d8ab45ab37a5383cb1471356.tar.gz
gentoo-2-685d6cb67fd2b912d8ab45ab37a5383cb1471356.tar.bz2
gentoo-2-685d6cb67fd2b912d8ab45ab37a5383cb1471356.zip
Introduce the initial release version of my Python maintenance utilities.
(Portage version: 2.2.0_alpha195/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gpyutils/ChangeLog8
-rw-r--r--app-portage/gpyutils/gpyutils-0.1.ebuild19
-rw-r--r--app-portage/gpyutils/gpyutils-9999.ebuild6
3 files changed, 29 insertions, 4 deletions
diff --git a/app-portage/gpyutils/ChangeLog b/app-portage/gpyutils/ChangeLog
index 030722f2ed85..0c03e2026ad0 100644
--- a/app-portage/gpyutils/ChangeLog
+++ b/app-portage/gpyutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/gpyutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/ChangeLog,v 1.2 2013/08/05 15:50:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/ChangeLog,v 1.3 2013/08/08 23:02:16 mgorny Exp $
+
+*gpyutils-0.1 (08 Aug 2013)
+
+ 08 Aug 2013; Michał Górny <mgorny@gentoo.org> +gpyutils-0.1.ebuild,
+ gpyutils-9999.ebuild:
+ Introduce the initial release version of my Python maintenance utilities.
05 Aug 2013; Michał Górny <mgorny@gentoo.org> gpyutils-9999.ebuild:
Add missing PYTHON_USEDEP.
diff --git a/app-portage/gpyutils/gpyutils-0.1.ebuild b/app-portage/gpyutils/gpyutils-0.1.ebuild
new file mode 100644
index 000000000000..028d97b615a8
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/gpyutils-0.1.ebuild,v 1.1 2013/08/08 23:02:15 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://bitbucket.org/mgorny/gpyutils/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.9[${PYTHON_USEDEP}]"
diff --git a/app-portage/gpyutils/gpyutils-9999.ebuild b/app-portage/gpyutils/gpyutils-9999.ebuild
index 47300b712e5f..9d546098072e 100644
--- a/app-portage/gpyutils/gpyutils-9999.ebuild
+++ b/app-portage/gpyutils/gpyutils-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/gpyutils-9999.ebuild,v 1.2 2013/08/05 15:50:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/gpyutils-9999.ebuild,v 1.3 2013/08/08 23:02:16 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
@@ -21,9 +21,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=app-portage/gentoopm-0.2.8[${PYTHON_USEDEP}]"
-
+RDEPEND=">=app-portage/gentoopm-0.2.9[${PYTHON_USEDEP}]"
#if LIVE
+
KEYWORDS=
SRC_URI=
#endif