summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-02 10:22:37 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-02 10:22:37 +0000
commit829f62cf678cd7b7045ab539b42812ec81f62228 (patch)
tree0f675e80ff2805643dc75c0519a58e77cb2d098c /app-portage
parenttest phase returned in working order; fixes bug #423483 (diff)
downloadgentoo-2-829f62cf678cd7b7045ab539b42812ec81f62228.tar.gz
gentoo-2-829f62cf678cd7b7045ab539b42812ec81f62228.tar.bz2
gentoo-2-829f62cf678cd7b7045ab539b42812ec81f62228.zip
Version bump. The new version fixes SIGCHLD restore issue when used as a portage set, bug #440904.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog9
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.2.5.ebuild32
2 files changed, 40 insertions, 1 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
index 982e04e16b75..3d77b47cf6e4 100644
--- a/app-portage/smart-live-rebuild/ChangeLog
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/smart-live-rebuild
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.41 2012/10/31 18:02:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.42 2012/11/02 10:22:37 mgorny Exp $
+
+*smart-live-rebuild-1.2.5 (02 Nov 2012)
+
+ 02 Nov 2012; Michał Górny <mgorny@gentoo.org>
+ +smart-live-rebuild-1.2.5.ebuild:
+ Version bump. The new version fixes SIGCHLD restore issue when used as a
+ portage set, bug #440904.
*smart-live-rebuild-1.2.4 (31 Oct 2012)
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.5.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.5.ebuild
new file mode 100644
index 000000000000..b7546f9a7f93
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.5.ebuild,v 1.1 2012/11/02 10:22:37 mgorny Exp $
+
+EAPI=4
+PYTHON_COMPAT=(python2_6 python2_7 python3_1 python3_2)
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://bitbucket.org/mgorny/smart-live-rebuild/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf
+}